English

Can't Flash LineageOS

Flashing LineageOS in TWRP fails with an error:

Can't install this package on top of incompatible data. Please try another package or run a factory reset.
Updater process ended with ERROR: 7
Error installing zip file `/sdcard/Download/lineage-14.120170626-UNOFFICIAL-FP@.zip'
Updating partition details...
...done

Here is what I did:

Any tips on what to do now?

Edit: looks like I am doing rubber duck debugging here on you all. Sorry about that…

I should have done a factory reset first. Now it works.
I hope my mistake helps other people in the future stuck in the same place. :slight_smile:

2 Likes

If you come from FP Open, don’t do anything with the migration zip, but follow the instructions under “When coming from any other OS”:

You need to backup and factory reset in stead.

Sorry, didn’t read your last 2 sentences. Glad you made it work :slight_smile:

This topic was automatically closed after 183 days. New replies are no longer allowed.