Cant access FP2 directories from Win7

Well I’m pretty stucked with this : i cant access to FP2 directories when connecting to a win7 PC.
FP2 is under android 6. I first connect the FP2, and the driver seems to have been well intalled.
Then I swipe down and choose MTP transfer. Then I can access only SD card, not FP2 : I tried the same way without the SD card, and there’s still no directory available on FP2 on windows explorer.
Pretty stucked, cause I have to save photos and music before sending FP2 for repair…
Does anyone have any idea what the problem is ?

1 Like

Thanks for your help !
I tried both solutions, unfortunately none of them worked.

I reinstalled the MTP driver, but it didnt change anything.

I downloaded and tried to installed media package, but couldn’t, I guess it’s because I have a win7 version, not a win7N.

I experience nearly the same on my FP2 (with LineageOS) but I can only see the internal storage (maybe it is similar to your problem):

Do you have configured your SD-card to be used as “internal storage” and not as “portable storage”? I think this option was introduced with Android 6. You can determine if the SD-card is used as such by going to Settings -> Storage and see if it says “Internal shared storage” as first entry.

Hope you find a solution, be careful and don’t reformat. If you use the FPOOS you could boot into TWRP recovery, plug USB in and check if the internal storage is shown now.

Thanks for your help Fschwab,
In fact I can read the directories of the sd card, this is only the directories from fp2 that I cant read - more precisely no directory appear.

I had a similar problem after updating from Android 5.1 to 6 and then to LineageOS. Linux and Win 7 werent able to copy files to the phone.
The simple solution for me was to format the SD Card with the current OS and then it worked. Maybe it helps.

_Chris gave me the relevant hint in post number 24.

So you can see the internal memory as a separate folder in MTP, but when you open it, no files appear?
If that’s the case, you could try:

  • checking whether keeping the phone unlocked helps (though IIRC this is more an issue in earlier Android versions)
  • clearing data (and cache) for “external storage” and “media storage” (somewhere under Settings > Apps). Then reboot phone and wait for device to be indexed again (depends on how many files you have). Though you’d think this would mainly affect SD card contents, I’ve heard reports of it solving issues with internal storage as well.

I have the problem, that my FP2 doesn’t give me the choice to mount through USB anymore.

The problem definatly lies with the FP2, since the same cable can connect another device through USB to my computer.

I am not sure if I ask this question on the right topic. The suggested solutions do not seem to apply.

Does anyone have a tip?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.