Can not go back from fairphone Open to Fairphone OS

I received my FP 2 a few days ago and spent some time toying with it in the “native” Fairphone OS. Then I switched to Fairphone Open and continued toying with it.
Now I would like to go back to the Fairphone OS (and probably switch OS a few more times before making a decision; but that is out-of-topic). The method 1 (using the built in updater) on this page is not working (the updater tries to update the open OS to open OS, not to fairphone OS).

I do not consider myself an advanced user. I installed some free applications from various sources. I did not root the device. The most avanced action I performed was a reset to factory settings.
So before trying method 2 ( Manually installing the OTA package), I would like to know: is it risky? or maybe if it fails, I will just be sent back to my current situation? or something else can solve my problem?

Any advice is welcome… I do not care if I loose some data (as long as I do not break the device), but I am not willing to spend too many hours doing something I do not understand.

You can just download the Going Back OTA Switcher (last download on this site) and open it with the updater, or - if that doesn’t work - open it with TWRP (#dic:recoverymode).

Thanks a lot for your answer. I opened the ota switcher with the updater, but now the phone has lost its display.

I think it started properly (I could see some some scripts on the screen), but failed to finish.

Now I have a totally black screen whatever I do.
I tried the recovery mode (power + volume up), I can feel the vibration, but the screen remains black.
Removing and replacing the battery has not effect.

Anything else I can try ?

Try to disassemble the screen and clean the connectors.

I just cleaned the screen connectors. After reassembling, still not working.
Maybe I should send a request to the support ?

I could solve my problem this morning by manually installing the OS, with the info on this page:

I was a bit worried to do this, but that was not complicated.

I am back to the fairphone OS, and display is working.

I have the same problem as @Baengsang (black screen) but manual install doesn’t work.
The flashscript on Ubuntu hangs, last echo I get is “Validation complete.” and then…nothing happens. The device is recognized, because “sudo fastboot devices” returns “fb77f672 fastboot”.
What can I do to force the script to continue?

Is there no one out there to help me? I have no Mac or Windows to test the other scripts :frowning:

Perhaps some helpful community member near you does?

Or are there even Fairphone Angels in your area? -> #fairphoneangels

Problem solved: the unix script must be run as root.
It wood be good to change the Manual Install guide accordingly. I am much obliged to #fairphoneangels, esp. @explit :clap:


@explit unfortunately is no #fairphoneangels:frowning: But good that you two could solve the issue! :slight_smile:

Just for the record: If you are talking about Google Apps … you can easily install those additionally to Fairphone Open OS or LineageOS. Open GApps is your friend, you can install the ZIP file of your choice using the TWRP recovery (press Volume Up when starting or rebooting the phone).


Or you can simply install YALP Store from F-Droid.


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.