Fairphone OS 17.07.6 (Android 6.0)

How about trying a reset of the cache and data of the camera app?

I get “System partition has unexpected content” error (Error 7) when trying to upgrade from 1.13.0.
There was a hint in one of the previous topics to re-apply 1.13.0 before upgrading to the current version, but I can’t find this option in Fairphone updater, even in advanced mode.
Any suggestions?

I just tried that - Open “Settings -> Apps”, delete Data & Cache of Open Camera, Camera MX and the built-in Android “Camera”-App. Still, only Camera MX can disable it’s Shutter sound, for Pictures only - Video still plays both start and stop sound.

I tried to find some changelogs in the code of FP Open on how the Update in April last Year accomplished the disabling of the sounds, but I didn’t succeed.

Funny thing: If I reboot, the Screenshot-Sound is silent in silent mode, Shutter and Video is not. After disabling and re-enabling Silent-Mode, all sounds play.

Anyway - I will try a complete reflash this evening, last time I only did a factory reset. If I find time I can check the logs first, but I doubt I am able to spot anything there…

1 Like

Ok. I downloaded the manual installation package, booted to fastboot, flashed the device, wiped Data, Cache etc. in Recovery and flashed again. I even tried Ubuntu Touch in between, so by now everything should be overwritten…

I then went though the initialization, got nagged by Google for resetting my device but still, only screenshots are silent in silent mode and only directly after booting, the camera is not. It’s an all-new FP2 experience now :wink:

I will try FPOpen next…

Is disabling the camera sound somehow regulated by e.g. the country the SIM card is from? I remember to read some weird stuff… I do happen to have a Japanese sim card at the moment…

I think I read something about this, too.

What if you remove the SIM card, enable flight mode and disable location, so that the phone doesn’t know any more, where you are? Does this change the behaviour?


Jep - just had to wait for the Phone to install (and the night to pass…). Indeed, as soon as I put the Japanese SIM card in, silent mode literally doesn’t exist any more. Mystery 1 solved, bonus points when someone figures out why it worked prior to factory-reset and updates.

For now, shall the endless power of root help me “scan” documents in office without disturbing everyone :wink:


I am trying to move from FP Open to FP OS (newest update) and followed the description here: https://support.fairphone.com/hc/en-us/articles/207914363-Manually-install-Fairphone-OS-for-the-Fairphone-2

Unfortunately, this didn’t work as planned. It is successful but when the phone reboots, it still has WiFi saved and it says that a lot of apps (that I had installed previously) stopped. I’d like to hard reset the phone but it seems not to work.

btw: Recovery mode seems not to work either. It only displays an android logo with a red x. Fastboot works.

Any ideas?

Edit: I was able to fix it by manually loading an older FP OS to the phone with bootloader, image by image. I think something on the recovery and/or the user data was corrupt… In the end I updated a couple times with the updater app

I’m having the same problems as you Victor. Lots of apps keep stopping with:

Unfortunately [app name] has stopped.

Anyone have any ideas what might be causing this?

You’re trying to move from fp open to fp OS?

Updated today (after making a backup). As always since Android 6 I had to do the manual installation (as described in the support article), even though I hadn’t

  • rooted the phone
  • changed the recovery
  • disabled any Google apps
  • modified the system partition in any way (as far as I can judge).

since the update to 17.06.04, which was also a full manual install.

Before doing the manual update I tried using the Update app

  • with the phone connected to a charger
  • with the phone connected to a charger and battery > 80%
  • with battery > 80% but phone not connected to a charger
  • without having updated any Google apps since installing 17.06.04
  • after updating all Google apps to the current version.

The result was always the same: dead android with message “Error”.

I can handle this, however I miss the uncomplicated updates from Android 5. I have to invest 2-3 hours every month to install the monthly (security) update since Android 6. To be very honest: this kind of sucks. Sorry for ranting…
But still would be grateful for any ideas what the issue might be.

1 Like

Have you ever gone into recovery mode when seeing “dead Android”? There you can find more details/a reason for the “error”.

No, not yet. Will try next time. Thanks for the hint!

1 Like

Eh, no sorry. I just meant I was having the same problem as you on this bit:

This problem persisted and I found the only solution was to uninstall and reinstall any of the apps that were stopping. Unfortunately, and bizarrely, the only one I haven’t been able to reinstall is Netflix. Having uninstalled it, Google Play Store no longer seems to be aware of the app existing (i.e. it doesn’t show when I search “netflix”). I believe this is normally when an app is not supported by your device/OS.

Anyone else unable to install or use Netflix?

1 Like

I guess your phone is rooted? The Netflix app can’t be downloaded from Play Store on rooted devices. But you can still get it from Yalp Store.


Aha, yes it is! Though I had sort of forgotten because I rooted it when Fairphone OS was still based on Android 5.x.

Wow, I did not realise they had done that. Just caught up via this story.

So yes, thank you very much. I’ve now successfully installed Netflix via the Yalp Store. Also thank you for introducing me to the Yalp Store! I didn’t know about this and would be much happier not installing Open GApps. I think I’ll just stick with Yalp next time I flash my device. :slight_smile:


… at the theoretical risk of getting your Google account banned for violation of the Terms Of Service, so perhaps don’t use an awfully important Google account for that :slight_smile: .


Eh, I didn’t think about that. Good advice! :slight_smile:

1 Like

Fairphone OS 17.08.1 is now available.