Camera shutter delay

There is almost a 1s delay between hitting the shutter button and the photo taking on my FP4. Does anyone else experience this?

This is especially annoying when trying to take a group shot and some smug b*std says “ugh just take it on an iPhone” grr… !

2 Likes

Hi and welcome. Which operating system in which version (settings-about the phone-build number) and Camera App do you use?

Fairphone OS version FP4.FP40.A.142.20220628 (Android 11) - July 11, 2022
Just the stock camera app that comes with the phone.

Thanks :slight_smile:

So you have the recent update that has some Camera improvements. So was it the same before the update? Do you use HDR mode? Else I cant test as I dont own a FP4, however I’m sure someone else will comment.

Same here since a few weeks. On e/OS/ build e_FP4-userdebug 11 RQ3A.211001.001 eng.root.20220628.065528 dev-keys

I’ve tested it with HDR on and off and it doesn’t make a difference - good thinking though!

No change since the update - I notice the video is a little more stable now, I suspect that might have been in the update as it was hella shaky before.

2 Likes

That sounds similar

Do you use an SD card? You can test another App, like Open Camera or a Gcam Port

It’s writing to internal memory not the SD card.

Thanks for the suggestion, I tried Open Camera but the performance is the same. I think its the processing time to adjust the autofocus and light settings because if I’m moving around or there is movement in the scene the delay is longer.

I think I just have to accept that the Fairphone camera is not as good as other flagships in the market, which concurs with online reviews of the phone. It’s a shame that as per usual the ‘Green’ option comes with sacrifices :man_shrugging:

1 Like

To say nothing of “Fair”. Inevitably (?) true in today’s world but let’s not start an off-topic discussion here :wink:
Do feel free to look around the forum, you’ll find other topics where you can discuss this …

1 Like

I notice this too, but only irregular. I think it has to do with loading stuff into memory. Sometimes the camera stutters for a brief moment when starting.

1 Like

I experienced the same and switched back to my iPhone since the camera system is way much better. As a fresh dad valuable memories get lost when the camera does not respond at the second you need it to.

2 Likes

I have the same with my FP4.
Not just with photo’s, the same with video.
Super annoying when you want to send a happy birthday message from your kid to grandparents “…py birthday opaaaaaaa”

Stock app, no HDR, SD+internal memory combined, but the SD card is more than fast enough.

I’ve also had the same, that I wanted to capture a moment, but the FP4 fought me and the moment passed before I could snap a picture. But to be honest, it hasn’t happened for a while now. The auto focus has improved as well. The only thing that bothers me is that the camera starts with the last used camera. So now that the camera loads fast, sometimes it loads the camera in selfie mode. The Pixel phones always started with the back camera and it was easy to quickly switch, you just had to wiggle the phone. Not saying that Pixels are the best… Just sharing a comparison that even though my impression is that things have improved with the FP camera, there are sometimes still hurdles to overcome in these in the moment situations :slight_smile:

I have the same problem. Disabling HDR doesn’t help, it’s still slow. The only thing that helps is switching to Pro mode and lowering the shutter speed. GCam works absolutely fine and manages to take the photo as quickly as it always did. I think they must have messed something up in the last update.

Same here. Instant photo with Gcam, 1 second delay with native app.

1 Like

I looked at GCam but couldn’t easily work out which version to use. Also concerned as its open source it might be buggy or risk security problems…

Please see here

Gcam is not open source as far as I know, so far I have nevertheless not heard about security issues

Not all versions work the same on all devices, so yes some might be buggy on the FP4 or become buggy with updates, however then you can just try another version

1 Like

Strange, mine works instant. Just checked outdoors. Maybe it’s indoors mostly? If so, I didn’t really notice it.

Edit: Just tested indoors, it’s slightly slower in certain conditions. I think it has to do with low light conditions. If it improves quality, it’s a trade off I can live with. But if it can be improved, it would be great.

1 Like

Ah right it’s ported, not open source. Even more likelihood of bugs / incompatabilities then. For me it’s not worth the effort going through versions, installing, debugging etc. I think I’ll just live with it until Fairphone notice and fix it.
Thanks though :slight_smile: