Camera says SD card full

I’ve tried clearing cache as the previous topic suggested, and my phone has over 10GB of storage left, however I still keep getting this message.

I guess it‘s the same problem as handeled here: Camera not working after update
SD card formatted as internal memory.

I have never used an SD card with my FP3

Can you just fill in a few details? I take it you’re also on the latest version of FPOS?
Which camera app are you using?

Even if you have over 10Gb free I would recommend emptying the bin and app cache as per the thread you cited?

Thank you both for the suggestions.

I cleared the camera app’s cache and app data and that resolved the issue.

1 Like

And why are you referring to a discussion with the topic ‚SD card is full‘ :confused: ?

I must say I think it’s very sloppy that error messages speak of “SD card” when they mean internal memory. Leads to endless confusion.


Problem with android rather than FP if I’m correct. But to answer your earlier questions I am on build 8901.3.A.0129.20210805. I use the default camera app. I’ve tried to find the bin but I don’t seem to have that option? Google Photos is my default viewer so if its in the gallery that may be why I’m not seeing a burger menu.

In Google Photos open the app and choose Library. That gives access to the Bin.


It miraculously started working again for no reason but thanks, I’ll try that next time it plays up.


So its occurred a few times in the last week. Every time I’ve flushed the bin in Google Photos to no avail. Any suggestions?

My only suggestion is to use an SD card, ensure you format it as portable and move whatever you can there, and set what ever apps you can to use the SD as storage.

I only use 17GB of my 64GB memory.

Thats not ideal. Understood if I was running low but as I said I have over 10GB. Any ideas for alternative camera apps that don’t require anything complex?


Clear camera Cache etc.

Check what may be working in the background

Start in safe mode to check apps

Reset, once you copied personal data off the phone.

Open Camera and probably also another Gallery instead of google photos like the Gallery form Simple tools

1 Like

Sorry I don’t understand what I’m supposed to do? I downloaded Simple Tools’ Gallery but the bin is already empty?

You asked for alternative Apps and Open Camera plus another Gallery was my recommendation. The bin within the Gallery app for sure is empty as long as no picture was deleted within the APP. Do the issues still persist when using othet Apps?

The problem is is I can’t access the default gallery - the popup blocks all buttons. I’ve downloaded Open Camera and that is able to take photos successfully.

A gallery normally is not the storage but just an app showing the storage and I would say at the end, Google Photos also is just a Gallery app with few more features than others. So bedside the Google Photos App there is another Gallery pre-installed on the FP3 or is Google Photos the default Gallery? Did you clear the cache and storage (this should normally not touch your pictures but is referring to e.g. password/logincredentials) of Gallery Apps? Have you tried to deactivate preinsgalled Gallery Apps and instead use another app like the simple. Can you explain what you are exactly/step by step doing when the error Pops up.Sorry if I misunderstood something and asking a lot.

At the end you would not need any gallery app at all you could also access your pictures via the data manager app.

I have had my FP3 since last summer and the camera has worked fine, albeit very slow at times. Recently I been nearly unable to take photos, showing the same error as mentioned in this thread. However I have plenty of space left, more than 35 GB (I have used 55%), and still the camera insists there is no space. Something is very wrong here - I have removed so many photos cache, bins and apps to be able to take 1 or 2 photos (!), that it can’t have to do with actual space left, but some sort of miscalculation error somewhere. Could it be related to a recent update of the system?

Welcome to the Fairphone community.

Do you use a SD card in your FP3? The thread opener doesn’t, but your calculations (35GB left with 55% used) point to more than 64GB.