Camera not working after update

Yesterday I installed the latest update, but after that my camera is not working anymore. The problems I experience are:
-for photos: I can take photos, but I cannot view them afterwards (screen is black and keeps loading). They also do not appear on GooglePhotos anymore
-for videos: from the moment I switch to the video recording option, it is like it automatically starts recording and immediately stops again…and this keeps repeating itself.

I have already rebooted the FP, and cleared the data for the camera app…but nothing solved this issue so far.

Could I get some help how to fix this, or otherwise how to undo this update?

many thanks!

1 Like

Welcome to the Fairphone community.

Do you use a SD card in your phone? Is it formated as internal memory? Problems like this start when using an internal SD card, not from the beginning, but sometimes later.


thanks for the fast reply.
Yes I am using an internal SD card. I indeed swapped it with a new one (with a larger storage capacity) last week, but it is only since yesterday afternoon that I am experiencing problems (that is why I thought it was caused by the update).
How can this issue with the SD card be solved?

How did you do the swap?
Just to be sure, the card is really installed as ‘internal’ and not ‘portable’ memory?

1 Like

I took the first one out and added the new one. After restarting the FP asked to format the card to be able to use it, which I did. I think that is all that I had to do…
How can I see of it is internal or portable?

In settings->storage.
If you have choosen the first option in the format menu, it’s an internal memory. But how did you migrate the data from one card to the other?

In the storage settings I see two items: (1) internal shared storage & (2) Samung SD card.
I copied the data from the original SD-card to the new one via my laptop. But since I formatted the SD card when first using it, I assumed that this data was deleted…or is this not the case when you format it?

There is a German thread that addresses the same issue:

OpenCamera should work fine, but using another app is just a workaround, of course…

(2) is labeled ‘PORTABLE STORAGE’? and shows an eject button?

If the card was accessible when inserted in the PC, it was formated as portable storage.

1 Like

This is how it looks like in FP, properties of the storage:

The card was formatted when I inserted it in the FP, not on the laptop.
Would it work if I deleted everything from the SD card and formatted it again?

I meant, if the old card was readable in the PC, it was formated in the FP3 as portable. When formated as internal, it is encrypted and only usable in the phone.

It should work, if you choose ‘Formatteren as draagbaar’ in the open menu on the picture. As far as I understand, there schould be a requester afterwards, whether you want to migrate all internal data back to the phone before the formating starts. At least it was reported in a thread dealing with the same problem.


So just to be sure: I get the following message:

So I should select ‘gebruiken als draagbare opslag’, which is the portable option?


I guess ‚draagbaar‘ is the dutch translation for ‚portable‘ :wink:.


Great, it works now… Thanks a lot for the fast reply’s!



Hi, my camera is doing exactly the same after I inserted an SD card as internal. Should it be portable then?

Yes, portable is the safe option.

1 Like

Thanks. I was going to change it back to portable, as you suggested, but although it shows about 2/3 of it full, I can’t back up as when I go into look at the files and apps, it says it’s empty.

It did take 45 minutes to move everything across so it must have done something. Now I can’t see photos either place ( though they’re backed up on Google).

Now worried about apps and messages it might be holding, even though it says it doesn’t

I can’t even screenshot as it claims to have no memory for that. ( Though both card and phone are only half full)

So is the SD card now formatted as portable or still internal?

1 Like

Am trying to back up first, but Im away from home and have a slow internet connection. Will update tomorrow to say if switching to portable worked. Thanks!