Camera not working FP 3+

Hi there,
I recently got my new FP 3+ and i am super unhappy with it. Despite the really hidden privacy settings, a super slow performance in general and a not good working touchscreen my camera isn’t working at all.
When I take pictures all that comes out are black images. In my Telegram and WhatsApp Messenger it wont even let me download or send images. I already reset the phone once, afterwards it worked for two days, then the same fault started again.
Someone had this trouble before and has a solution? Thanks very much in advance.

1 Like

Hello Sunshine, and welcome to the community.

It seems you have several uncommon issues with your phone, that are not acceptable.
Have you tried to contact support? Unlessed you’d have damaged your phone, your issues would definitely be covered by the warranty.

What you could do beforehand would be to unmount and remount your phone, especially the screen and camera modules, since there could be a loose connection. Of course, this will not void your warranty, if done properly: be careful with the connectors.

Could you elaborate on these please? What do you mean by hidden privacy settings? How slow? When doing what? What happens with the touchscreen?


Unfortunately if your prior experience is a modern mid/high end smartphone, I believe this is true. :frowning:

The processor is the mid-range Snapdragon 632. What would you expect?


Found a solution: you are not allowed to format the Mirco SD as internal memory.


Now the next problem occured: after charing it doesn’t turn on any more. Just the blue point appear and nothing happens… Do you know a solution for that problem by chance :wink: ? I am unable to use it at all at the moment… Really expensive experiment this phone.

Did you do the following?

Because if you didn’t, your filesystem will be all screwed up and a factory reset may be in order. This is one of the reasons it’s discouraged to set the SD as internal storage - not so much an FP thing, more an unfortunate quirk in Android.

1 Like

I did a reset to factory settings.

When did the problem pop up? Was it right after the reset, or did it boot for a while and then stop?

I rebooted it two weeks ago. Then all worked and now I can’t turn it in again. I tried to reboot it today, but this didn’t even work out, because it hangs at “wipping” data.

So did you do the hard reset after you changed the SD card from internal storage to portable storage, or before? If before, you’ll have to do it again.

If it’s no longer possible to do a factory reset, a full reflash of the operating system may be in order (you’ll also have to unlock the bootloader).

I did it before I undid the internal memory… Oh man you mean I now have to download android 10 on my computer, unlock the booster and then reinstall it? Isn’t it dangerous for.malware.then?
Thanks very much for your help.

Yeah, it sucks that you have to do all this stuff - but it looks as though the whole SD card thing broke your operating system to the point that a hard reset won’t work anymore.

The unlocking of the bootloader is safe. After unlocking, you can install the operating system after downloading it straight off Fairphone’s website, and if you want you can relock the bootloader afterward.

It’s all on those pages I linked - it’s a bit fiddly but it isn’t that difficult to do. Please have a look at the process, and if you like, we can guide you through the process step by step.