English

Camera is not storing pictures after ugrade to Android 10

Since the upgrade to android 10 and installing the new camera modules (both front and back) the made pictures will sometimes not be saved on the phone. The whole screen seems to be frozen at that moment. When I go then to the main screen and again to the camera and make a picture it will store it normaly.

1 Like

Same here, but with the older modules… It’s quite annoying…

I have this too, also slow motion video doesn’t work, the image freezes while it appears to be taking the video, then when you stop recording nothing appears in the preview circle and the photo gallery shows a 0 length video that display an error when you try to play it.

Same here with the old modules. Problem only occures while taking the first image. The second photo is stored correctly.

Yes, and in fact, since I updated to Android 10, the “Photos” application (from Google, the one with FP3 by default) also works worse: deletion is much slower, and sometimes it does not delete selected photos properly (especially when you want to delete batches of photos or videos), or takes a long time. I hope they will fix it with some update…

Same problem here.

Steven

I am using OpenPhoto and OpenCamera in Android 10 FP3. I am almost sure that the update has written new pathes. It works correctly with Google Fotos but not with the other applications. I think that the Apps have to be corrected according to new Android 10 changes.

I just cleared the storage on the camera app and I think it’s fixed it, slow motion is definitely fixed.

5 Likes

Similar issue here, but only with photos taken with the rear camera. After rebooting phone it is now storing photos again. Prior to reboot, the following was observed:

  • any app using the rear camera (within WhatsApp, default camera, OpenCamera) would either not store the photo or crash/ get stuck in the attempt of doing so.
  • videos recorded with rear camera were fine
  • photos taken with front camera were fine
  • changing storage location internal or SD card made no difference
  • trying to record slomo videos would immediately let the default camera app crash

I should mention that I have recently had to replace the display due to water damage. However, this camera problem doesn’t feel like a HW issue to me and I had also successfully taken a photo after installing the new display before it started showing the storage issue.
Due to the water damage, a few more components (sensors; gyro, ambient light, proximity) have failed. I am yet to figure out where the failed components reside and replace the affected modules accordingly in a next step (unless it’s the core).

System config: FP3, Android 10, new display after water damage.

Welcome to our community forum. :slight_smile:

Can you tell how your SD card is formatted? Is it part of your internal storage (“phone storage”) or is it formatted externally (“mobile storage” or “portable storage”)? SD cards formatted internally often cause problems with saving photos.

1 Like

Wow, that was quick. Thanks :slight_smile: To be honest, I wasn’t even aware the SD card could be formatted to be part of the phone’s internal storage. I checked the memory settings and it says “mobile storage” which I guess is the default setting. In the camera app I currently have “SD card” selected as storage location but I had the same issue when “Phone” was selected.

1 Like

There’s no real default setting but there is an option to format as internal or external when inserting a new SD card. My SD card already had data so it was clear I wanted to keep it as external but often people go with the first on the list which is extending the phone memory i.e. internal.

That is the starting point of many issues like yours and more. It also seems more of an issue with Android 10 than some earlier versions ??

2 Likes

I bought a new SD card especially to fix this problem. The SD card is faster than my old one and says specifically that it suitable as Android memory (Sandisk). It’s configured as portable storage. But unfortunately, I still have the same problem :sob:

Your first post infers it isn’t a camera module issue, your most recent that ‘still have the same problem’, but your never clarified the problem.

Could you provide detail?

Got a new FP3+ a feew weeks ago and also bought a sandisk SD card. i configured the SD card as internal storage.
among other apps, i installed a weather and map app (meteoswiss and swisstopo)…apparently both were installed on the SD card.
after a few days of normal usage (all the apps working perfectly fine), the weather and map app couldn’t establish an internet connection anymore (map app didnt show maps anymore and weather app didnt fetch new weather data). i assumed its an internet stability issue. i also tried to reinstall both apps several times and restarting the device, but nothing helped…
moreover, the internal camera app stopped working; it could shoot photos, but it didnt manage to save them properly (only grey photos were appearing in google photos). thus i downladed the open camera app, which worked fine for a couple of days, but then same phenomena; after each shot it told me “error while saving photo” (or something very similar like this).

Luckily, i found this post, which let me reconfigure the SD card to external…and all the abive mentioned issues were gone, at least until now (fingers crossed!).

4 Likes