CalyxOS (is coming to) is here for FP4!

I could have a memory leak since the 4.6.1 update as battery life is poorer. It might have been due to the update itself, but overnight it lost from 65% to 7%.
For the 1st time today it was running red hot at one point. Running a battery monitor to see what processes are running but wondering if anyone else having the same issue??

1 Like

once? or all nights?

FP of my partner is working OK and like before the update.

Ive removed gphotos preview apk and gcam and things seem better. Battery held its charge better so will monitor it.

I need your help guys. I am on CalyxOS atm and I need to sell my phone, therefore I want to go back to stock before putting it on ebay etc. Is there a safe way to do so? bootloader is locked. Thanks a lot!

  • Install the latest (outdated) FPOS factory images (don’t lock the bootloader)

  • Update the phone to the current OTA

  • Just to be safe restore OEM unlocking (I’ll upload a current patched boot.img later)

  • Reboot to the bootloader, lock critical partitions fastboot flashing lock_critical

  • Check fastboot flashing get_unlock_ability
    If you get: (bootloader) get_unlock_ability: 0
    Don’t Lock it, otherwise you will brick your phone.

    Only when you get: (bootloader) get_unlock_ability: 1

  • Lock it fastboot flashing lock

  • Perform a factory reset through recovery

Edit: Allright, here is the FPOS-B.065-magisk-boot.img (completely forgot that the kernel page is up to date for once, you wouldn’t have had to wait)


Thanks a lot - unfortunately, my unlock ability is 0 - so what can I do to lock it? I don’t get you workaround with magisk

EDIT: HA! it worked - thank you so much!! I altered this guide from you:

Hirnsushi, you are an ancient god!!


Not really a Fairphone question but…

There’s something slightly curious with CalyxOS: the features page says the browser is “Chromium based on Bromite”.

Firstly, that makes no sense: Bromite is based on Chromium, not the other way round.

Secondly, the only browser installed in a vanilla CalyxOS install is the vanilla Chromium as far as I can tell - i.e.

Anyway, no biggie. I installed Bromite separately. But I’m a bit confused by all this. Does anybody know if Calyx is confused or something?

I have no idea about the rest of your post, but I would recommend against installing Bromite. It is very behind on updates

Last update was in december

1 Like

Yes I know. I’m okay with that. Bromite is more privacy-oriented than Vanadium and I only visit a handful of very trustworthy sites on my cellphone. My threat model leaves room for lower security and I value privacy more.

Bromite has 196 known security issues and hasn’t been updated since December 12th of 2022.
Please use another browser, see my comparison table: Browsers - DivestOS Mobile

Note the forked version of Bromite included in CalyxOS is up to date:


CalyxOS does not come with Mulch,or any other fork of Chromium. It’s running plain jane Chromium.

As for Divested’s browser comparison, I’m well aware of it. Here’s why I run Bromite:

  • I’m not running Firefox or any fork of it. Firefox is riddled with bugs and UI annoyances that make it unbearable within a New York minute. I’d love to avoid Chromium as I try to stay clear away from anything Google, even if it’s open-source. I would like to run Mull instead, but Mozilla really tries its hardest to make its browser infuriating. If I didn’t know they have a knack for doing everything wrong, I’d swear they work for Google.

  • Webview-based browsers are essentially unusable.

  • Brave is a fake privacy-oriented browser: it’s just a different advertising company.

  • All the other Chromium-based browsers apart from Bromite leave to be desired privacy-wise and use proprietary bits.

That leaves Bromite. It’s not up to date but it’s the least bad option in my opinion, and the security risk is acceptable considering that, again, I only visit a select few trusted websites.

No, CalyxOS forked from Bromite: build · android13 · CalyxOS / platform_external_calyx_chromium · GitLab

If you’re on CalyxOS there is ZERO reason to use the old, outdated, and insecure Bromite.

The Chromium that comes with CalyxOS is different from Google Chrome. It is heavily modified to prioritize privacy, and is based on Bromite, a privacy focused browser with ad blocking and many anti-tracking privacy enhancements.


Okay I took a closer look: I dumped the Chromium APK that came with CalyxOS and inspected it: I did find Calyx’ certificate, and a couple of reource files containing the string “bromite”,

So yeah, it does look like it’s a patched Chromium.

But here’s the thing: Calyx hasn’t modified it in any visible way. It’s still called Chromium, it still has the stock Chromium icon, and worse, it’s still called It’s really not very pro: it’s confusing as hell, and it means if you ever install the real, it will silently overwrite the patched Calyx version.

Helluva dirty patch job if you ask me. They should have made it a proper fork.

Now that I could confirm it for myself, indeed you’re correct. Thank you for taking the time to convince me to take a second look :slight_smile: I’m a bit of a bonehead sometimes and I need a little help :slight_smile:

1 Like

Not possible, Android won’t let apps with differing signing keys replace them.


Hmm yes true.

So what happens when the namespace clashes?

The install just gets blocked.
CalyxOS should adjust that, but it can be difficult to do after the fact without loss of user’s data.

Well, personally I guess it’s fine as long as I know it’s not the stock Chromium. It’s just that it looks like it in every respect, and I tend to be anal enough about the software I run to throw a wobbler over trivial stuff like this. Especially when the stuff I read before installing it doesn’t seem to match what I see.

Recently installed CalyxOS on my FP4. Thought I would give a wee run-down of how it went.

I installed it on NixOS, so I was glad for the instructions provided, the only bit that wasn’t clear to me was that shell.nix was just a text file one creates.

The installation process was super simple with their flashing script they have.
It was not super clear, after stage 5 and 6 that one should remove the USB-cable and reboot into fastboot every time it stalls out, which is fairly frequent to begin with.
Then it runs super well by itself and within a short period of time, you’re rebooting into Calyx.

Starting was pretty good with many apps pre-optioned for install/removal. Once you’re in, it feels like any degoogled device.

Good setup, I think!


There’s apparently a Bromite fork called Cromite. You may want to check it out. It’s made by one of the Bromite developers.