CalyxOS (is coming to) is here for FP4!

Hey there,

just checked out the latest update’s ChangeLog (CalyxOS 4.3.1), and saw this:

FP4: Make wide-angle camera available to third party apps (OpenCamera, Google Camera, amongst others)

I’ve got the OTA update installed, but couldn’t notice a difference at first glance using nikita NGCam 8.2 v1.8

does anyone have a clue how to test this ?

At least with the stable Nikita (and Greatness) version I tried, I had to enable AUX camera #2 in the settings, have you tried that? :thinking:
It’s under Settings → Advanced → Auxiliary camera → switch 1st and 2nd lens to on.

Other GCam versions, like BSG (I use) and Wichaya, seem to pick it up automatically.

1 Like

alright, thanks!

it works with nikita when enabling auxiliary lenses (also tried with BSG 8.1 and indeed it works by default in this case), however the refresh rate seems much slower than with the main lens, is it expected ?

We’ve had some discussion about that in another thread, seems like an issue with GCam in low-light situations. It’s working fine if the environment is well lit.
There might be a setting in GCam that needs to be changed :thinking:

It’s working without issues in OpenCamera, so it seems to be GCam specific. You might want to switch to OC in the meantime, if you often use it in low-light conditions.

hi there, I just bought a FP4 last week and was playing with /e/ and CalyxOS. I managed to install both easily. Right now I am running CalyxOS 4.3.0. It works quite well but it seems I have some problems with notifications on some apps downloaded from Aurora.

Did you disable microG when installing Calyx? :thinking:
If you didn’t, have you enabled Cloud Messaging in the microG settings and do the apps you have problems with show up in that list?

I don’t think I have disabled it when installing, at least it’s definitely installed now with everything set on it seems. Thank you for the suggestion.
I do receive notifications on some apps (like ProtonMail) but it doesn’t seem to be as responsive as before when I was on a Pixel phone, but I need to confirm this with more usage, I still have some messaging app to install or check with bank app notification when making a payment (i.e. Revolut Bank). But in general I am quite impressed how well it works, amazing to have a 5G ready ethical phone without Gmaps or GDrive pre installed for Christmas!

1 Like

After more days of usage, I can say CalyxOS + FP4 works greatly. I think the problem with notifications was a mix of apps being updated (maybe normal updates, or bug, or to support Android13 since it’s now being deployed on many phones see here) + the fact I use pi-hole ( at home, which does block a lot of things.

Fairphone should really partnership with Calyx as they did with /e/, it’s a shame they still haven’t updated to Android 12 while CalyxOS fully supports Android 13.


Anyone tested the Camera with CalyxOS 4.5.1 again? In the changelog I see a switch to the Lineage OS Aperture. Does it support all the lenses and with full resolution?

Will test on my own in some minutes (currently updating), but maybe you can share your experience?

It supports both lenses but not the 48mpx mode, and doesn’t seem like it’s making use of the TOF sensor in any capacity.
As a general photo app it works fine, way better than the previous one and I was able to get rid of my QR-Scanner app now, but it’s no match for GCam, obviously. Not yet at least :smirk:


hello humans. thank you for the treasure trove of information posted above. almost to much for my brain to opticalsmosis all at one time.
combining what i see here and over on the rooted instructions )very scary instructions btw( is there any way to get rid of bad apps in calyos on my pf4 outside of rooting? or i have no choice i must root to use the phone?

Welcome to the community :wave:

Do you mean apps shipped with Calyx? Which ones did you have in mind? :thinking:

You can just disable most of them, and CalyxOS doesn’t come with many included apps anyway.
But if you want to block the systems access to them (not remove them, mind you), you’ll be taking the Magisk route.

copy magisk. rooted caly it is.
is it possible to root, clean off, uninstall magisk, unroot and lock the boot loader back again?
hm. really there are to many to list.
if you think of barebones minimalist you will get the idea.
if the phone does not need the app to make a phonecall or rout through mulvad vpn then the app should not be on the phone.

all deeds can be accomplished through librewolf having no problems and no issues about being rooted.
apps are intended for surveillance and privacy circumvention.
websites are easily manipulated. use the website instead of the app. always. no discussion.

the most unforgivable one i can think of is device companion manager.
that should never be on any phone at any time for any reason.
but there are to many in caly to list here.

If you want to completely rip out system apps (and I mean remove them), Magisk won’t suffice, you’ll have to build it yourself.

Check out the instructions to do that here:

No, you can’t lock the bootloader if you mess with system partitions, that will change their hashes and ensuring those stay the same is the whole point of locking it.


sincerely grateful for your response. thank you for sharing your wisdom

Running A12 FPOS which is currently rooted and looking to finally migrate over to vanilla calyx OS and lock bootloader. Looking for saving SMS/MMS and WhatsApp messages. Would like to backup apps but probably not possible. Came from LOS20 to FPOS12 now to finally finish with CalyxOS so should be fine to lock. Will check with ability check but understand CalyxOS does this anyway. Anything else I need to be aware of. Thanks

for SMS/MMS backups/restore you might want to try this app: SMS Import / Export | F-Droid - Free and Open Source Android App Repository

it also does call logs (and contacts as an experimental feature, but personally I prefer using vcf import/export directly from the AOSP contacts app), no root and no cloud required


Good little program that missed it searching on fdroid. Thanks for that :+1:

Just to add I’ve fully migrated over to CalyxOS and also successfully locked the bootloader. The only warning I get on boot is that the OS installed is different to what was installed originally. Otherwise banking app’s with the exception of Nationwide Building Society which hangs at the loading spinning circle and proceeds no further.


that’s normal and singnalling that you run verified boot

1 Like