Calls stuck on speakerphone after Android 11 update

#contactsupport -
After my FP3 updated to Android 11, all calls only use speakerphone. If sound is set to “Phone” the sound comes through speakerphone.

This includes calls from regular phone app and other apps. Inbound calls and outbound calls.

I can only make a private call with bluetooth headphones.

I saw online that OnePlus 7 had the same issue but the settings on FP3 are different so unable to use the suggested solutions.

2 Likes

Hi and welcome to the forum.

By the way the hash link you provide can be used by you to make an official complaint maybe for warranty but it is ineffective here. :slight_smile:

As this is not a comon issue it is likely to do with your setup.

  • Do you use an SD card and how is it formated?
  • Have you tried a ‘Safe start’ to rule out app conflicts
  • Have you switched the phone off completely, removed the battery, remove and replace the SIM only, then the battery and start the phone again and see if it helps.

A problem being that if you contact support, as well as the above possibilities you are almost ceratin to be asked to do a factory reset which will wipe all your data like you are a new user - drastic measure :frowning:

2 Likes

Welcome to the forum and just a comment to avoid misunderstanding: using the support tag does not mean you contact support, this is a user forum only.

2 Likes

At least three people reported this in the main A11 update thread but I haven’t yet seen a fix. This may be a case for a factory reset so make sure you have backed up your phone.

4 Likes

Thank you for responding.

  • Yes, there’s an SD card, FAT32. I’ve powered on with noSD. There’s no change
  • Tried Safe Mode, it’s the same
  • I’ll try with other configs ( just SIM1, just SIM2, both SIMs etc).

I’ll see if I can do the update again. I’ve also seen Android 12 install instructions but worried about bricking the phone.

Never had a problem in 2+ yrs. I already ordered an FP4 on backorder, but was hoping to give this phone to a family member

1 Like

Good to know I’m not alone! :slight_smile:

If the above mentioned factory reset solves it then this should be possible.

1 Like

Found this thread while experiencing the same issue. I’m usually not one to update, this strengthens my resolve.

Welcome to the community forum.

It’s not a simple update, this one upgrades the phone from Android 10 to Android 11. OS upgrades like this are always tricky when done in-place, instead of a new install from scratch. No difference between desktop computers and smartphones there.

1 Like

I’m still running Windows 7 Pro, but that’s beside the point. A factory reset doesn’t fix it, just brings you to a clean slate of Android 11. On to LineageOS it is…

Whatever works.

At least the LineageOS updater doesn’t support OTA upgrades to a new major Android version. So nobody can assume this will just work out fine.

Maybe you could share the ‘solution’ via a link?

How did you do that? I see no option to set Sound to Phone
Settings > Sound

When the call is active, there is a speakerphone soft-toggle. By default it’s disabled. Toggling it has no effect.

1 Like

I’m having the exact same issue on my FP3+ after the Android 11 update. Persists in Safe Mode. Hoping there’s an easier solution than a factory reset! If anyone has found a fix, please do post it.

1 Like

Hej all, strangest issue.

A couple days ago my phone stopped selecting the earpiece for calls. It goes to speaker mode only, whether speaker is selected or not.
test features say I don’t have an earpiece installed, and mic 2 is super quiet. Is this a multiple module failure? Any other way to troubleshoot?

You say test features, you mean by dialling *#*#66#*#* Service tests > Test Single > etc.

Maybe the top module is loose or not working, so maybe remove, see if it’s clean and replace. Then do the tests again.

I think mic 2 is on the top module with the earpiece. Mind you mic 2 is always a quarter that of mic 1

All the best

1 Like

Other cases here:

so if you don’t mind we’ll probably move this thread and merge it.

Not sure yet but a factory reset may solve the problem, so make sure your backups are up to date.

P.S. Edward could you indicate your OS version. You’re probably on Android 11 but it’s as well to know.

Would those of you experiencing this problem (loudspeaker is used for calls instead of the earpiece) mind listing in this thread, all the apps you use to make calls (these could include stock Phone app, Signal, Whatsapp etc.)

Hej, good point… Yes, I am updated to Android 11. These issues coincide with the update a few days ago. I should add that wired headphones work fine. Bluetooth earpieces have not worked well before, I will guess a codec issue that keeps the mic registering very quiet. I have not tested Bluetooth with the new update, and I will.

So far the issue with speakerphone is in both regular calls and with WhatsApp. I haven’t tried in other apps yet.

1 Like

This is a common issue, many people have reported it, including me.