Calls stuck on speakerphone after Android 11 update

There may be other users that had or have this issue but that hardly makes it common. I’d say it’s a rare issue. Out of the nearly 200,000 possible owners (sales figures) I have seen less than 20 which is 1 in 10,000

In fact I can only find 7 or 8 with this problem ??

1 Like

Technical note. In the service tests, what we have been calling “earpiece” (i.e. the low-volume speaker you usually hold to your ear) is denominated “Receiver”. To test it, choose “Receiver Test”.

The “Earphone” test refers to a headset, so you need to plug one in first, or get an error “Did not detect” which I have seen one or two people (@stern.ed for e.g.) report.

1 Like

The OnePlus 7 solution I saw is here Oxygen 11 - Stuck on Speakerphone - OnePlus Community

Settings → System → Accessibility and turned on “Hearing Aid Compatibility”.
This was off but I turned it on and had an incoming call… No bottom speaker!

I didn’t see a Hearing Aid Compatibility setting on FP3

I’ve only used Phone and Whatsapp for calls

2 Likes

Thanks Andrew for posting your info source.
This is useful because it seems that a factory reset is not likely to help, so at the moment I would advise against.

P.S. for those wondering what Oxygen OS is,

OxygenOS is an Android-based OS developed by Chinese smartphone manufacturer OnePlus exclusively for their smartphones.

Source: Wikipedia


QUESTION for those impacted: are you using any call recording software and if so which?

I may have fixed it.

I have an SD card, US SIM card (T-Mobile) and Canada SIM card (Public Mobile/Telus). Before doing any resets, I tried every configuration of SD Card, SIM 1, SIM 2, with no success

  1. Did a factory reset.
  2. Restored my backup and inserted SD card.
  3. Tried the original configuration (SIM1: TMO, SIM2: Public). Still only speakerphone
  4. SIM1: Empty, SIM2: Public; Calls went back to normal! Inbound, outbound, whatsapp, all worked normally.
  5. SIM1: Empty, SIM2: TMO; Calls still normal
  6. SIM1: Public, SIM2: TMO; Calls still normal
  7. Just to replicate, went back to original configuration (SIM1: TMO, SIM2: Public), Speakerphone only again
  8. Went back to #6 configuration (SIM1: Public, SIM2: TMO); Calls went back to normal again.

So I’ll leave it in this configuration. I will update this thread if it anything changes.

6 Likes

Wow, this improved my phone too. I had TMO on sim1 and no sim2. I switched to TMO on sim2 and the calls go to the earpiece like normal. I’ll keep using sim2 for now.

4 Likes

Thank you very much for the tip! I had the same symptom and similar set up. Fairphone 3+ with Mint mobile (a T-mobile mvno) sim in slot one. Moving it to slot two stopped the whole speakerphone problem. Thanks again! ~Scott

4 Likes

Good news!

To sum up, from the experience of Andrew1, kanishka and Scott_Holden the problem was caused by the presence of a SIM from T-Mobile (or MVNO thereof) in slot 1, and is fixed by moving the SIM to slot 2.

@palday @strongthany (who posted in the general update thread) @Fairphonemjm and @stern.ed : does this help for you people too?

Note: this might not be limited to T-Mobile SIMs so I would advise anyone who is experiencing the problem to swap SIM slots.

2 Likes

Well that’s good to know. Not really an actionable solution for me right now because of how much I rely on my SD card and that doesn’t fit in slot 1. But I have a ticket open with Fairphone Support right now to try to get it addressed.

Well call me a goofball, because I thought the FP3 had only 2 slots, one for sim1 or SD, and one for sim2. I moved over the SIM card to slot 2 and now calls function correctly. I’ll update fairphone support to let them know.

3 Likes

@OldRoutard

I’ve had luck just now swapping the T-Mobile sim from slot 1 to slot 2, with my Swedish Vimla sim to slot 1. I tried that a week ago and no joy, and happy for this to work now. Tusen tack!

2 Likes

I feel so relieved since this workaround. Thanks again to the person who discovered this.

Swapping which SIM is in which slot does indeed fix it for me.

However, I’m a little bit disconcerted about what causes this problem on a low-level. :confused:

1 Like