Call quality and noise cancellation (regular calls, handsfree, Signal voice messages, Microsoft Teams video calls)

It’s the first point, she’s got issues with the handsfree microphone.

1 Like

OK so I moved this over to the other topic, I assume Hardware was checked by calling


I don’t think there is a fix, so far many people have the same issue. There were some improvements, but FP hasn’t fixed it.

As a workaround you can use a headset/earbuds, that’s all.

1 Like

same issue here - I’ve also bought a FP4 for my mother and I have a really hard time calling her because she always uses the hands-free mode, which produces really annoying and sometimes even painful (depending on the volume and if I have my earbuds/headset connected) noise when she’s speaking. We’ve also already deactivated the Google app, but it didn’t help at all.

1 Like

Best is to #contactsupport

I have a problem with the sound quality during phone calls with the FP4: Other people complain about the sound quality (underwater-like and sometimes “choppy” sound).

Disabling microphone permissions for Google as suggested in this topic did not help.
Also The microphone test (##2886##) showed that all three microphones worked.
The Software is updated (FP4.FP4G.A.170.20220920)

I have now done the following call tests with fp4 on an iPhone:

  1. phone call from fp4 from within a quiet room with no ambient noise:
    ->sound quality is fine
  2. phone call with fp4 from the same room making irregular noises while speaking (knocking, scratching against cabinet door):
    ->sound quality is choppy, the speaker is barely understandable
  3. phone call with fp4 next to running dishwasher (continuous moderate ambient noise):
    ->sound impaired, muffled, the speaker is barely understandable

(I paid attention to not cover any of the 3 microphones with my hand/fingers.)

The same test with inversed phones worked way better: the speaker was well understandable in all three cases

My guess: ambient noise filtering does not work properly on fp4 (software issue?).
Can anyone confirm/reproduce something similar on his fp4? Can we turn off the noise canceling during calls (as a workaround), or is there even a (real) solution?

Thanks so much and kind regards


Welcome to the community :wave: I’ve moved your post to this existing topic.

As you can tell, you aren’t alone with your problem. If you haven’t already, please #contactsupport so the issue gets assigned a higher priority.

1 Like


I was wondering if anyone is experiencing some bad sounds issues with the F4? I can’t use the speaker or headphones and even without, people complain about the bad quality of my sound… I can hear perfectly the other person on the phone but apparently they don’t

Just to clarify, it’s not related to any poor connection network:)

Hope you can help !



Welcome to the community :wave:

As you can tell from the number of posts in this topic, you’re hardly alone with that issue :see_no_evil:
Please #contactsupport so hopefully this gets resolved at some point :crossed_fingers:

I too have these voice quality issues with my FP4 and I talked about them with my colleagues, two of them also using a FP4. Interesting result: One colleague has the same problem, the other doesn’t. The colleague with the problem and I own the 8GB/256GB variant whereas the colleague with the working phone has the 6GB/128GB version.

Has already been checked if the problem is related to the variant and perhaps it only occurs on the 8GB/256GB model?



I have the 8GB version as well. Do you use the same carrier?

My colleague with the working phone and I with the non-working both use congstar, so this seems to lead nowhere…

I use the 8/256 version with Telefónica in DE and so far no one complaint about bad calling quality…

Does Congstar always use Telekom or do they have contracts with D2 or Telefónica as well?

Congstar is a Telekom brand, so no contracts with other networks.

1 Like

congstar is always Telecom, it is the “cheap branch” of Telecom


Just a guess, try to reset your carrier profile.

Go to Settings → Network & internet → Mobile network → Advanced → Access Point Names. And there click on the 3 dots at the right top and “Reset to default”. Also make sure both of you have the same settings such as 4G Calling and WiFi Calling enabled/disabled.

If you then can still reproduce it, then maybe switch phones and see if it’s still the same. It could be the way you hold the device (blocking a mic) or talking “in a funny way” into the mic which may trigger noise cancellation.

Interesting that you have this “luxury” of doing some fancy troubleshooting. It helps to find the cause faster. Who knows, maybe we can even solve it! If we can find the root cause.

I am using my FP4 with my SIM-card for less then a week now, resetting after such short a time seems rediculous.

I am well aware of the 3 mics - I am not covering any of them (especially on the bottom and the left side) or talk in a strange way.
Here (Seafile-Server der Universitäten und Hochschulen in Rheinland-Pfalz) you can find a sample recording of one of my test calls - does not sound like I am covering a microphone - sounds more like a codec problem or phase cancellation for me.
And it is no fancy troubleshooting at all - I did buy a phone which cannot be used as such in about 50% of my calls. I really like the ideas behind FP and I would appreciate a solution!

For proper support you need to #contactsupport, we’re just like you, a regular user :wink:

I’m just trying to pinpoint the cause here. Having a testing environment that’s as reproducible as possible is key in order to do a root cause analyses. It’s likely a codec issue and perhaps also a noise cancellation problem, that’s also something support told me once. Although, a few weeks later this conclusion was according to them not valid anymore.

If you just want a solution, then it’s best to poke FP support. On this forum we can just share our experiences and try to pin down the problem and find workarounds. And if we find it, we can help FP support to find a fix faster.

Yesterday I have created a support ticket :grinning:

1 Like