Buttons pressed randomly

Hi everyone!
I have a problem with my Fairphone: sometimes the 3 buttons (options, home and return)
are pressed randomly! Withuot i touch nothing…

Another issue: my battery level was at 4 %, then i have switched off my phone and i have plugged in the carger, but at that moment the screen showed that the battery level was 34%.
Any ideas?


Hey! I HAVE THE EXACT SAME PROBLEM! But i didn’t know how to phrase it! So last night I was trying to send a text and the phone just continued typing and adding random letters (usually “h”) and I didn’t even touch the screen. So I would try to erase the words and new ones would pop up (and lots of “h”)…so I was confused and turned it off for a second. When I turned it on again it was gone but it has happened various times to me before that random windows just pop up, open and close (e.g. the internet browser and apps) without me touching the screen at all. I always have to restart in order to get rid of that confusion. This whole crazy independent-screen-thing is very extreme when I try to plug in the charger. I have no idea what that triggers but it gets crazy. Im happy about any kind of feedback.
And thanx Penty for starting the conversation!

Ps. this is the latest fairphone…i literally just got it 3 weeks ago.

This is a known issue - with chargers. (Not the Fairphones fault, that is.) If you can use a charger with ground, you should not see the erratic screen behaviour.

Does either one of you have trouble with the screen without the phone being plugged in for charging? If so, you could try to boot to factory test mode (turn off, press vol down + power), test the touch screen there and see if the test produces erratic results as well.

Oh thats good to know! (This is my first smartphone so I didn’t know this was a common thing to happen).
So the situation I described when it started to type words without me touching the screen actually happened when I wasn’t charging the phone. And it has happened before that some windows started popping up without me touching anything (not as extreme though as when I charge it).
To be honest I didn’t quite understand your suggestion:
"if so, you could try to boot to factory test mode (turn off, press vol down + power), test the touch screen there and see if the test produces erratic results as well."
Could you please explain that again… Im supposed to turn off my phone, then press the volume down and then turn it on again? That doesn’t sound right… sorry, if Im missing the obvious here.
Thanx for your help so far!

Quite exactly. I’ll guide you through it:

How to test your touch screen for abberant behaviour.

  • We will now boot to factory (test) mode:
  • Turn your FP off. (Wait a moment until it is properly turned off.)
  • Press volume down and hold it, then press and hold the power button.
  • The screen turns blue. (Wait.)
  • The screen shows “factory mode”. (Wait)
  • The screen shows a menu with mandarin characters, and (in brackets) the english translation.

In factory mode, you can navigate ONLY with volume down. The power button is going to select. In some (not all) menus, volume up is going to take you one menu back.

  • On we go:
  • Press volume down twice to go to “Item test”.
  • Press power to select “Item test”.
  • Press volume down again to go to “Touch panel”.
  • Press power to select “Touch panel”.
  • Press power to select CTP Test.

You can now test your display. Play with it. Single touches should show single white dots, multitouches should show straight lines between the touched spots, touching the squares in the corners should turn them from red to green.

If you are not charging your device at the moment, and are not being charged with a lot of static electric energy yourself (you should ‘ground’ yourself, e.g. by touching a central heating radiator), and if you can now still reproduce “ghost” touches and other aberrant touch screen behaviour, there is quite probably something wrong with the hardware, and you should contact support.

  • To get out of factory mode from the CTC test:
  • To leave the touch screen test, press volume up.
  • To go back to the “Item Test” menu, press volume up.
  • To go back to the main “Factory mode” menu, press volume up.
  • Press volume down five times to go to “Reboot”.
  • select Reboot by pressing the power button.

Done. Your FP should power up as usual.


As stated above, turning the FP off and on again already fixes the problem.

I have noticed this same behaviour a couple of times as well and thought it might have to do with static electricity as it did seem to change sometimes as i moved my finger above the screen without touching it. But this isn’t behaviour I’ve ever seen on another device. The ungrounded adapter I use for my FP I also used for my previous device and it didn’t cause anything like this on that device.

One characteristic of the FP is it’s metal back cover, and I do think it affects the touchscreen, as I stated here: [quote=“Stefan, post:4, topic:924”]
This happens to me too. I found out when you consciously touch the metal back of your FP, the touchscreen works fine.

Did your previous phone have a metal back cover?

It was an HTC Desire S, which has an aluminium unibody case. And now I have my FP in a FP case, which is not metal.

Hi, I found this guide to the screen test very helpful. Thanks. My result was, that the red squares turned green by themselves. Does this mean hardware malfunction?

Without you touching the display? Sounds like a hardware problem to me. I guess you tried everything else, like removing every type of casing, screen protector, gloves you could have been wearing… ? :wink:

Yes, no touching at all. And in test mode it startet to register touches. So hardware problem!

Send it in for warranty claiming then.

1 Like

Just got the same problem as you. Did you get a warranty claim? What did you have to do?

In response to Stefan’s post (https://forum.fairphone.com/t/touch-screen-activating-by-itself/2626/8?u=doraxp)

I have done a screen test. Red squares turn green without me doing anything at all with the screen or the phone. This happens from the bottom left corner along the middle of the left side. I have done this twice.

I have also performed a factory reset, and a hard reset. The screen is unresponsive, and when it does respond, you see entries made from characters on the left side.

The phone is unusable, basically, after only 3 months. Very dissappointed. I have emailed support, but who knows how long it will take to get a response (with Christmas / New Year break and all), how long it will take to fix, and how much it will cost me - I’d expect a warranty replacement or fix, as I have not handled the phone in any inappropriate way - let alone having to beg other people for a spare phone to use in the meantime - or two, as I have two SIM cards…

I am sorry for the inconvenience!

If this started after the (later postponed) upgrade to 1.8, it could still be, that the issue is solved by a downgrade to 1.6. However,.to be honest, I doubt so… :frowning:

I hope you get a response from support as soon as possible. They are back in office on Monday (29. Dec. 2014).

I doubt it is related to the update, as the problem occurred until after 15 days of the update.

I don’t think the downgrade would help; I can’t even set the phone up for its first use. Let’s see how soon I get a response. Would love to see what response other users had when they encountered the same problem.

I got the same problem. Phone randomly “pressing” screen, only in the right side. Did the screen test and a blur of white lines showed up in the right side with one red square turning green in the lower right side. It is not possible for me to downgrade or do anything at all as the phone keeps accessing apps and activating functions (pressing" whatwever is there to press)
I haven´t updated (as far as I know, so thats not the problem)
What do I do now? send in the phone?
(I have been quite happy with the phone otherwise!)
I hope this can be resolved quickly as i am quite dependent on the little machine…!
Thank you and happy new year!
Asger (Denmark)

Please all contact support, as the community forum cannot help with hardware and warranty related issues.

Ok, just wrote to support. Hope they get back soon, I am slowly realising how dependent I am on my fairphone…

Thank you for you quick reply and happy new year!

1 Like

[Edit by @Stefan: This post was moved from that topic.]

I’ve got a similar issue, however it happened 2 weeks or so after Kola nut was installed on my phone (not straight after). My phone is unusable as a result.

Other users have experienced the issue before the update was released, others have reported it as a result of updating from 1.3 to 1.6, whilst with other users the issue seems to be independent of the updates. There’s been lots of posts describing the issue as associated with charging, although there are also cases of the issue occuring when the phone is not charging, or being held on its metallic case.

See topics titled:
Buttons pressed randomly
Touch screen activating by itself
Phone goes crazy - gets inputs I don’t make
Touchscreen detecting inexistent touches
"Software update Cherry 1.6"
Lower area of touch-screen not registering press
Capacitive buttons and lower part of touch screen not reacting
Random key action
Fairphone got a mind of its own
Several Problems with phone

I have made a list of all users I could find who have reported similar issues on the forum: 30 individuals, and this excludes users who may have directly contacted support. That’s a failure rate of 1 in 2000 (assuming both batches). I’m slightly regretting having purchased the phone to be honest; I’ve been keeping off from buying a new phone since March last year, persevered 6 months with an old and tired phone until I got my FP, and it does that in three months with no impropper use.

I reported the issue 5 days ago and the only response I’ve had so far is whether I’ve installed Kola Nut.

What surprises me is that not many (I’ve only seen @humorkritik post a post-repair update) of the people reporting issues have actually provided any information on how their problems got resolved (i.e. repair, replacement, warranty, how long it took them to get a functioning phone back).