Building LineageOS for FP4

If it’s a kernel module, the source it’s the kernel itself. In that case: link


Reporting back in case other people were interested.
@eudaldgr thanks for your very clear instructions.

After some struggle I realized one step was missing which was actually saving deconfig:

make menuconfig

I was required to run:

make savedefconfig


mv defconfig arch/arm64/configs/


I builded LineageOS-18.1 + microG + stock FPCamera succesfully :tada: (I’m trying poshul pull requests 1, 2).

Built and signed the build with the lineageos4microg docker image.
Following the instructions given by @Error :heart_eyes:.
Here you can find my proprietary blobs + FPCamera. All extracted from device, no iode things.

I can launch the “pro”, “video” and “selfie” modes, but if I launch the normal application, it crashes, logcat.

If someone wants to try this, build or download. Any feedback will help.


Let me ask you a question, even if it is a stupid one
Why is there no official LOS?
No maintainer?
Other problems?

The building of the image itself seems to work.

Is there any information about this?

There is already a GSI image of LeOS. So the AOSP seems to be already ported.

I guess the answer can be found in the parallel thread:


Then download the iodé rom linked above (file Extract the zip and follow this tutorial 2 on how to extract the proprietary files from payload.bin file.

I just do use the iode zip to extract the payload.bin file, right?

1 Like

Yes, using the iodé zip to pull the rest of the vendor blobs is enough. Follow these steps to extract them.

I tried to build myself, now when I sync, I get these errors:

error: frameworks/compile/slang/: platform/frameworks/compile/slang checkout ec03988d63f0cd47939ab814e08668c30cbbeb66 
error: Cannot checkout platform/frameworks/compile/slang

Please move or remove them before you switch branches.
error: external/libunwind/: platform/external/libunwind checkout 2a99ffade2eb18de165e20efc9609f1f923ae9eb 
error: Cannot checkout platform/external/libunwind

Should I delete everything in the folder and start over?

Hmm that’s weird, seems like local changes were made that broke your sync.
You could try to discard them all :

repo forall -vc “git reset --hard”

and resync :

repo sync

If it doesn’t work, my advice would be to start all over :frowning:

Many thanks - another question: I need to sign my own builds to continue with future updates on this path, right?

I have absolutely no idea, I didn’t sign mine which is probably… bad ? Honestly I have no idea, but if you find out the answer, I’d be glad to hear about it :smiley:

I hope my question is appropriate here:

I have tried to build it by myself. But it failed, because I cannot follow the guideline 100% precisely I think.

I use a Linux system, which is good. However, my system directory is on an SSD. It has not enough space (~100GB) left. So I need to adjust it to work from another harddrive.

Maybe you can review my steps and tell me if I do something wrong regarding my adjustments:

I followed the steps here with the following changes.

You see that I always try to refer to the respective drive:

  1. Create the directories:
    As in the guide:

mkdir -p ~/bin

My change:

mkdir -p ~HARDDRIVE/directory/android/lineage

  1. Initialize the LineageOS source repository
    My change:
cd ~HARDDRIVE/android/lineage
/HOME/bin/repo init -u -b lineage-18.1
  1. Download the source code
/HOME/bin/repo sync

The issue I experience then I explain here ^

Is my approach totally wrong?

I don’t see an issue in your steps. Have you tried what Aaanze recommended to recover from this error? Or try starting with a fresh lineageos folder.

I will try to delete everything and do the steps again. But thanks for confirming it is possible my way.

FYI, I can confirm: Using both PRs from poshul did the trick. FPCamera is operational now. :slight_smile:


Is it working properly? I can’t open the app normally, it closes right away.

There’s another PR to solve the backlight issue. :clap:

As far as I can tell, it works properly. However, I did not test everything. That PR is for LOS 19.0.

EDIT: The slow motion effect crashes the application.

I didn’t noticed that i can built LOS 19.0 yet, thanks.

Why is there no official Los version for fp4?
After that long time?
I think /e/OS and iode base on them and there are out for long now

Because people need the time to do this volunteer work in their freetime. And having no idea about the work to be done, I will not judge if it takes long or not