English

Bug: can't change preferred network type again after change

mobiledata
Tags: #<Tag:0x00007f57d744ce98>

#1

Hi,
i used fairphone open 18.10.0
i face the bug that i can’t change preferred network type after i set him to 2g.
The Menu is shown grayed out, after i reset the network settings, it works again, but after set differend its grayed out again.




#2

You may take a (long) read here.

But generally spoken. You should start off with setting the lowest network type which is 2G (both cards) as only one of both may use 3G/4G while the other is forced to 2G. The assignment is totally up to you.

Both cards may be set to 2G at once, but not to 3G/4G. So the configuration sequence makes the difference here as the setting for the limited card to 2G will be greyed out once 3G/4G is defined.
1st configure your preferred card for calling (any socket), Last configure your data card with 3G/4G.

If you are completely stuck, power down the phone, remove both cards. Have a power cycle. Once switched off again, reinsert both cards and retry after the next boot.


#3

This is unfortunately yet another known bug. You can read about it (and vote for it) on the bugtracker: https://bugtracker.fairphone.com/project/fairphone-android-7/issue/50

karloff obviously uses only one SIM.


#4

That is correct, I only use one SIM. (Provider: Vodafone Germany)
I try’d change SIM Slots, but did not help.

Thank for the bugtracker link!


#5

I also have this issue. I was scared to loose saved WiFi networks if I “reset network settings”. My work around was to get to internal testing app (enter *#*#4636#*#* in dialer) where i can choose from many “preferred network type” choices:

after selecting 2G in settings > more > mobile networks > preferred network type:
testing app > phone info shows “GSM only”

after selecting “LTE/UMTS auto (PRL)” in testing app, I again get normal 2/34G connectivity:

note, going to settings > more > mobile networks will reset to 2G-only connectivity again (and the preferred network type is still greyed out) even if you dont change anything.

regards,
M

PS similar issue (closed thread) from long ago:

(Edited by @AnotherElk for correctly displaying the dialer sequence)