English

Bug: Android 10 FP3 - Unknown Caller

Is this still talking about outgoing calls?

I had this issue with android 9. Fixed by opening the dialler app, then /settings/calling accounts/Telekom(my operator)/GSM call settings/Additional settings/Caller ID/Show number

I’m connected on 4G most of the time but I guess my SIM doesn`t allow VoLTE so when I make a call it falls back to GSM/UMTS.

Not sure why network default isn`t to send the caller ID but this helped.

Iain.

2 Likes

Thx, Iain. It seems to me that in Android 10 there is no specific option re. showing caller ID numbers, at least I couldn’t find it… :frowning:

It’s in the Phone app settings.

Best wishes,
Thomas

1 Like

Thx, still don’t find it (use the phone in German language), but it seems I have no “dialling accounts” in the Telefon App…

Ich denke, es ist diese hier

3 Likes

Danke, Thomas. Interessanterweise scheint sich diese Einstellungsseite bei mir nicht zu finden. Wenn ich nach Anrufer-ID oder Spam suche, komme ich nur zu einer Konfiguration, um die Standard-App für Anrufer-ID und App einzustellen. Das war bei mir offenbar nicht die normale Telefon-App. Hab ich jetzt eingestellt, dennoch erschien nirgendwo das, was oben in Deinem Screenshot steht…

Telefon-App, drei Punkte oben rechts > Einstellungen > Anrufer-ID und Spam

3 Likes

Vielen Dank nochmals. Hab das jetzt so gefunden, interessant, dass das über die Suchfunktion nicht ausgegeben wird. Dort war das aber ohnehin korrekt eingestellt, dennoch, bei neuerlichem Test, keine Anrufer-ID übermittelt, wenn LTE eingeschaltet ist. Es muss weiterhin der oben beschriebene Bug (in Kombination mit meinem Provider) sein. Im Support-Ticket dazu wurde mir bestätigt, dass die FP-Entwickler weiterhin dran arbeiten.
Schönes WE!

Hallo magoo,

ich habe gerade mein Handy auf Deutsch geschaltet. Bei mir liegt es hier:
Phone App / drei Punkte / Einstellungen / Anrufkonten / (dein Operator Name,z.B. Telekom) / GSM Anrufeinstellungen / Zusätzliche Einstellungen / Anrufer ID

Vielleicht ist das bei jede Operator anders. Keine Ahnung.

Viel Erfolg.
Iain.

2 Likes

My issues with unknown caller are back again today after the latest update which reading the details says it makes a changed to the VoWiFi provisioning process.

Anyone else having these issues again?

Some users reported that with this update it is no longer possible to set VoWiFi preference when connected to an LTE carrier. Have you tried airplane mode (with WiFi enabled, expecting an established WLAN connection of course)?

1 Like

Yeah, with no mobile networks enabled and just of WiFi I can receive a call so it’s definitely using VoWiFi setting

I have access to all the settings, so can confirm when I disabled both VoWiFi and VoLTE, the problem stops - it’s only when taking calls through one of these two methods that I get unknown caller appear

2 Likes

Yes. I also have the problem. But this time not all the calls are marked as unknown, only some ob them. Really annoying.

Seeing this myself, on mine and my partner’s FP3s. Bit of a problem really as we have moved to an area that has poor signal, and so are relying on Wifi calling.

For your information: I found the same problem here in Luxembourg (provider POST). Enabling 4gLte results in all incoming calls showing as ‘unknown’.

After my FP3+ was upgraded to 0066 im hardly ever have problems with not being able to se the caller. I am also relying on VoWLAN. This is actualy one of the very few problems that was solved at least for me.

1 Like

Same Here, but the “downgrade” workaround ist working.
Thanks and hopefully IT will be fixed soon.

Tom

1 Like

HI @datengarten

I’m not aware of the option you chose to downgrade and you don’t mention which version you were and are now using, would you be so kind as to elaborate :slight_smile:

1 Like

The problem still persists via LTE connctions.
I disabled WiFi Call lately, as A1 in Austria seems to have troubles with it since a few weeks.

I’m more than happy with my FP3+, but still those little things are annoying :

-Cannot lock the exposure in video mode with the stock app (it works with GCam though)
-WiFi calls are enabled, but the icon is not always here
-Notifications are pausing my music, I’m not sure it’s a bug but this should definitely be automatic