English

Bug: Android 10 FP3 - Unknown Caller

Hi Adrian, same as you, the Caller-ID for outgoing calls to ‘show number’ did not solve the problem… So I also disabled 4G altogether :frowning: tested it… now the Caller-ID shows up when I am called :slight_smile:
These are the steps in Dutch I followed to disable 4G:
Instellingen > Netwerk en Internet > Mobiel netwerk > Geavanceerd > Voorkeursnetwerktype > 2G/3G auto (previous setting was 2G/3G/4G auto)

normally you don’t have to disable 4G completely.
have you already tried to deactivate this setting?

hey @Ernestina :slight_smile:
could you take screenshots from those menus and post it here?

@Alex.A I never heard before that this setting is provider specific.
I too had some issues regarding VoLTE: my provider didn’t supported it back then but somehow this setting got activated. Thus, I wasn’t able to receive and make calls - the calls were canceled after a second. So, in my case this setting shouldn’t have been there…

1 Like

Thanks for thinking along @HolosericaCaligo, but I do not seem to have the option “enhanced 4g lte mode” under “advanced” :frowning: maybe it is a provider dependent setting…?

1 Like

Thanks for your reply!
Could you take a screenshot? It’s not that I don’t believe you, but it would help to understand how this menu is different on different devices :slight_smile:

1 Like

In reply to @HolosericaCaligo’s request for a screenshot:
I added the language English (Netherlands) and placed it above the Nederlands (Nederland) language, so it can be read by anyone…

Followed path:
Settings -> Network and internet -> Mobile network (simyo) -> Advanced
This screenshot shows the entire screen content:

4 Likes

Perhaps your SIM is to old. Or it’s different at my phone because I am running /e/.
As you can see on the screenshot of my phone is looks different.

I don’t make calls with the Simyo card.

3 Likes

When you tap on “Preferred network type” do you even than have the option to choose 4G?
It doesn’t seem like it from the preset.
Does your contract maybe exclude 4G or is your SIM outdated?

Edit:
Lidwien was faster than me.

1 Like

Thank @Lidwien for sharing the screenshot with options I do not see on my phone. I have contacted Simyo about the SIM-card I use. They confirm I have the most recent 3-in-1 SIM-card, the one I ordered in October 2019 especially because of the nano-SIM I needed for the FP3…

Thanks.

For the screenshot it’s the same as posted by @Roenepoen .

Hope FP is gonna solve the bug asap, this is super hyper annoying

Hi @Roenepoen, it turned out that I had also disabled 4G, just like you did and describe in the next message. Only disabling 4G and not the caller-ID for outgoing calls did not work. So had to do both…

1 Like

Mine is the same. I was thinking, what could cause the difference. I did not receive the august security update, mine is using the July 5ht update. Maybe that is of influence?

1 Like

@anton thanks for your message. Yes I had to set both as well, first setting the Caller-ID for outgoing calls to ‘show number’ in stead of Networkstandards. That did not work but I kept the new setting, and only after disabling 4G I saw the Caller-ID on my screen when I had someone call me to try it out…

1 Like

I’m experiencing the same issue here as @Roenepoen, I’m also with Simyo. So it’s either unknown numbers or 4G for me now. I’m on the July-5th update as well @anton. Hope this issue can be resolved soon.

1 Like

Wasn’t aware of the problem but followed instructions and
all is ok, just as well as i use wifi-calling mostly. This is with FP3+ with Android 10 pre-installed, though i do have the Virgin carrier when It should be EE

1 Like

The problem of the unknown caller is solved on my phone with todays Safety pack update. (and also the problem with the name of the service provider and time sticking to each other)

5 Likes

Here it is solved too, after the Safety pack update.

5 Likes

Infortunately, the problem is still not solved for me…
When I read here that the last update should have solved it (and when I was asked by a lady from Fairphone support whether this problem is solved), I turned LTE on again, but, again, only “Unknown Callers”. As soon as I switched it off again, it works. So the safety pack update from end of October… :frowning:

1 Like

So sorry to hear that.
I might be, that they could not solve this problem for every provider yet.
Have you reported your problem to Fairphone support, so they know your country and network provider? They should learn of this. One can never be sure, that they are aware of every relevant combination already.

2 Likes

Thx. I am in contact with them via a Support thread. They are quite slow, however.

1 Like