English

Bug: Android 10 FP3 - Unknown Caller

Same issue (Netherlands, KPN). Reported it at Fairphone. The workaround did work.

1 Like

Same issue (Netherlands, KPN). Reported it at Fairphone.

Same issue, KPN netherlands too

Seems that the issue comes and goes on my phone. Some times it says unknown, and then later the same day it shows who is calling. ?

1 Like

Hello,
Three of my customers had the issue, but not the others… They did update their phone (FP3), they tried the two workarounds (4G/LTE; Phone settings “Caller id = hidden”) but none would work.
What else can we do for now ? Just wait until it’s solved ?

1 Like

Have you also tried the both workaround as suggested here?

  1. Settings -> network and internet -> mobile network -> advanced -> enhanced 4g lte mode
  2. Phone (app) -> three-dots-menu -> Settings -> calling accounts -> select sim -> wifi calling

AFAIK this issue only occurs when WIFI Calling and especially VoLTE is used.
If those services aren’t support by the provider, you won’t get this issue.
Also, if you are at a place where you have just 2G/3G or no WiFi reception, you won’t get this issue.
This could be the answer for @ModularKing’s question, too…

2 Likes

Hello,
One of the three called me again, he told me that he had not did the update, so now he updated his phone and it came back to normal… apparently, this person has been lucky with the update. The other two though, didn’t call back to tell me it’s good :frowning:

2 Likes

thanks Chris! however, i cannot find the things you’re referring to on my ‘dutch’ phone… could you maybe make ‘printscreens’ of the steps to take?

It might be faster, if you set the language to “English” just for repeating the steps listed in this forum.
-> Instelligen -> Systeem -> Talen en invoer -> Talen
Then select English.
You then should find your way. :slight_smile:

1 Like

Hi Cecilejl,

I have the same issue and can’t find the settings on my Dutch fairphone either, and my phone is set to English. I think it varies per country or provider whether or not we have those settings?

I reported the bug, with my country and provider, and the lack of settings for the workaround today.

2 Likes

Same problem, workaround with disabling LTE 4G (see above) works but is not a solution.

400+ Euros to use a phone without LTE 4G to be able to call back incoming callers.

Others replace phones that cannot use 4G LTE, I bought the FP3 to avoid electronic waste but have to make phone calls now without 4G LTE.

What next?

Without this strong community I would not have found the workaround, thanks.

1 Like

It will get fixed. I sent my bug reports through to them.

If at least some other people share three same with FP I’m sure there will be a permanent solution soon

3 Likes

You still can use LTE on your phone without any problems!
You don’t have to deactivate 4G/LTE entirely.
Just this one function called enhanced 4g lte mode has to be deactivated.

6 Likes

I have switched to 3G and now it seems to work🤞🏻

(Fairphone helpdesk is not available for a few days already…)

1 Like

Same problem here.
Here same problem since Android 10. Network KPN. Netherlands

Maybe I missed something in the thread but I can’t find those options in my phone to disable them.
Settings -> network and internet -> mobile network -> advanced -> enhanced 4g lte mode
Phane (app) -> three-dots-menu -> Settings -> calling accounts -> select sim -> wifi calling

Welcome to the community forum!

Could you explain in details what you mean? Where do you start not being able to find them anymore? Could you send screenshots perhaps?


@others
Is enhanced 4G LTE mode available with all providers? For some users, the workaround seems to be to deactivate 4G completely and use 3G…

4G LTE (or VoLTE - voice over LTE) may be carrier specific, I don’t know. But when you disable it, it should not disable 4G itself, just how voice data is dealt with

4 Likes

thanks Emiel, I set the settings to 3G and it seems to work…

1 Like

For KPN users in the Netherlands with the Unknown Caller bug: I’m using KPN (Dutch carrier). I can’t find any reference to 4LTE on my FP3 using KPN. I found a reference to Mobile calling via WiFi on the KPN site: (https://www.kpn.com/beleef/mobiel/mobiel-bellen-via-wifi-van-kpn.htm). KPN also call it VoLTE. There’s a list of phones that support VoLTE but FP3 is not on the list.

Wifi calling: I think that so-called Wifi calling is turned on or off for KPN at:
Settings > Network and internet > Mobile network > mobile data.
I still get the unknown caller message with mobile data turned off.
Maybe someone more knowledgeable can advise on this.

I also have Simyo Netherlands and tried the steps mentioned by anton, but alas to no avail :frowning:

I will put the steps in Dutch here, just to be clear for other Dutch speaking members that might have more luck:

  1. Ga naar de telefoon app, dat is die met het blauwe icon met telefoonhoorn erin
  2. Tik op de drie puntjes die rechts bovenin staan > Instellingen > Gespreksaccounts
  3. Tik op de SIM-kaart die je gebruikt
  4. GSM-oproepinstellingen > Aanvullende instellingen > Beller-ID “Nummer weergegeven bij uitgaande gesprekken”
  5. Nummer weergeven

@anton, are these the steps you have followed to succeed…?