English

Bug: Android 10 FP3 - Unknown Caller

Just for the record, I also have this problem.

1 Like

For the record, I also have this problem and don’t have the option to disable “enhanced 4g lte mode”. I noticed that after disabling 4G the caller id is shown again. But disabling 4G is not a proper solution…

@gigawebs - we know, that’s why I’ve suggested it as a workaround until FP fix things.

If you haven’t already done so, report the issue to Fairphone as well and let them know the network and country your SIM is connected on. The last update on my ticket, they have developers looking at this but need this info

2 Likes

Yes, I’ve also reported the issue to Fairphone support. :slight_smile:

5 Likes

Had the same problem… could fix it. Thank you! Good support!

Hi, just wanted to let you know that for my phone (Simyo Netherlands) it got it working again with the soltion from Chris_R (sep 14), setting the Caller-ID for outgoing calls to ‘show number’ in stead of Networkstandard’. Strange that it is for outgoing numbers (al least the Dutch text says so).
Note: I have no option to disable WIFI_calling and Enhanced 4G LTE Mode…

Thx to all who contributed

Anton

5 Likes

I have the same problem, with provider KPN (Netherlands). For me the only workaround is to disable 4G altogether, which makes my internet rather slow…
My phone doesn’t have the ‘enhanced 4g lte’ of ‘wifi-calling’ mode. Also setting the Caller-ID for outgoing calls to ‘show number’ did not solve the problem. I hope Fairphone is working on an update!

Cheers
Adrian

3 Likes

I’ve used your work-around on my fairphone for the same provider as well. Works like a charm, except for the fact that I can’t use 4G anymore.

2 Likes

Have the same problem since the last system-update last weekend!!!
…and NO response from the support :rage::rage::rage:

Same problem here (but not all callers, interestingly) - habe das gleiche Problem (aber interessanterweise nicht bei allen Anrufern).

2 Likes

I don’t have te option to disable “4g lte…”
Theee are 2 sims in my phone; Kpn and Truphone.
In my settings I can disable the advaced setting for Truphone sim but the kpn hasn’t got that option
I do have the troubles with unknown incoming calls

It’s normal, you can have only one SIM in 3G/4G, the other one is blocked on 2G (I think, that was the case with FP2 and I think it’s the case with FP3 as well).

No that’s not the case anymore with the FP3.

3 Likes

Here same problem since update to android 10. No Caller ID. Network KPN. Netherlands

I’m new with Fairphone and I had the same problem. I changed it and now it works with the transfer of the saved names.

I’ve had an update from FP this morning asking for more information to try and figure out what’s happening.

Anyone still having the issue, I suggest sending this info through to FP

I am contacting you again, because we would like to ask you, if possible, for further details.
Since we are still investigating this issue, I ask for your collaboration to help our developers to investigate it further.
We need you to capture a report directly from your device and send it to us. We will use this information abiding by our privacy policy.

Please, follow these steps:

  1. Enable the Developer Options.
  • Go to Settings > About phone > Build number.
  • Tap Build number seven times (enter your phone pin if required).
    Once activated you will see the message “You are now a developer!”.
  1. Go to Settings > System > Advanced > Developer options.
    If the status is “Off”, tap on the first toggle on the left to change it to “On” (the color will change to green).

  2. Scroll down the options and enable Turn USB Debugging and Bug Report Shortcut.

    • IMPORTANT - Restart your phone.
  3. Reproduce the issue making sure to perform all the usual necessary steps. Before you do this, make sure to enable again VoLTE and VoWIFI. Then ask someone to call you. If you receive still a call as “unknown”, proceed with the next step.

  4. Once done, long-press the Power button: several options will appear.

  5. Click on the button called Take Bug Report…, after a moment you get a notification that the bug report is ready.

  6. Tap on the notification and share the bug report to us via email following the instructions.

If the file is bigger than 20 MB, you can use our Fairphone Fileshare portal to upload your files.
Please click here and follow the instructions. (Edit: Can’t provide these instructions, but if you log a ticket with FP they will as it is personal to you).

  1. Once the report is sent, it’s safer to disable again the developer options.
  • Go Settings > System > Advanced > Developer options.
  • Tap on the first toggle on the left to change it to “Off” (the color will change to grey).
  1. All done! Just go back to the home screen and use your phone as usual.
7 Likes

Thanks a lot for sharing this and I hope this problem get’s solved really soon.

Maybe you could add the link to the instructions for using the Fileshare portal for files larger than 20 MB (Point no. 8)

1 Like

Done. Apologies I copied and pasted quickly :slight_smile:

1 Like

You probably want to remove your personal details (email address, ticket id?,…) from that fileshare link.

3 Likes

Oops, good spot! I hadn’t noticed it was personalised! Doh

1 Like