Bootloop fp2 after update recently (14. july)

Hey folks,

after updating my FP 2, everything seemed running normal. (No root, clean orinial FW)
But after the battery went down, it dind´t recharge the battery. Instead, the red light is fast flashing permanently (like deep discharged).
First i did a hardwarereset to troubleshoot (at this moment i still could reach System recovery mode via vol. button down/power button).
But the HW reset did nothing. After that, the FP2 is looping: fairphone logo/vibration - crash - red light flashing fast.Sometimes its just stuck with the “iniciating screen” which shows FP logo and lower side “powered by android”.
I tried different chargers/ cabels, chared it over night, removed the SD card, dis- and reassebled the FP Hardware etc…the Device manager (Win7) doesn´t recognize it/ has problems/“blinks”: (recogniced new hardware-disconected).
I couldn´t reach System recovery mode or the FP via minimal fastboot (as recomendet on troubleshooting site), lists nothing.
Is there any way to flash the FP2 “the hard way”? I remeber flashing my nokia N8 in “dead mode” that worked always, and i worked a lot with CustomRoms on the N8 (…good i miss it :slight_smile: )

Has anyone an idea? All the How-to´s refer to use the System recovery Mode…


Did you manage to get the LED to light in a different color then red already? If not try the battery reset described in the #batteryguide and if that doesn’t help try more different chargers.
The phone not being recognized via fastboot mode speaks for a faulty cable as well. And if it’s not the cable then your USB port (bottom module) is probably broken.
Do you know someone with a working FP2 near you who would let you test their bottom module in your phone, and maybe also try charging your battery in their phone?

1 Like

Hi, thanks for the fast answer.
Acording to the #batteryguide I removed the battery for mor than 2 hours from the FP. But that didn´t work.
The FP startet to boot fist the blue battery loading gif , and then “123 apps to conigure” (due to the Hardwarereset). But then again crash, blinking battery loading light. I changed the charger, dind´t help.
unfortunately i think there is nobody around with a FP2 here to Test the bottom module.

But could it be that the Battery Module or the battery are broken, unrelated to the update, but to the same time (strange things may happen)?


Did you press the power button or did the phone start booting on it’s own? For the battery reset you shouldn’t boot the phone.

I pressed the button :frowning:
I will do it once again…

1 Like

If you do it correctly after putting the battery back in and plugging in the charging animation should appear. Wait until the LED turns green before you boot.

Hi Paul,

i did the battery reset three times and charged overnight, but nothing changed. As far as i can see, the OS is trying to start. Several times, it screens a withe square with says “Android is starting”, a moving circle and “optimizing appl 1 of 78”. So far so good, this goes up to app 21 of 78.
Than it crashes, and the cycle repeats again. During the booting time, the red light isn´t blinking at all…
Because of this I assume that there is a FW-failure because to the new update.
Or some hardware is broken (battery/ battery manager?)
But than it should boot with just the power cable pluged in. But just with the power cable connected without battery, it just starts to boot, vibrating, and restarting (1-second-loop)
This is why i considered (from the beginning) a new OS flash…

Greetings and thanx so far,

Did you ever see the battery charging light become green?

No, it never became green.
Just fast red blinking with black screen, then boot with black “fairphone/ poweerd by android” withot led light, booting with slow red blinking, then crashing -> looping
never got the blue battery gif image.

Really does sound like a deep discharge problem. Whether this is because the charging behaviour changed with the update is another question. I don’t recall the FP2 being able to start without a battery present, so the crash during the app optimisation is likely due to the phone running out of power. The power draw during that stage is quite significant, and probably exceeds the rate at which the phone can charge. This is also why when you run the updater app, it refuses to update unless the phone is charged for >80%. Hence @paulakreuzer’s comment to wait until the light turns green - you’ll need a high enough battery charge to get the phone fully started.

There’s a more in-depth of the deep discharge problem in the topic below. As your phone needs to be able to finish app-optimisations you should definitively wait more than the 10-15 minutes indicated in the guide (rather wait for the light to become green). Try your collection of chargers and cables if you can’t get a steady charging light with first combination you try. If nothing works to charge the battery, contact support as there may be a problem with either the battery or the charging connector.

Thanx for the fast answer.
i tried several chargers, that worked fine with the phone for the last 2 month.
But I have no influence to stop/start the booting, the phone does it on its own.
What i just saw is that the phone is not beginng with the optimizing process from 1, but continues with higher numbers ( i think thats new!!).
So if the battery is really deep discharged (possible), i could just wait until all updates are with a high number of boot cycles are done :slight_smile: and then charge until 100% . That would be a unusal, but great solution, if it works :slight_smile:

Just to be sure, check whether the power button isn’t getting stuck in the pressed position - that would cause a reboot every ~ 20 seconds or so…

Just checked it, no, the power button isn´t stuck (but this would explain everything)…
i just wayt a little bit until all optimzings are done, its still working step by step.
But many thanx for the fast replies!!

Try to reach the recovery mode, this is not so energy-hungry. If that’s possible, you could try to clear cache+dalvik, to install update again. But I tend to the reason: the battery is the problem. Battery sits tight? No contact problem?

1 Like

I could finish the boot process, and iniciate the OS (select language etc.) The left the phone on in order to charge, and it crushed again. Now the red light blinks again and the FP doen´t start (couldn´t recovery mode so far)…
The FP boots on its own, but after reaching the OS iniciating process, it crashes (due to lack of energy, I think).
Battery sits thight so far (cleand all contacts).

So far nothing changed. The battery light is blinking red, the FP is getting warm, and its still in bootloop. has anyone an idea how to stop the bootloop?

Difficult to do anything if it also occurs in recovery, or you can’t reach recovery. I wouldn’t recommend flashing new firmware if the device is that unstable, it may make things worse rather than better. As attempts to fix it don’t seem to work, you’re best off contacting Fairphone support, as they’re the ones that can arrange for warranty repairs if they think it is the hardware that’s at fault. They still seem to be working on fixing a backlog in requests, so chances are you’ll get a faster response if you call them.

I’m pretty sure you need some new hardware. Either a battery or bottom module.
Someone with similar issues recently contacted support and they sent them “new parts” (I’m guessing a bottom module and a battery) for testing.

That was ME.

FP sent me a new battery and a new bottom module. The original battery seems to be OK (it’s back in my phone) but it was very deep discharged and some bottom module fault was keeping it that way - something in the bottom module was stopping charging and maybe even discharging the battery.

However, I reached a point where only the red LED would flash and only then if I pushed the USB plug hard into the socket, The phone had even stopped trying to boot. If you can get the red LED to flash all the time, then at least you have a charger connection to the battery.

You know what … we need an external battery charger device!

Support were really quick to help me (got new parts a week after posting the ticket), once I got them to recognize that I’d posted a support ticket (it had disappeared “in the system”).


Thanks for the follow-up and good to hear it all worked out. :slight_smile:
What will you do with the extra battery? Send it back? Buy it as a spare? Or did they gift it to you?