Bootloop after Marshmallow Update

I had this too once. I don’t think it’s a thing that will happen all the time - otherwise they’d just disallow deactivating GAPPS - or rather only happens the first few reboots after the update (when some Optimization is still going on).

Anyway I switched back to Open OS after testing the beta update too (it was never my intention to stay with FP OS anyway) and had no problems with it.

  1. Linux OS. When i saw the Fairphone boot animation (with the 4 blue dots) I connected in commandline to the phone via adb shell and navigated to /storage/emulated/0/ to simple note the desired folder paths, then i copied everything via adb pull xyz
  2. phone was in bootloop
  3. I tried update via adb, but it didn’t stop the boot loop, cause the update itself was never the problem
  4. No never
  5. via adb command line tool under Linux
1 Like

@schmulschubiak Thanks for the info.
I could not replicate the steps, so I swallowed the bitter pill and wiped it out. It worked, and that’s that.

@paulakreuzer I guess It has been covered in other topics but, is this an android marchmellow “as is”? No more fairphone flavour?

1 Like

No it is not AOSP, it’s still FP OS, just with a few less FP specific #features.
However you still have a (different) FP-launcher, FP wallpapers, the inactive Apps feature and of course the FP updater app (& there are probably more).

Calm down. :slight_smile:

This issue is very specific, it’s not about being unable to deactivate “GAPPS”.
This only concerns the Google App, not “Google apps” in general (like Hangouts, Drive etc.).

Android 6 has a new feature called Assist. The Google App is set as the default Assist app. If you disable the Google App, you have to set the Assist app to None or you will end up in a boot loop. You only have to do this once.

Since this setting does not exist in Android 5, you have to make sure the Google App is enabled before you upgrade. After the upgrade you can disable it again, set the Assist app to None and you’re good.

This is not specific to Fairphone, it’s a well known issue. But I agree that the Updater should at least warn you about that.


Thanks @ChuckMorris for this info. Could you add a description on how to set the Assist app to none in the wiki above. PS: Thanks! :slight_smile:


Thanks for your suggestions, I’m afraid I got stuck at 2), there is no sd card in my Phone.
Also, 3) requires a fairphone 2 operating normally, that’s exactly the problem, it’s not operating at all.

I’ve tried to read the pages about adb and noticed that for any option that has been suggested here, something is required that I don’t have (sd card, a functioning Phone, a setting in developeroptions that I never set). So thanks everyone that had tried to help, but I’m afraid that I will have to just do a factory reset and loose anything I haven’t backed up.

Hello! So could anybody come up with a solution to avoid a complete wipe out/factory reset? I contacted FP two times via mail but they don’t answer. I also tried to save everything via adb but it didn’t work. Does my phone have to be rooted to do so? I didn’t study IT so all this is really new and annoying for me, I just want my phone to work again…
Can somebody please help me??

A post was split to a new topic: Updater App vs Google App

@Alexandra_Maria if you haven’t upgraded yet you won’t any longer run into this issue as the updater app now prevents you from updating unless everything is set up right.

Did you already upgrade and need assistance getting out of the boot loop? Otherwise I’d close this thread.

1 Like

I did upgrade last week and I’m stuck in the boot loop, yes!

Well if you didn’t disable the Google App or rooted your device before upgrading go to #dic:recoverymode to perform a cache wipe. After that the app optimization process should work (may still take 2 or 3 times).
If you did disable the Google App, rooted your device or the cache wipe doesn’t help there is unfortunately no other way than to do a #dic:hardreset.

Sigh. Disabled the Google App and now my lovely updated phone has had to be wiped clean. AH well…

@ChuckMorris Just happened to me, how did you get out of it again? I updated to Marshmallow, then disabled the Google App and a couple of seconds later the phone crashed and was caught in a bootloop…

I think it’s a good idea to set the Assist app to None before you disable the Google App. I edited the Wiki post to make that clearer.

Unfortunately, if you are already in the boot loop because of disabling the Google App it is too late. You have to wipe the phone. At least I am not aware of any other solution.


Somehow funny that all depends on an app. Have not tested this or had the developers create this dependency, because otherwise there is trouble with Google? :confused:

A post was split to a new topic: FP2 stuck on “Change is in your hands” screen

Sorry, but are you guys fucking kidding me :neutral_face: .

I updated properly, switched off the Google Aps, did not receive any warning from my phone / Android, and now I would have to whipe my whole phone?!

Sorry, but this is ridiculous.


Tell that to Google. It’s certainly not our fault.

I understand, and I am not blaming you / FP for the fault, but a warning in the FP-updater would have been nice…