FP2 stuck on "Change is in your hands" screen

Hello, my F2 is permanently stuck in what I guess is called the bootloop. Screen states:
Fairphone
Change is in your hands
dot dot dot dot dot

I’ve tried several things, like, removing battery, sdcard. To no avail.
The phone’s accu/battery at one time was completely EMPTY (started at +90%full)… Reading through several posts I tried to ‘break in’ on this boot-hickup.
I guess I have myself to blame, 'cause when allert came: Update available…I tapped INSTALL NOW, not being aware there were 2 updates, one that should have been installed BEFORE the other.
So, now, the phone is not responding at all. No matter what sequence of buttons I press in whatever order.

I understand this will mean: HARD RESET or said in an other way: BACK TO FACTORY SETTINGS. So be it… ;-(

But: since my phone is not accessable, how in @#$'s name can I even start to perform this process?
PS It took a over 3 hours, I put the phone in a cool spot, but it did not get out of the loop…simply drained till empty.

Please advise!
Thanks
Fleu

I moved your post to a new topic as what you describe doesn’t sound like the app optimization boot-loop to me.

There is no sequence. You just have to press power and volume up at the same time and keep them pressed until you end up in #dic:recoverymode.
If nothing happens pressing both buttons for 30+ seconds, then take the battery out, put it back in and then do the combination right away, before you get to the Fairphone Screen.
In Recovery Mode you can do a #dic:hardreset.

Thank you, paulakreuzer, I will try these suggestions…at this moment the battery/accu is completely empty, again, so I guess I’ll have to wait a little longer for it to charge and try … I will update results.
Gr, Fleu

Same here :frowning:
Could this be caused by to less storage? I think there were round about 1.5 GB … 2 GB free when i started the upgrade.
Any chance to recover the phone without wiping everything?
Kind Regards
Wiz

Hello, Fleu again.
So, I’ve now recharged the accu/battery enough to get a chance to press both buttons (before screen switched to “change is in your hands” screen, as advised) .

This leaves me with the screen dispaying the miniature figure laying on its back, and a red warning triangle on it’s tummy.

No pressing of buttons will interfere with this, no choice menu can be accessed. And, again, I tried and tried and tried.
After some time the screen goes back to the “change is in your hands”.

Removing battery/accu: Same thing, when pressing buttons the little figure on its back apears…and just as above, I can not get in to anything and change in hands screen comes back.
Drat!
My phone is not filled with loads of pictures, video’s, and other memory-consuming stuff. I ‘clean’ the caches of the apps I have regularly…

Starting to panic a little bit, now…

Thanks again for any reply sent!
Greetz,
Fleu

Press power button, then additionally press and release vol up button. You’ll be in stock recovery then.

Hi Volker,

Thanx for your message.
I’ve tried the things you mentioned in your post…alas, to no avail.

The phone does not switch to stock recovery.

Furthermore, as it stays in the “Change is in your hands” loop, the accu/battery drains again…unless I remove the battery completely and not put it back in again.

Boohooh snif snif

grtz,
Fleu

just to be sure: did you try pressing the buttons mentioned while you saw “the screen dispaying the miniature figure laying on its back” as you’d mentioned?

Hi Volker,

Yes I pressed buttons while on its back (I’ve now learned its called the Android-Robot). And before that. And after that. And a few minutes later. And some time earlier. My fingertips hurt from all this pressing small phone-buttons :wink:

The phone, in the mean time, is back on charging…

grtz,
Fleu

It’s no matter of time - just a matter of “sequence”… And I’m quite sure it works. So you press power, leave it pressed(!), short press volume up and release volume up. Then you should be in recovery menu. If THAT doesn’t work, well, then…

All right, but did you press the buttons exactly as @Volker mentioned?

Does it say “no command” (or equivalent in your language) along with the picture of the robot?
If yes, then @Volker is most likely correct (if it isn’t another problem):

It’s the way to get into recovery with Android 6, slightly different than before in Android 5.1.

Goodmorning y’all,

Having left the phone to charge for a loooong time, I tried again to fiddle with pressing buttons…and

I’m IN the recovery menu. Jeeej!

Showing, as you all probably know, the following options:

Reboot system now
Reboot to bootloader
Apply update from ABP
Apply update from SD card
Wipe data/factory reset
Wipe cache partition
Mount / system
View recovery logs
Power off

and in left hand bottom corner : Supported API: 3

I selected: Wipe cache patititon and YES.
This, to try and get around any full memory issues.

Now I hesitate on how to continue.

shall I select: Power Off, go and take a nap, return in a few hours,
or select any of the other options, worst of all being: Wipe Data / factory reset…?

Having gotten this far, I don’t want to rush into things, so I’ll wait for any reply before continuing.

Yawn…I will go and get some sleep, first.
Thanks again in advance for replies and support!

Grtz, Fleu

I don’t know about recovering it, per se, but if you manage to get into recovery mode you might be able to use Android Debug Bridge to pull all the data you care about off it before wiping it.
(*Take this with a grain of salt. I don’t actually have a fairphone yet, this is just a standard Android thing.)

Goodmorning again,
I’m back, awake, ready to continue and so is my phone, battery loaded and in the recovery menu. (that is, in the menu as I listed earlier/above).

Zergling__man, thanks for your post.

While phone is connected to laptop AND in this menu, it is NOT visible in the computers overview (where I normaly expect to see it as a discdrive F and open it/acces data/copy foto’s etc). Maybe because the phone is currently in rec mode, it is not shown as accessable disc.

When I leave the menu, (phone goes back to ‘stuck in change is etc’) the phone shows up in computer overview, as drive F. BUT I can not access it, as if it is NOT connected to laptop, although it is by USB cable.

I 'm not clear on what is suggested, about using Andoid Debug Bridge…What how etc worketh it?
It would be great if this would give me some kind of way to restore info on phone after wiping it / back to factory settings.

Thanks again for any help provided…

Grtz, Fleu

Android Debug Bridge or short adb is a pc-program (commandline) which allows several things with android-devices that are coupled via USB. Afaik it comes with Android Studio which you can get for free at https://developer.android.com/studio/index.html.

I’m currently practicing the mantra: PATIENCE STAY CALM PEACE WAIT
while the Android Studio thingy is downloading (thanx for sharing link, wiz !), followed by installing it on my computer. Yeah, it’s an ‘old’ Acer laptop (2009), running on Windows 7. The beating heart of my digital world!
(in case someone wonders, I tried W10, installed it, let it run some time, and went screaming back to W7.
Maybe one day, with a new laptop or something, I’ll give W10 another try. (I don’t need it for work)

Breathe Innn…Breathe Out…for over an hour now…
I stay hopeful!
Will update here on results or other new developements connected to this issue…
I WANT MY PHONE TO WORK!

Gtz, Fleu

I don’t wonder. Some years ago i went to ubuntu… :sunglasses:

Meanwhile i made a new attempt with removing SIM-cards and SD-card. Only SD-card was nearly full with 2 GB left. Internal storage should have some GB more. I think internal storage has at least 10 GB free.
But no success, phone still doesn’t start.

Greetz
Wiz

Hi All,

Over two hours have passed. Around 12h it seemed Android Studio was installed…So I tried to open it, run it, whatever. This unfortunately gave an error…end of the matter was: TRY AGAIN.
So, uninstall Android Studio, download again, install again. It’s currently at 69% of extracting.

By the way, my phone, in Android Recovery, says, on top
Fairphone/FP2/FP2
6.0.1/FP2-gms-17.04.8/FP2-gms-17.04.8
user/release-keys
Use volume up/down and power.

I think this means that in theory Android 6 is somehow somewere on my phone, which is YEAH.

I’m not sure what can be done with the Android Studio, when it is finally installed…
I manualy made a backup of my phone on 19th of April:
-> INTERN (by selecting what was shown in whole folder, copy paste to special seperate storagefolder outside my phone)

So, before I will, (probably soon) deside to select ‘Wipe data/factory reset’ is there ANYTHING that should stop me from doing that?

I really apreciate comments, and learn all the time. (Android Studio now at 78% extracting)

Crossed Fingers…

Fleu

Once you have installed Android Studio don’t open it but open a command window and enter ‘adb help’. Luckily this will work. adb provides some options to backup and restore and many other things. Unfortunately i’m not experienced with it.
Good Luck!
Wiz

Command window:
Hmm, i think [Windows-button] --> Apps (maybe page down) --> list named system tools --> ‘execute’. Then a s small window should open where you can enter a command. There enter ‘cmd’ and hit [Enter]. Now a command window should open.

I’m restricted to 3 replies therefore i have to edit my previous posts…

Ok…Android Studio is installed. Press Finish, launch it.
“No JVM installation found. Please install a 32-bit JDK
If you already have a JDK installed, define a JAVA_HOME variable in Computer --> systemproperties --> system settings --> etc…”

(My phone is still connected by USB to laptop)

Above is jibberish to me. I think there is not much else to do than the RESET.

No Idea how to (if any) retrieve anything from backup of 19th april. Will it conflict because at the time it was still Android 5?

Realy sad, now.
I guess Umbutu is wonderfull!
I’m still trying to grasp/understand my old Windows and Android…same with the going to OpenSource and stuff, Would like to, but can’t run before I’ve learned to stand…

Greetz,
Fleu