Bootloop after Marshmallow Update

Just for my info: it means I will lose everything that is not saved on my SD-card? Pictures, movies, sounds, everything :s ?

Today’s update refuses to update with disabled Google app. The accidentally offer last Wednesday came without any warning.

But I updated today. So the app was enabled. After the update was done, my phone functioned normally.

Then I switched of the Google App, then went to the proximity sensor, recalibrated it, it asked me to restart the phone, so I did, and since then it’s in a loop.

1 Like

Can’t you reboot into recovery and save your data partition so you won’t lose pictures, movies, sounds,…?

Not even rebooting is an option: when I press the power and the volume-up button, it shows me the Android-robot with a red warning-triangle in the middle, saying ‘Geen opdracht’ (which is Dutch for ‘No task’)…

Then (when you see the lying robot) press power button and then also press and release vol up button. Then you’re in stock recovery.
Maybe better is to use fastboot to boot TWRP recovery.

Hey, thanks a lot, that worked.

Uhm, I’m not an expert in this at all. So I did reach the Android Recovery menu, not sure how I could now make a back-up? Should I re-insert my SD-card; could I copy everything to there? (and what is TWRP?)

Thanks in advance!

I think flashing TWRP will cause boot-loops again with the next update - Android 6 doesn’t seem to do good with any modifications.

Maybe a weird question: but is it not somehow possible to reupload the old Android version?

I’d not flash it. Just boot TWRP. Then you can copy your data to the external sdcard.


Sorry guys, what is flashing and what would TWRP be?

“TWRP” (Team Win Recovery Project) is an “advanced recovery image” where you can do MUCH more than with stock recovery.
You may have a look at this:

Once you have managed to start TWRP 3.1.0-0 it’s easy. You go to “Advanced->File Manager->sdcard” (or whatever folder you want to save), click on the “copy folder” icon, select /external_sd as destination, navigate to any folder you want to copy your data to and press again the “copy folder” icon. Then it’ll copy your data (fotos, music, … or whatever you need).

1 Like

Thanks, unfortunately I can’t get TWRP 3.1.0-0 working. I followed all the steps, but my phone just keeps on showing ‘Fairphone’ on the screen; nothing happens.

Then your phone is probably still in fastboot mode and waiting for fastboot commands through USB.
Did you try something lilke that? (if you’re working with a PC)
C:>fastboot boot TWRP_3.1.0-0_signed.img
< waiting for any device >

Yeah, I tried that, but then my computer asks which command I want to give, and it gives me this whole long list of options:

'usage: fastboot [ ]


flash [ ]
flashing lock
flashing unlock

flashing lock_critical
flashing unlock_critical

etc. etc.

It says, when I type ‘fastboot boot twrp-3.1.0-0-fp2-signed.img’:

‘No such file or directory’.

When I type ‘fastboot twrp-3.1.0-0-fp2-signed.img’ (what I accidentally did the first time), then it gives the list of options as I wrote in above message.

Ho, my mistake, I apparently put the file in the wrong folder; slowly making progress here.

Sorry for all the fuzz and questions…

1 Like

Can somebody please test that with a non-Fairphone with Marshmallow? (But please be aware that this phone maybe goes into a boot loop, too, so you should do a backup and know how to reset the phone.) I want to know if that is a Fairphone-specific bug.

1 Like

I got the TWRP working, but even though the data on my phone were in total less than the size of my external SD-card, it gives an error (which is probably related to a full SD-card (although I inserted it being totally empty).

For me, the most important thing, is to get a copy of my pictures and movies (seem to have those, even though the copy of the folder ‘data’ did not fully complete) and a copy of my contacts and messages. The rest I don’t care about.

So, long story short: do you / anyone else know, from which folder I can copy my contacts and messages?

Thanks in advance!

As far as I have seen, the updater did not tell me this.

Now I have the boot loop.

Again, this is a major disappointment and another mess-up in Fairphone communication.

Thanks to you @paulakreuzer, though, I unrooted the phone first.. This prevented me from sweating a lot, I guess.

Now, I know what caused the bootloop : I disabled some google apps (google play games, google play music, youtube). Since when disabling apps caused a system to bootloop ? They are not even system apps !

Now, let’s move on.

If you want to backup your data, please read below !

Go to : @retsifp has done another good thing for the community by publishing the TWRP tutorial.

Once your phone has rebooted into fastboot, there are some things to know :

  • When using fastboot, your phone is reachable using adb. You can copy the pictures to the sdcard : cp -R /sdcard/DCIM/* /external_sd/. Please note the ‘*’, which will NOT copy the .thumbnails directory of the /sdcard/DCIM directory. You will spare a few worthless gigabytes.
  • TWRP has a “backup” feature. I don’t know what it’s worth, but since I’ll be doing the long leap to FPOS, I guess this will help. Anyways it’s better than nothing …

I’ll update this post later if I manage to do something. Fingers crossed !

I do not, sorry …

EDIT : I didn’t disable google play, merely google play music & games
EDIT2 : After my first try, it didn’t work, I had to wipe the phone using TWRP in FPOS.