Bootloop after Marshmallow Update

FYI - The instructions given do not seem to work for me. I have tried this (twice - to make sure) and I still end up in a boot loop:

  • Have disabled assist.
  • Have disabled Google App.
  • Still end up with an unusable device.

For my third attempt I supposed I will have to tolerate google’s continued intrusion for the moment.

Does anyone have any further advice?


nitpicking: It’s recovery project, not run project.


i have miss something… i have reboot the phone to go out the bootloop (and losing all my data)

the operation succes and i have had the possibility to manage the phone (install app, turn off the google apps, …)
but when i have restarted the phone to test, he bootloop again with the same message “Fairphone Change is in your hands” and with several optimization of my apps.

what else can i do more ? (not touch the google apps ?)


Please read the second post which is marked as the solution of this thread.

1 Like

Ok, Thanks, it’s all good :slight_smile:

I think they are, as usually GMS are system apps (though I can’t check as I don’t have them installed)
Anyhow, I wouldn’t be surprised if Google simply does not allow to deactivate their apps.

I confirm Youtube is indeed installed in /system/app. I don’t remember about the others.

What I meant was that Youtube, although installed in /system/app, is not per se an app that requires system privileges …

Plus, I disabled the applications using the application list, and not using the usual shell script I use after each update when my phone is rooted.

Nothing prevented me from disabling those apps neither …

Anyways, now that I made my leap of faith to FPOS, I’m eager to get Marshmallow :slight_smile:

Hello everyone,
I am stuck in the bootloop as well because I turned off the google app.
Now I tried to hard reset my phone. I get to the ‘resting’ android but pressing the power button (or any other botton) does not open the menu.
Thank you for your help in advance

Recovery changed a bit.

You have to:

1 Like

Ah, I jumped to the extended Guide and didn’t see the new quote. Thank you very mutch!

Hi there. Thank you for all the great comments!

Did anyone manage to restore their backups and/or copied data + apps?

I ended up in bootloop but managed to do a backup with twrp in fastboot after that. I also copied all the data on the internal storage.
However, every time I put the backup on the phone I end up in bootloop again. Has anyone got an idea for an easy way to get my data and apps back on the phone without manually reinstalling everything or ending up in bootloop?
Any suggestions much appreciated!

Hello! I am having Problems with my fairphone 2 after the upgrade as well. It basically seems to have broken my phone completely. There’s three aspects of the Problem and only one is the bootloop but I cannot solve it the way it’s described here. 1st: when it upgraded, at some Point it just completely froze without finishing. After nearly a day it still had not finished and the Screen was completely frozen. It could not be turned off either. I had to remove the battery for it to turn off. Problem was after that the phone was pretty much dead. I cannot turn it on at all when the battery is inserted, even when it’s hooked to a charger. I have to remove the battery for it to actually do anything at all. When I do and I try to turn it on, it starts up for a few secs to the fairphone Screen and then turns off again and then starts up again, repeating this endlessly. I cannot Access recovery mode. Pressing the Buttons does nothing. Can the update or me taking the battery out have damaged my phone or the battery on a Hardware Basis? And do you have any idea what I could try to get this Thing up and running again? I don’t really care that much about the data. It wasn’t much to begin with. Any help would be appreciated. =(

You can try to flash the binary images manually (method 4). This does not require recovery mode.

(BTW, the easiest way to get fastboot is to download the Android SDK Platform Tools. It’s a small package and doesn’t require installation.)

I killed youtube the moment the UI became available to me, what with the recent permission requirements.
I still haven’t found the location of the assisst setting, however.

If the reason for you to end up in a bootloop is that you disabled the Google App then restoring the apps will always get you there again. You could try reinstalling Android 5, restoring the backup there (without restoring the system of course), re-enabling the Google App, backing up again (just to be safe) and the upgrading again to Android 6.

Try the battery reset described in the #batteryguide. Once the LED lights green try to go to #dic:recoverymode and do a #dic:hardreset.


Thanks for your patient and competent advice! Sounds like a plan worth trying! In terms of the Android 5.1 file, I found these files:
I’m not really confident with binary images and I couldn’t find a description of how to use the flashing script. So, my plan would be to flash the latest flashing image with TWRP in fastboot, apply all updates until I reach FPOS 1.13.0, recover my data (except the system, of course) from my backup using TWRP, re-enable the Google App and upgrade.
Does that sound right or is there a more meaningful/faster solution?


Yeah that sounds about right.

1 Like

###No reaction of the phone after stopping bootloop

I was stuck in the bootloop, most likely because I disabled the google app.
The phone was now bootlooping for like 2 hours without any change, so I decided to take the battery out to manually turn it off and try to get into #dic:recoverymode.

However, after taking out the battery the phone doesn’t react any more at all. When I connect the charging cable, the LED starts slowly flashing red. I can’t either turn the phone on by just pressing the power button, nor can I go to #dic:recoverymode.

Has anybody the same problem or a solution to my specific problem?

thank you! that solved the problem!

1 Like

Jesus f Christ no wonder the search for assist didn’t yield any results. Never expected it that deeply hidden.