Bluetooth audio bug on Android 12

I am afraid that there is no workaround. I also tried different settings (+dev settings), repair, …

So this is another bug and not this one?

Have you reset the Sennheiser BT device and tried newly connect?

I connected my headphones (Sennheiser HD350BT) this morning, and they would not play.

So i disabled, as suggested, AptX and they started playing again. Out of curiosity i opened the developer options to see which Codec they use, to see that disabling AptX in the “Bluetooth Device Settings” completely disabled HD-Audio.

Since there are other HD-Codecs which are supported like high bitrate SBC and AAC, this will lead to those enabling the workaround with worse audio quality.

Having manually enabled HD-Audio again, and selecting AAC everything works as expected :slight_smile:

Edit: Oh no, seems this is no viable workaround either. Having restarted my Fairphone, enabling HD-Audio in the developer Settings seems to enable all HD-Codecs with AptX being the “default” one. Either i manually chose AAC / SBC in the developer options on every connect/reboot or i disable all HD-Audio Codecs.

1 Like

Same happening to me since updating to android 12.
My handset spec states aptx compatibility but the headphones are mute.

Changing the codec in developer option to AAC works, but at every coupling the preferenze Is Lost.
Disabling Audio hd: audio Qualcomm aptx in the pairing settings works, but feels like going back.

Waiting for a fix from fairphone!


this is my first Post :slight_smile: . I have the same issue and this made me very sad.
I use the Soundcore Liberty 2 Pro Earbuds and i love to hear music. The Qualcomm aptx HD Audio Codec doesnt run under Android 12 :frowning: under Android 11 all works fine I hope Fairphone fix the Bug!

The post has now been marked as “solved”, which is not the case at all. It would be nice if there was feedback on this.


Hi everyone,

Thank you for flagging this. Our software team is aware of the issue, and are in the process of validating a fix. I can’t confirm if it will be ready for the next release but I’ll keep you posted.

In the meantime, disabling HD Audio in the Developer options is a viable temporary workaround.

Apologies for the inconvenience.


Thank you for taking our concerns seriously :slight_smile: .

With the switch under the Bluetooth settings of the headphones, as in the picture above, it can disable the HD Audio aptx option without the developer menu.

I have those ear buds, too.
EDIT: Sorry I misread your comment: I do have the Liberty Air 2 Pro.
I updated them to use LDAC and that is still working for me.

1 Like

You have to explain that to me in a little more detail. What is LDAC mode? And how can I activate it?
I have firmware v1.28 on my Liberty 2 Pro. Under the Bluetooth settings I have no LDAC function. I don’t have access to the DEV menu.

Had the same problem and same solution today.

  • every video was stuttering as long the BT headset was connected.

I think Aptx is really not important, so shocking bug but no real problem at least.

My firmware version is 5.63. You can upgrade it via Soundcore app from the playstore. Then there is an option to use LDAC as codec for better sound quality.
EDIT: Just found the possible reason: I have the Liberty Air 2 Pro. Sorry for the confusion.

1 Like

I have the same issue with Aptx not being able to play audio. Instead the media is constantly pausing and unpausing.

  • Aptx worked on Fairphone 4 with Android 11
  • Android defaults to Aptx instead of AAC. I would have to switch to AAC in the developer options every time my headphones connect
  • For now I can deal with it by turning off HD Audio and using SBC but it’s slightly worse quality-wise

Does anybody know if there’s a way of disabling Aptx as an option?

1 Like

Just found this thread while having the same issue with my new Fairphone 4 and Sony WH-1000XM3s. Pleased to see that Fairphone team are already on it!

SBC audio not terrible in the meantime but it will be nice to have the LDAC setting persistent

1 Like

Same here :frowning_face: : since my FP4 upgraded to Android 12 FP4.SP1Y.B.041.20230109, my Sennheiser Momentum 2 don’t play any sound any more.
Am very looking forward to hearing Sennheiser Momentum 2 playing sound from my FP4 again.

BTW: Bose SoundLink Mini is working fine, and so does an old Plantronic PLT_M55 headset.

Update: switching off HD-Audio aptX does work around the problem for me.

Try this

This can only be a temporary solution, no mini jack and no aptx support are a definite exclusion criterion for me.

Welcome to the forum!

For me the words In the meantime and temporary workaround describe it as a temporary solution here…:

Simply not true.

Was working with aptx adaptive until Android 12.

No clue on how you can tell it like that. See feedback from Fairphone.

1 Like

I’m not lying, maybe misinformed. AptX is not listed as a codec for the FP4 and FP support did mention to me once that AptX is not included due to licensing or something.

@Yasen_Tomov, sorry to drag you into this. Could you confirm or deny this? Does the FP4 have support for AptX? And if not, why did it work before? Was that just a transparent fallback in the background to e.g. AAC? And thus users may simply not notice that they’re actually using AAC. And perhaps this fallback mechanism is now buggy/broken in Android 12?


This supported codec list you show is for playback. Not for Bluetooth.
Otherwise it would say you can play AAC+ or FLAC via Bluetooth, what is not the case.