Black screen Problem (LineageOS 17.1 (post-Jan 2021-version))

after the LineageOS update at the end of January finally resolved the crashing LTE issue, I switched back from /e/ to LOS (preferring an OS without microG).
In order to do that I reinstalled everything from scratch.

A new problem has emerged:
If a call comes in while the screen is switched off, it remains black. I can answer the call using the volume buttons (I activated this feature in the dev settings), pressing the power button silences the call and turns on the screen, but I did not find any way to answer the (still ringing) call after the screen turned back on.
Doing the exactly same thing while the screen is locked, yet activated shows an “incoming call” screen as expected.

Looking at the Telephone ( permissions showed all notifications activated. They are greyed out so I cannot deactivate them (I hoped the classic turning it off, turning it on trick might work).

Any ideas what might cause this? Am I the only one? Could I simply reinstall LOS without data wiping my phone?

side note, not necessarily related:
Discord voicechat stops working when screen turns off. I could still hear the other participants, but they could not hear me. Need to investigate further, but I thought I leave it here as a side note.

Maybe this helps you:

…This was a good opportunity to clean the phone from inside, now the calling screen is working again…

It’s working for me ever since!

1 Like

Maybe no LineageOS issue, but one with the proximity sensor:

@d2w was faster, thanks!

1 Like

Right, that I forgot to mention: Recalibrating the proximity sensor didn’t help either! :sweat_smile:

I just dis- and reassembled the phone (in between dusted everything off with canned air), recalibrated the proximity sensor once again (in case the last calibration was botched due to dust) and the problem persists… unfortunately :confused:

Which baseband version is flashed?


One more try on the proxymity:

can you test it with:

In my case proxymity value changes from 5 to 0 cm when I cover the top of the handy

proxymity is on the 2nd page, down right

I can reproduce that, proximity changing between 5 and 0.
BUT I just had another glitch: While I was using my phone (screen unlocked and active) I received a call, but it only rang, no visual indication of an incoming call. (There should be the “Answer” and “Decline” overlay showing up in the top quarter of the screen. It did not.)
The only way to answer this call was (once again) via the volume buttons (the call itself “just worked”).
Is there a way to “reinstall” the Telephone app? I’m under the impression this install is seriously broken…

Edit: Another idea I had would be the permissions regarding notifications might have been corrupted somehow. As I said, it is enabled, yet greyed out, so I cannot deactivate it. Does this indicate anything?

Edit2: The “no overlay glitch” is not reproducible, apparently… I called myself and it worked :man_shrugging:

I just reinstalled the same version of LOS “over” the existing one, without wiping any data. The first test suggests it works, but I’ll give it a few days (last time it didn’t start immediately after installation either).


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.