Black screen after switching to Fairphone OS

Hello,
So I got a second Fairphone 2. When starting up the screen is black and stays black. Searching I found that this might be because of outdated OS/newer screen. I downloaded the manual switcher package (Fairphone open - Android 10) and installed it and voila the screen worked as expected.
But then I decided to go back to Fairphone OS (with google) and switched again (I don’t know which installer I selected the switcher package or the regular (I don’t even understand the difference), and the screen went black again. And now it stays black, no matter which package I install.

Is this a coincidence that something broke while I was switching? Or am I missing something on which package to use.

Thanks for any help.

Bart

To rule out interference from all the OS switching I would wipe the phone and install the OS from scratch to get to a clean starting point again and then to proceed from there, if the problem indeed persists …

@AnotherElk
Thanks.
I tried but at some point in the proces the fairphone screen is used (step 4). I get a black screen.
Bart

Did you also try to manually install the latest FP version, following support article https://support.fairphone.com/hc/en-us/articles/360018801738?

1 Like

Hmmm … I thought a halfway recent TWRP might perhaps work.
In case further installation attempts don’t end in success, you can always try the hardware route …

You said you got this as a second Fairphone 2. So there’s a second display module you could test (and a second phone you could test the black display with)?

@Volker
Thanks for the suggestion.
As at this point I no longer knew what version was on the Fairphone I installed fp2-A10-gms-22.02.0-rel.0-manual-switcher first and then the update you suggested (fp2-A10-gms-22.02.0-rel.0-manual). Screen is still black

1 Like

@AnotherElk
Yes I have a second fairphone that’s working. I switched the screens: so both of them are working the working fairphone. Both stay black on the second fairphone. So I think we can rule out the screen. So it is the main module I guess: hardware or software.

1 Like

Is there no way of really wiping the Fairphone memory clean? Like one would do with a windows computer when reînstalling windows from scratch?
Thanks

I cleaned the contacts with WD-40 specialist contact spray. Didn’t help.

fastboot format and fastboot erase ?

@AnotherElk
Sorry for the late reply (I only weekends to spend time on this).
I’m a bit out of my depth here. I researched the format/erase command. I think they must be accompanied by a partition name. Can I erase all partitions? How do I know which partitions are on my phone?
Thanks

Hi,
so this is what I did.
fastboot erase userdata
fastboot erase system
fastboot erase boot
fastboot erase cache
fastboot erase recovery
installed fp2-A10-gms-22.02.0-rel.0-manual
After restart still no screen.
I removed battery and restarted and … got the Fairphone start screen. But after that again blank.
It was difficult to recreate.
Then I erased even more partitions:
previous 5 + aboot, splash, modem, tz, sbl1, rpm.
Again I installed Fairphone ( I don’t no which one Sibon or GMS, switcher or normal).
And again after restart + remove battery the startup screen came on.
But then I again did all the partition erases and added fastboot oem unlock.
And I think I bricked the phone…
As you might have guesses I had and have no idea what I am doing.

Even though having tinkered a lot with the FP2 I’ve never experienced a similar problem.
So after what you’ve all tried out I’d expect that there’s a HW problem with the core module, unfortunately.

Plz read the discussion here https://forum.fairphone.com/t/fr-gb-black-screen-after-install-fairphone-os/36042/teatime. Hope your solution is in this discussion.
Have a nice day to all the members :heart: