English

Battery symbol in center of black display

Hello, I have a problem with charging my Fairphone 3+. It doesn’t charge, there is no charging-LED. The Fairphone tries to start, when I plug in the USB charging-cable, but than it stops and there is a battery-symbol in the center of a black Screen. Nothing happens for hours. I tried it with different cables and chargers… Is this a battery problem (deep discharge)?
Thanks!

Welcome to our Community Forum :slight_smile:

From your description it could be a problem with your bottom module. Do you happen to know any other FP3 users nearby who could lend you their bottom module (and/or their battery) to test if it makes a difference? If you don’t, have a look if there are Fairphone Angels in your region who might be able to help you testing it:

1 Like

Hi and welcome.

You may find a way of measuring the battery voltage. If it’s at least 3.8V then it should be fine for charging.

You may also want to check the USB port for debris.

And of course you could remove the bottom module and replace it to check it has good contacts.

Failing all the above if the phone is less tha 2 years old then you can exploit the warranty ~ if that’s the case contact support|at|fairphone|dot|com as soon as possible.

1 Like

I haven’t an FP3 to hand but isn’t this normal behaviour for a phone that doesn’t have a battery in it? Maybe clean the battery contacts, both those on the battery and those on the phone - see if it makes a difference.

This sort of thing is an issue with lots of old FP2s, which is it why it springs to mind.

6 Likes

I have an FP3 and with no battery there is no sign of ‘life’

After removing battery to check the above
With a battery present and charging connected and phone still off there is, in this order

  • A flash screen and vibration
  • A battery symbol with charge level
  • Blank screen

Hi folks,
Thanks to You all, specialy to robbert.f! I cleaned the Battery connectors and now it works! So easy, thanks again!

6 Likes

Fantastic! Happy to help.