Apps not compatible with FP2

Hello Friends,

The last update of my Whatsapp just would not load (“download pending”). I uninstalled and tried to reinstall, no better. I cleared cache and data of Play Store and all related apps. I force stopped Play Store, and G. P. Services, I reset apps preferences, I switched of the VPN, I removed and re-added my google account, I allowed installation from unknown sources, and finaly I did the factory reset. Nothing works. And its not only for Whatsapp but for whatever other apps (which I obviously lost when factory-resetting…). I tried to download the APK file on my notebook, but it in internal storage and installed from there, but the phone says the app is not compatible with my phone.
I am getting slightly despaired, I only have had my FP since 4 years and I hoped at least for another 6 but there is little point having it without apps… At the same time, it feels a little pointless to buy FP3, if it only lasts 4 years.

Truth to be told, I am in Chad and the connection is slow. But I used to download apps even here with no problems.

Thank you very much for your help

On which version are you?
Go the Settings,
Go to the last option (I think in English it’s called ‘about the phone’
What does is say by “Android version”
What does is say by “Build -number”

It could be that by the factory reset you are back to the old version of Android 5 and that you need to upgrade your phone by using the app “Updater” which should be on your phone.

1 Like

This can not be, because a factory reset will only delete Apps and user data. The OS will stay in place as is, no other OS version will be restored.
But the phone could still be at Android 5, if over the years the available OS upgrades to Android 6 and 7 were not applied.

This can be.


It would be nice to someday get reality up to your expectation, but at the moment this is just unrealistic. The workings of the industry have to change significantly for that.

Fairphone are trying to influence the industry towards that end, but I guess they would consider it an achievement to reach 5 years at the moment without getting huge road blocks in the way mainly by chip vendors stopping support for their chips when new major Android versions arrive.
(Which made an important OS upgrade impossible much too soon on the Fairphone 1, and caused major headaches for them starting with Android 7 on the Fairphone 2.)


Thanks Lidwien, sorry I should have mentioned it - I have Android 7.1.2 and OS 19.11.2.

1 Like

If you already did a factory reset I suppose you don’t have any data to lose anyway, you could try a manual installation of FPOS: :gb: :de: :pencil2: Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall

If Android 7 is too old for Whatsap…

That doesn’t seem to be the case – at least for me WhatsApp (update 3 Dec 2020) works under Android 7.1.2 (FP OS 19.11.2).


You probably downloaded the wrong APK (for ARM64).

1 Like

Hmmmm, thats sounds a bit scary. What happens in case I screw it up somewhere in the middle? Is it better to wait for a good connection?

Thanks a lot for the advice

OK… where is the right one then?


Your notebook and your FP2 are two completely different devices, so no wonder that this does not work. Go to with your FP2, and download from there.


You can start again with the 4. step and wipe everything again on your phone.
Though it depends a bit how you screw it up. If you follow the steps very carefully, you shouldn’t have any problem in any case.

The internet connection is just needed to download the files on your computer. Once they are all downloaded no need to have a connection. If your connection is enough to download the few files it’s ok :slight_smile:

Following the guide is not as scary as writing the guide, I can tell you that :wink: .
(Admittedly that’s a bit subjective.)

1 Like

OK, i tried and it made me finally phone-free (yey!)
Here is what happens;
The command fastboot devices does not do anything. It just generates an empty line.
I still tried to go further and tried to download the twrp image, but cmd tells me that there is no device.
When plugging in the FP before, the sound of booting a usb device occurred, but it is true that I dont see the FP anywhere in the directories of the computer.

Could it be due to the USB cable? Does it have to be original FP cable? I dont have this one anymore.

Now, when trying to switch on the FP normally, it seems to boot normal, but the screen does not react to touch, so I cannot unlock it.

Please let me know if there is anything more I can try.

Thank you so much


It doesn’t have to be the original cable, but it has to be a data cable. There are USB cables out there which are only wired for charging and will not work for data connections.

With the phone in Fastboot Mode this is normal, there’s nothing for the computer to see in the form of directories or files.
Fastboot Mode only enables the fastboot command to work via USB.


It is a data cable. At least I was able to transfer data from the phone to the computer with that very cable before. I used it to back up all my photos. So what (the heck) might have gone wrong this time?

I tried 2 different computers, 4 different usb drives, I tried to download the latest android driver.
But it still says that it is waiting for any device.

So, I guess thats it… I am going to buy a new phone. Please tell me why it should be fairphone.

If fastboot devices doesn’t find the phone, then the flashing of something with fastboot to the phone (where I suppose this message comes from) will not work either.

If there’s no hardware fault and if you followed the steps and didn’t accidentally skip something, it’s hard to tell remotely what could be wrong.
But if something’s not working out in the process, there’s no harm in just starting over from the beginning again.

You will have to get to the point where fastboot devices finds your phone first, to continue without that will not work.
I just downloaded the current Android SDK platform tools, and fastboot devices as well as flashing TWRP with fastboot works with my Fairphone 2, so that part of the guide is still valid (and there are current reports that the guide has worked for other users).

With earlier OS versions it made no visible difference on the phone whether it was actually in Fastboot Mode, or whether it was just hanging at an attempt to boot.
If your OS is halfway up-to-date, Fastboot Mode would let the blue LED blink permanently, and the phone would vibrate several times to confirm Fastboot Mode was started.
Are you certain your phone is in Fastboot Mode when you run the fastboot command on the computer?

If you happen to have #fairphoneangels (<- see link for info) in your vicinity they might be able to have a look at it in person.

The benefits of a Fairphone haven’t changed.
Doesn’t help if the phone doesn’t work reliably, of course.


You may have a look at this topic:

At least for me personally Sander lists important reasons to choose a Fairphone…

This can be a reason too: