English

App symbols too big since kola nut update

since the recent update to fairphone os kola nut, the app symbols on the home screen are huge! why is this? can I change that? I am sorry but it looks ridiculous.

1 Like

Hi @christinar this is the way because the new launcher was implemented in this update and that has this look. We thought everybody would appreciate it, but I’ve seen some more feedback that not all people are to happy with it.

I did some research and for now your best option seems to be to install a custom launcher.

Nova launcher and KK launcher seem to be alternatives.

I no this is not ideal, but it’s the advise I found for now. I will check with our developers if anything can be done in another way.

Before you install a custom launcher, there is a way for you to play around with the DPI settings on a per app basis. I will post back shortly with some instructions of how to do this - it’s fairly safe as long as you follow to the letter (I’ve done this successfully and been using it on the pre-release version of 1.8 for the last week or so)

2 Likes

Hello everybody.

After updating to OS 1.8.
This is not a matter of taste: The icons are unsharp.
I guess every designer would be turning in his/her’s grave!
How could that happen and how can I change it.
Compare: The icons in the quick access are still alright.

Cheers! <3

2 Likes

Thanks a lot, Chris_R! That would be great.

Would like that a lot chris. I also think the icons are too big and i would appreciate the extra line off apps

Yes please! Thank you, highly appreciated :smile: :blush:

I’ll caveat this with the usual - this is not an official answer to the problem and this solution does allow a greater deal of access to the system than usual so you have to be your own judge as to whether to install the below. It’s not particularly risky, but anyone of a nervous disposition may want to think twice.

1) Install the Xposed Framework:

  • Click on this link from your phone to download the Xposed Installer
    APK, then click on the download to start the installer:
    http://dl.xposed.info/latest.apk
  • Launch the “Xposed Installer” from the Apps menu
  • Go to the “Framework” section and click on “Install/Update”
  • Once the update has finished, click the “Reboot” button

2) Install the App Settings Module

  • After rebooting from the above, Launch “Xposed Installer”
  • Click on the “Download” section
  • Scroll in the list to find “App Settings” and
    click on it
  • Click on “Download”, then click on “Install” when you get a
    pop-up. Then click on “Done”
  • Once installed, you’ll get a notification message on your status
    bar saying that the module is not active. Click this message (or go
    back to the main menu on the Xposed Installer and go into the
    "Modules" section)
  • Click on the tick box next to “App Settings” to enable it
  • Reboot

3) Configure the App Settings Module for Fairphone Launcher

  • After rebooting go to All Apps and launch “App Settings”
  • Scroll or Search for “Fairphone OS v2” and click on it
  • Click on the On/Off button at the top to activate first
  • Change the “DPI” to “225” (you can also play with other figures, the bigger you make it the bigger the icons will be. I think 240 is the default setting. If you play around with this, change it in small increments)
  • Change the “Font Scale” to “95” (you can leave at 100 or change to a different figure depending upon your preference)
  • I have also ticked “Apply res to widgets” so that it applies to widgets, but you don’t necessarily need to do this
  • Click the “Save” button at the top right
  • Click “OK” to Kill the app so that it relaunches with the new settings
  • Now exit the App and the launcher should refresh and the new settings should be active

If you don’t like the results, you can play around with the DPI and Font Scale settings until it fits how you want it. If you really really don’t like it, simply disable the settings by clicking the On/Off button within the app again to disable.

Happy fiddling :smile:

5 Likes

What is not nice, is that the overall look and feel is now inconsistent. The icons on the home screen and in the list of apps have changed, whereas the launcher and the last used apps kept the old appearance. imho, it doesn’t look/feel right, and I liked the old UX better!

@fyok 100% correct look is inconsistent. For me the bigger icons look hazy, and therefore no longer classy.

No please - to play around with a upgraded version that was just published. So my question
about beta test was serious: I wonder what they have tested.

1 Like

Who exactly thought this?
I see even moderators like Chris_R that were trying the beta version for weeks did enormous tweaks to get back to the smaller size -this should have been telling…

Nince one @Chris_R

I wasn’t aware of this Xposed Installer app. I was already running Gravity Box, but for sure am going to look into this one as well.

1 Like

At first I thought it was too big but after two days of testing I already got used to it.
The thing is the bigger icons is actually also part of KitKat where the new launcher is based on, so this is just implemented in the new launcher.
Further I guess it is a matter of taste, some like it smaller, some like it bigger

Though, I understand @Chris_R but that’s just because I am also crazy enough to try all tweaks (even with the chance of not being able to use my FP anymore without a hard reset).
Now if I can only find a way to remove the text below icons…

2 Likes

For me, the big issue was not the size of the icons but the fact that the screen only allowed for 5x4 positions instead of 6x4 in the old launcher.
Will this also change if one follows @Chris_R 's instructions? Or is it just the app icons that are resized?

2 Likes

exactly it’s the sharpnesss that bothers me…

@kgha - Yes, I believe it does (although I’ve not tried). The settings I detailed do change how many icons per row in the All Apps part of the launcher.

@rainer_zufall - The sharpness is better with the settings too

@Herve5 - I think this is a matter of personal preference and not my opinion of the update - see my general note below

@Sietse - glad to be of help :wink:

@tin - you’ve made your point enough times, I believe the Fairphone team have responded on this so I won’t say anything more.

My thoughts on this issue:
When I upgraded to 1.8 I didn’t like the layout and searched the net to see if there was anything that could be done. It’s not an uncommon problem apparently because the settings FP have used are those that Android advocate and this really annoys a lot of people on many devices. BUT it also satisfies a lot of people. The benefit of Android is that it is so customisable - so my advice is that if you don’t like it, change it, it’s in your gift to do whatever you like with your device. Thanks to rooting, you can do many things that you can’t (or invalidate your warranty to do) on other manufacturers devices.

1 Like

Same here - the icons are way too big for me. I have very good eyes and I love having a lot of info on my screen. On my Windows 7 machine I can set the icon size just how I want it. Isn’t that what computers (including phones) should be? Customizable to anyone’s needs? There’s more than one reason I don’t buy Apple products, but in this case the important one is that I’d like to be in control. I want to make the most of the screen real estate.

Weird that although I have good eyes I don’t have a problem with the sharpness. I don’t have a massive number of apps but the icons I do have on my home screen are very clear. Inconsistent with the Latest Used and Most Used apps, yes.

2 Likes

A much easier way to get the old layout back in 1.8 is to just load the “Fairphone Launcher” from the Play Store. It’s the old launcher, so everything can be arranged as before, while still having the rest of the update.

Alternatively (if you don’t want to trust the person who re-packaged the old launcher for Play Store, but don’t want to build it from source yourself) you can open some older software image .zip file, grab FairPhoneHome.apk from the /system/app folder and install that.
Remember to re-disable installation from unknown sources in Settings -> Security afterwards.

3 Likes