Android KitKat (4.4.4) for FP1

Hey Pablo,
you can use either the build-in backup tool (I don’t know about his quality, but I used it), or install Titanium Backup, and do a full backup. Afterwards you can follow the steps in the guide of Urs. Hope this helps!


1 Like

Hello Fabian,

if I can’t let my FP1 work on my pc (another opportunity maybe available) I’ll do the full back up and repeat the useful advice that everyone gave me on this chat. Thanks

Do you mean you have problems to connect your FP1 to your computer?

Hello BrFabian, yes I wanna try to connect my FP1 to my computer and go inside extranet from my mobile. That’s can maybe be the easiest way to don’t update all, in case I can’t I’ll do the suggestion that you gave me. Thanks and seems you have a FP1 and same problems but with more knoledges then me :slight_smile:

Probably this old post of mine helps…?

One would think so…
In the meantime I figured out that the regular X-Posed installer is NOT working on Android 4.4.4…
Solution is found on XDA:

XDA Developers

Xposed for android 4.4.4 is NOT fixed, please compile 87v for sdk19,

Xposed for android 4.4.4 is NOT fixed, please compile for sdk19, aka kitkat 4.4.4. ROVO has fixed the securty update breaking xposed but no one has compil…

Hope this is useful to somebody.

Thanks for you answer, @Hasgar. In fact, this installer (2.7.1) didn’t work for me. But I found the 2.6.1 one, as described in my post. With this one I got it set up! Perhaps you can answer my questions in that post?


please excuse the really late reply, anyway I cannot help you on that one, I did a clean install. Exprerienced none of the problems you described. All data I wanted to preserve I saved with MyPhoneExplorer…

In the meantime I tested the 0.0.3 Version.
Yes, I could observe different problems with stability, all seem to be due to multimedia.

  1. the stock music player does something strange every 5-6 songs. It appears to stop and then restart. Quite often it is not successful, and crashes.
  2. stock camera is really a pain, crashes on a regular basis stateing something is wrong with “gallery”. Open Camera behaves slightly better, crashes less, but does not start properly due to “camera being used by some other app”, which it is not…
  3. Use of media apps drains immense parts of battery. Even if playback is finished battery consumption remains high and the device gets quite hot, unless processes are terminated. (e.g. using VLC)

I have been travelling and was unable to create logs. Hope this still helps a bit.

1 Like

Hi there, I want to try the upgrade on my FP1.
I don’t manage to make a backup of the recovery as explained on the original post: it seems MTK Droid cannot do it on my phone.
Is there an alternative way to do it on linux or windows?

Ok I managed to do the upgrade, thanks for this project!

I have some difficulties to set up dav-droid: I’ve found version on Internet Archive, but the app doesn’t want to connect to my nextcloud. Does anybody managed to set up davdroid properly?

DAVx5 works fine for me on my FP1 (Android 4.4.4). It is not available for free (€ 4,99), but connecting to my nextcloud server worked like a charm.
If you want your tasks synced you will have to install OpenTasks (free on Play Store) first.

Davx5 is free on F-Droid isn’t it?


Yes , it is, indeed. They also mention this on their website (quite at the bottom of the page), but I missed it.
So it obviously is the way to get nextcloud sync going.

I also successfully updated from 4.2.2 to 4.4.4 - thanks!

But: Can anybody tell me, if it should be possible to install Magisk on top of 4.4.4? I simply tried the latest Magisk ZIP via the CWM recovery, but after that FP1 do only boot straight to recovery (after shortly blue screen of FP loading screen) - but do not boot anymore to 4.4.4.
Re-flashing 4.4.4 solves the recovery loop and again boots to 4.4.4 (all data stayed untouched) - but what would be the correct way of using magisk (instead of SuperSU)? My goal would be to bypass safetynet (or makes it no sense in 4.4.4?) for using a Banking app (DKB, Sparkasse).

By the way: DB Navigator in this version is the last version which can be installed to 4.4 - and it seems to work out of the box (no certificate error anymore) .; ticket buying process can also be started (I did not proceed further)). Both did not work on 4.2.2. due to missing/old certificates and missing TLS 1.2.

As far as I know, there is no safteynet on Android 4.4. I never used SuperSU on my FP1, I tweaked it with the Xposed Framework and Gravity Box. You might have a root access or hide with the Xposed Framework. Check that out.


Yes I managed to install Dav5x at last but fist Fdroid told me it was “incompatible”, even with archive repos activated… I’ve installed an old archive of DavDroid on Internet Archive, then F-Droid updated it the Dav5x…

Thank you so much ! It works


Anyone else get a chinese menu after flashing in CWM?

I did factory reset, wiped cache and wanted to keep cwm after boot. now I have a non-touch list of chinese… the only latin characters on the screen is in the 6th option in the list which has eMMC in it.
(if the image upload worked there should be a blurry webcam image of it)

EDIT: I moved around the menus and eventually got to the bottom which booted me into system. I guess the CWM “reboot system” took me to some bootloader/MTK-bios place. In one of the menus there were options to make a test beep from the speakers and MIC1 MIC2 tests - as well as a hardware info screen with the IMEIs etc. It’s amazing the things you can find when tinkering.

Welcome to our Community Forum :slight_smile:

Apparently what you found yourself in was Factory Mode / Testing Mode:


There we go!

You learn something new every day.

After booting into system and restoring non-system app backups everything seems to be working fine, even the IMEIs were both still there ^^)

1 Like