Android KitKat (4.4.4) for FP1

0.0.3 is out!

Changes for this release:

  • Finally some frameworks/av security patches
  • Security patch level is at 2019-02-01 [1] but some patches from later patch levels are included as well

[1] All patches from 2019-03-01 are merged, except for sqlite which apparently makes problems when being upgraded to a later version. If anybody is willing to test this new patch (it will probably break some apps, or maybe it doesn’t but it does have to be tested with a lot of apps) feel free to tell me. All patches from 2019-04 are merged as well.


Thank you very much, @z3ntu, for the new update.
The update to 0.0.3 went smoothly.
And of course I re-installed OpenGapps, as I need some apps that are not available in F-Droid.


Thank you very much, @z3ntu !!!


Thanks again!
No issues observed, neither during nor after the update.
Gives me trust to go on using my bank-app!


I finally found some time to try this image on a donated FP1 that has a broken USB port.

The instructions say that one needs to restore the IMEIs after flashing the image.
But for me the correct IMEIs were shown when entering the engineering mode > CDS Info > Radio Info :slight_smile:
Looks like restoring them isn’t necessary in this case.


BTW, originally I was triggered by a Tweet by somebody who said they weren’t able to run Twitter on their FP1 anymore as apparently they dropped support for the installed version of the Twitter app and newer versions are no longer compatible with Android 4.2.2.

I did some more testing on the phone with the broken USB port before trying to upgrade my own FP1 that I use as backup (e.g. when going to festivals). I found that none of my car-/ride-sharing apps (except one with rather limited service) are compatible with 4.4.4. So there goes the possibility to use the FP1 as backup :frowning:
I tried DriveNow, Moia, ShareNow, Sixt, none of them could be installed and the old versions I have installed right now are not working anymore.

Android 4.4 is just super old by now and many apps don’t support that version anymore because the market share is just extremely small by now (especially in European countries, which most apps we use target) - and targeting e.g. Android 4.4 and lower makes the job as an app developer more difficult.

1 Like

Yes, I know. That post was mainly intended as information for other people who might want to try out 4.4.4 for the first time hoping it would address their app incompatibility issues (it still does for Twitter).

1 Like

That is so sad and true, @Ingo and @z3ntu … I know wanted to upgrade my daily-use FP1 (4.2.2), but I don’t dare it because I wouldn’t be able to reinstall all my apps which works still. I have already to sacrifice a lot of them, e.g. BlablaCar app and other stuff. Very annoying. So in fact the FP1 is dead now, you can’t upgrade the OS and can’t get any more app updates. In a few month there won’t be any working apps anymore, I guess. So I would need another smartphone, but this is another topic…

Well, now I am trying to update my old FP1 nevertheless. But I am stumbling on a problem: when I type su, it says permission denied… What can I do there? How can I give superuser-rights to the terminal app (if this is the solution)?

Type root or sudo, but usually this is not needed. Are you following the installation instructions?

yes. I typed su. sudo wasn’t accepted by the shell… root neither.

Which step are you at and why are you doing anything in your phone’s terminal app?

@hnms had the same problem last year and was able to solve it using a different terminal app (“ConnectBot”).


Is Root access enabled in the developer options / in the the Superuser menu in the settings?

Thanks for your suggestions. In fact, I changed the terminal app, to the same that @urs_lesse referred to in his solution, and now it works! I am so excited, I will do it right now…!

Well, after a bumpy upgrade (first it didn’t seem to work), it’s up and running now!

So now I am trying to get back all my stuff. But Internet doesn’t work… any ideas???

Once I will have it working, I will install f-droid and titanium bckp, and restore my apps… does this sound like a good plan? And get xposed from somewhere…

Thanks for the work, @z3ntu!

1 Like

So somehow by re-installing AFWall+ and rebooting two times, internet works again! :sweat_smile:
But after trying to install Xposed, I went into a bootloop… I made a factory reset… again! Anyone knows how to install Xposed and Gravitybox without bootloop? That would be awesome!

Thanks to all you guys here!

Happy you made it, Fabian. @urs_lesse has a frighteningly good memory :slight_smile:

1 Like

I understood 10% … I have no idea how to make a back up too… sorry about