Android 10 - MicroSD as phone storage

Yes your situation can be upsetting and I’ve seen others have this issue.

How much data will you loose by resetting the phone and reformatting the SD card as external?

When you say “most part of may data was stored on the card” do you mean previous to insertion or data moved from the phone to the card?

It appears however this is not a Fairphone issue but more a lack of clarity of Fairphone and lack of knowledge on the user about the benefits and drawbacks.

I didn’t even consider formatting the SD card as internal as the one I was using was from another phone and contained data I wanted to keep.

The issue for those that choose to use the SD card as internal storage and then have problems is an Android issue which you see from the following link. The method suggested for you may also seem daunting and may not work but may be worth reading.

What would happen if I remove a formatted SD card?

If you format an SD card as internal storage then remove it, applications will lose access to data which leads to considerable disruptions in operations. Fortunately, devices store information regarding the formatting of SD cards on internal storage. Therefore, as soon as you reinsert the formatted SD card, your phone should go back to normal.

How may I recover data from a formatted SD card that becomes unreadable?

When formatted SD cards refuse to be read, the best options for owners of devices that run on Android would be purpose-design repair applications. Such applications would allow the recovery of important data inside corrupted cards and they could restore the card themselves too.


I’m having the same issue. I’m using a PNY Elite Class 10 UHS-1 microSD Memory Card - 128GB

Maybe you would like to detail your problem?

It’s July 21. And I feel extremely frustrated and angry about the fairphone. Imagine you buy a phone, then you plan long holidays out in the nature and to be safe you have enough space you bring an sd card. Cause It says on the phone you can put in one of those. At the middle of the trip you run out of space and realise that you could just use that sd card you brought along. Well that’s what I did and then all of my pictures of the trip and the last months were gone. And the opportunity to take new pictures was gone as well. Now I’ve spend several days trying to recover the stuff with no success at all. I’m working with editing and cinematography. I’ve been recovering a lot of data that seemed gone and most of the times I was successful. Not here.

The most terrible thing about this is, that this thread is nearly a year old. And the bug is still not fixed?! And please don’t tell me it’s a bad idea to use a sd card in this way. It seems like the most natural thing to do. Selling a phone in this shape should have a huge sticker on the backside saying “DO NOT USE THE SD CARD SLOT!” Or there shouldn’t be a slot at all.

I wish so much somebody had warned me. This is really terrible. I’m ashamed that I tried to encourage people to buy this device.


Hi Dionysos, I really understand your frustration and assume you formatted your SD as internal storage instead of mobile? If so this indeed can cause a lot issues and it is always recommended to format as portable/mobile storage (not only for the FP3). So you can use an SD card (which by the way can break any time even if new), but not formatted as internal storage.


Hi Dionysos Welcome to the forum although not a great time your having.

As @yvmuell has considered you may have formatted the card, once you inserted it, as Internal storage rather than Portable, whereas this issue is not specific to Fairphone when an SD card is inserted the top option is to format as Internal.

a) If you choose internal the SD card is encrypted as are the contents of the Phone memory so you will not be able to view the contents once you remove it from the phone

b) if you remove the card the phone may not function properly as being now a part of the internal memory some app data may be stored on it too.-
For more detail see :-

Check the SD card Settings > Storage to the right of the SD card would be an eject icon if you have formatted it as Portable.

See also comments on the link below you are not the only one with similar problems ~ it’s not really a Fairphone thing.

1 Like

Hej, yes of course. That’s how I ended up here. And I read the whole thread. So of course I know these things now. But I really don’t think any costumer knows these things before formatting a SD Card. I just can’t understand that this option still exists nearly a year after being reported the first time and hope that it will be fixed soon. So less people end up like me.
The only thing to help me, are magic tips on getting back all my pics.


Ok, but I don’t really know how this should help now either.

In case you do not know this, I never used, but have seen comments here, that it helped

That using internal storage is often a bad idea, is def nothing only related/known to/since the FP3. Things with Google and Android are not always that easy as one might think and companies have to go through thousands of approvals before rolling out customizations. So even of I agree that it would be best to just remove this option, it might be Google to blame and not Fairphone

It’s been going on since Android 6 . It was happening in FP2 days etc.
Fairphone. I’m not sure there is a fix but a warning may be useful that’s if people read all the instructions manual etc, which of course do not come with the phone.

As far as recovering more info may be usefull.

Did you have photos on the phone before inserting the SD card?
Did the camera continue to save or stop?
Have you removed the SD card and done anything to it i.e. try to reformat it etc.
Is the card back in the phone.

OK Have you tried using adb to access the phones memory to see what you can find?

Although I use a Raspberry Pi here is some idea of how adb can be installed and used.

I can fully understand your frustration and I agree with you. Unfortunately, I will have to quote myself:

Fairphone do not consider this as a bug, as they can’t reproduce it. Therefore, it won’t be fixed as long as they can’t hold relevant information. Please contact them directly, all we can do as a community is advising you not to format it as internal storage, and asking Fairphone to remove the option (which wasn’t done).

This community forum is not an official support channel. Therefore, even if this topic is one year old, it can’t be hold against Fairphone for not fixing the bug for reasons explained above. This is sad and unnnerving, unfortunately the only thing we can do here is complaining to Fairphone and providing useful information for fixing it.


Hello all,

unfortunately I’ve experienced similar problems as people who wrote in that thread before me. After more than one and a half years of using my FP3 I’ve added a SD card (SanDisk Extreme 32 GB microSD) and formatted it as internal storage and moved apps and data as well. First everything seemed fine. Around 20 GB of data was moved to the SD card which I could see in the settings. But then my camera app wouldn’t let me take pictures and I also could not open old pictures anymore. After a reboot all my pictures were gone and the storage of the SD was much emptier than before. The phone also asks to put in the SD card though in the settings it appears. When connecting the phone to a computer I just can find the sd card and don’t have access to the storage of the phone itself.

I am still desperately hoping to find a solution to recover my pictures and data and to fix that problem without having to reinstall everything. So if anyone has a good advice I would be very grateful. Has anyone tried the PhotoRec application yet?

I’ve read the whole thread and thanks for all the good suggestions. Hopefully anything is working for me.

1 Like

Hi and welocome to the forum.

Sadly the SD once formatted as internal can only be read from the phone as it is encrypted.

You can connect via adb but I haven’t tried to download anything that way only remove google apps

Thanks for sharing, gsvelto. I tried the process (“From the storage settings I ejected the SD card…”) that is described in your post, but it did not work in my case (FP3+, Android 10, SD Card Kingston 64 GB).

Hi @Sandro.

I’m not sure exactly what you did but to clarify.
if the SD card is formatted as internal it is encrypted and can’t be read outside the phone.

You must remove everthing from the SD card before removing it or if you remove it do not reformat it untill the phone is working and you have all your data secure else reinset and try again.

Only reformat the SD card once a) the phone is working without it and b) after you have copied all the data that was on the combined internal SSD &SD card somewhere safe ~ either off the phone or clearly on the internal SSD memory.

I just had the exact same problem. Did you manage to fix it?

Hello same thing happened to me, did you find a solution?

Hi @Fabiana_Leibl Welcome to the forum

Sadly quite a few people choose to format as internal and come up with problems. There is no single solution, it depends upon what you have done, in detail and what you can do. Generally if you have tried to resolve it by removing the SD and making any changes it will very difficult.

But you haven’t detailed your problem, is it something that doesn’t work, have you lost data etc.