All unsaved data lost after waking phone up..Settings?


I have bought a new used Fairphone 3 last year after mine was broken, I had to flash the stock firmware under different circumstances.

Now since that(so, since one year…) I have the issue that always when I’m in an app or the browser and I have entered some text or actions and I will leave the phone still for 30 seconds and the screen gets black and went into sleep mode, after I wake it up by fingerprint or code, every data I have entered is lost or the web page where I have scrolled down loads again and is at the top.

Yesterday I was so damn nerved, that I wanted to smash the phone against the wall…:face_with_peeking_eye:

Is there maybe a setting which would switch this bad feature off?

And why is this switched on by default, I never had this issue withe the FP3 I had before, my wife also not.

Please help…

You can change that to a longer time in the settings, if it helps to perhaps mitigate this a bit.

I’ve seen such behaviour when the phone is running low on resources.

If you didn’t already reboot the phone for troubleshooting, do it now.
Do you have a lot of Apps open at the same time?


Are you using Battery saving mode by any chance? This can cause pages to reload, I learned recently.


To precise: it might be dark mode which is enabled automatically with battery saver.

Here the explenation in a FP4 topic


Thanks for the many replies, but sorry it doesn’t helps with the problem, a longer screen time is not a solution for me, cause when you use a page and will put the phone away for a time I will open the page and the form with my data has to be there, but in my case it would be empty, and also some apps begin at the start…

I have not switched on battery saving mode,
have now also already switched of dark mode,
have switched of intelligent battery,
nothing works???

maybe a switch in the admin area, which I have switched…

Maybe if you can list the apps where this happens, we might find something they have in common.

In view of this useful info from AnotherElk, @picrard make sure to dismiss apps that you’re no longer needing (and that don’t have unsaved data :wink: ). Are you in the habit of leaving apps “open” in the background, rather than dismissing them?


You might wanna check the phones average memory consumption and/or if an app is consuming excessive amounts of memory for some reason. If free memory is low, Android will close/suspend apps to prevent crashes.

Settings > System > Developer Options > Memory


Did you reboot the phone?

As it’s not the normal behaviour of the phone, in the end you can always do a factory reset or even reinstall the OS from scratch to get rid of something like this.
Unless it’s a hardware problem, but for the moment this seems unlikely.

Hardware … which reminds me … perhaps use the opportunity to reseat the SIM card or check with a different one if possible. SIM cards can deteriorate over time and can cause the most surprising trouble you would never attribute to them.


Yes maybe I will get back to e/os or another google free system, I’m also annoyed of this google advertising…
but this also anoys me…maybe just one day off for backup data, install os , back install data…

I have now tested so many systems but nothing is 100%
also tested Ubuntu and /e/…
does someone have any other recommendation?

Have a look at oslist

Why do you not like e/OS?

1 Like

No, I liked it, but my first Fairphone 3 was dead last year and so also my e/OS was lost and after I got a new one I firstly tried again Ubuntu touch but moved then after some problems with WhatsApp and banking software back to the stock OS but the stock is so damn slow, sometimes I’m waiting many seconds open an app… that’s very funny when shooting a photo quickly…

So will watch the list, but maybe it will be e/ again, the only thing wich is a mess is that im using a kodi remote called Yatse and I have bought it once on the google store and still needs connection to it, the fake google microG don’t work …

No, sorry, have told you wrong, I have used iodé os…
that was great, have used /e once but had a little bit problems with it…

So, just for Info, I have installed iodé OS and it is much faster than the stock
and I have my lovely shortcut for the torch(one longer press on power button) back.
But the cache problem still persists, maybe there is really some hardware fault,
which chip could it be on the board, is there something for the cache for the programs?

Or is there this error, because of I had to erase something for the security pattern, like in a post one year ago??? :woman_juggling:

…damn… I have now factory reseted my whole phone :face_with_symbols_over_mouth:
after not reading till the end this post…
:see_no_evil: :hear_no_evil: :speak_no_evil:

…hm, maybe someone could confirm my suspicion… :person_shrugging:

after I have locked the bootloader, I’m now able to open apps or websites,
lock the screen, and when I unlock, the apps or websites are still at the same position or page
or adjustment, maybe I have solved it now…

…but as I said, I’m very happy again to use the Iodé OS…
runs very smooth :smiling_face_with_three_hearts:

Sorry for deleting the SOLVED, but after some days using, I have the same problem with apps,
when I open them and lock the screen and unlock, the app will reset, have the problem in SIDAMP, Wahl-O-Mat, and others, the problem is, you can’t run the app in the background, so when you unlock the phone the app start from the beginning, sound stops and my playlist is deleted, all cleaned.

I have’nt changed any settings? :pensive:

I guess maybe you found an answer. Make sure your critical apps are allowed to run in the background.

Settings > Apps > App battery usage >
Choose the app and accord Unrestricted.
This will probably lead to higher power consumption.


Yes, I’ve got it,!!! …after my old sd card crashes, I put it out and all worked fine,
after putting in a new one the same problem…

Yes, it’s the kind of using the sd card, but what do I have to do to use it,
maybe there are some folders which are the problem,
or is it the kind of formating, the sd now is exFat?

For advice about SD cards read here:

and here:


Thanks to all for this discussion about the cache problem :slight_smile:

Yes after formating the sd card in the Fairphone 3, which also parted the sd(pic2),
it worked, I have then also just copied pictures and some media to the disk,
without any kind of config files, the first picture(pic1) shows the stock format of the sd card,
its an Samsung EVOplus 128GB, it works now the formating with the Fairphone 3 configures this kind
of structure as shown in picture no. 3

Thanks, I hope now this kind of problem will stay away…

1 Like