All of the sudden I cannot make calls, just nothing happens

Hi there, I have a serious problem with my FP2. Yesterday, my phone ‘rebooted’ without any notice (i only found out when i picked up my phone that i had to enter myPIN again…) and since then i cannot make phone calls anymore. I do receive calls without problem, but when i try to phone someone, it starts normally but then stos before there is any tone. I just stops and i’m back to the overview of recent calls and my latest call is not in there.

I have done online research for the cause, and i found the problemshooter in case there’s the text 'cannot make connection (or something like that)" but in my case there is no notification whatsoever. And I don’t use 2 SIMcards.

So… i’m curious if anyone can help me?

Hope to hear from you

What happens if you put your simcard in the other slot?

Have you tried clearing cache of your dialer app?

1 Like

Thanks for the tip. The strange think is that it seems to work, but only
for 1 phonecall. After i switch SIM i can call some one but when i hang up
i cannot make a second call. Seems that something happens during
connection? Any more tips?

Thanks in advance


Thanks for the tip. I tried it but doesnt make a difference. I did notice i
have 2 dialer apps??? I cleared both…

Any more tips?

As the upgrade to Android 6 is coming very soon, perhaps you can wait a little bit longer.
There is a small chance the Android 6 is solving your problem.
Please make already a backup to be prepared for the upgrade.

Any idea when we can expect the upgrade?

Tomorrow at Fairphone in Amsterdam Android 6 launch event. So I would guess this week or the next end of april for Fairphone ‘normal version’, for Fairphone Open I guess it will be May.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.