English

Alarm clock doesn't work properly after Android 7 Update

alarm
Tags: #<Tag:0x00007f57d392e578>

#1

Hi Fairphone Community

Last week I updated my Fairphone2 to Android 7 (Fairphone OS 18.09.2).
Since then, my alarm clock is not working reliably in the morning. Some days it works perfectly fine, other days I wake up waay too late to find a message of a missed alarm.
When I tested it during daytime I never had any problems. Today in the morning I noticed that the alarm went off, but after 1-2s the phone “rebooted” (“change is in your hands”-screen with the dots), silencing the alarm and setting the “alarm missed” message. Same with a second alarm I set a few minutes later.
Interesting point: I don’t have to type my PIN code after the “reboot”, so it doesn’t seem to be a “real” reboot.

Does anybody else have this issue as well?
I keep my phone on flightmode during night and plugged in for charging, so the battery should be fully charged.

Have a nice day folks

Stefan


Several events delayed for hours, calender alarm, sms, countdown timer
#2

Fortunately didn’t experience this issue here. I don’t charge my phone over night as it loses only around 3-4% of its battery level over night and I don’t have flightmode on but use do-not-disturb instead.


#3

I have several of those “soft reboots” every day since the Android 7 upgrade, so I can confirm this part. Fortunately so far this never happened when the alarm went off. But I use a third-party alarm app, so not exactly the same scenario.


#4

I have been using “fake dawn” as alarm and after the update to Android 7 it worked twice as expected. However, the 3rd time the alarm only rang, when I picked up the phone to check the time - it was 45 minutes too late.
My theory is that Android 7 uses a deeper sleep mode which keeps also the alarm asleep. During the nights when the alarm worked properly I had checked the time during the night as well, so this woke up the system. The 3rd time I did not do so, so the phone was able to sleep for 7+ hours, so was the alarm.
At least this is my theory.

3 days ago I also found the phone had turned off during night. The evening before battery was supposed to last for more than 1 day. And actually when I started to load the phone afterwards it showed a remaining capacity of 25%. So it did not turn off because the battery was drained.
But I think this is not related to the alarm issue. I will take my 5€ alarm with me now, like in the pre-smart-phone-time.

Some technical details: Fairphone Open, up to date Android, no root, no Google stuff, nearly 2 years old.


#5

Similar to your problem, not the build in alarm (never so far I know), but with the build in email program…
I’m running linageos, but this also happened with android 6
My workaround is to automatically wake the phone from time to time


currently: every hour, with screen on, but not at nights! :sleeping_bed:


#6

Hi,

I have exactly the same problem. I have a FP 2 with multiple parts already exchanged (screen, top and bottom module). No clue if that matters.

No solution so far except a second alarm on another device…

Cheers,
Philip

Edit: Additionally I now experienced another “soft reboot” during a phone call…


Time stands still
#7

Hi all
In the meantime I tried to observe this issue a little better, but as it never was very reliable I can’t tell that I definitely found a solution.
I found my Fairphone not to be a morning phone anymore. Alarms before 6AM were very unreliable, after 6Am they seemed to work better. When I automatically turn off the “Nachtlicht” option (not sure how it’s called in English, the option to cut blue parts of the lighting) before the alarm, it seems to work better.
There waren’t many people with the same problem, but maybe it helps somehow.

But as it feels like my phone is generally running not as good as before the update, I’m considering switching back to Android 6. Shorter lasting battery, some annoying settings etc.

Cheerioh Stefan


#8

I have the same issue, I think.