A few days ok with A11.0025, then boot looping with oem unlocking disabled

Last week, I sideloaded the 0025 update to A11 and everything seemed fine. Then, a few days ago, the phone randomly started bootlooping. Sometimes it even gets to the moving bubble graphic, but Android never fully boots before it starts the loop again. I’m able to access the Recovery Mode though.

Here are the solutions I’ve tried:

  • multiple factory resets from Recovery Mode
  • reloading the sideload update for 0025, but this fails with this error “E:Package is for source build gms-e1827e20 but expected gms-b182be55”
  • unlocking the bootloader with “fastboot oem unlock” to do a clean install, but of course this doesn’t work because I didn’t enable OEM unlocking while Android was still accessible. (error: “remote: unable to open fastboot HAL”)
  • multiple disassemblies/reassemblies of the entire phone, including removing the connectors from the motherboard in case those were loose.

The next step would be baking the motherboard, and after that buying a new one.

My question is: is there any way for me to save this motherboard myself? I tried finding a way for force flash the ROM, but as I understand it, there really isn’t a way to do this unless you are very experienced with Android and the Android tools. That’s why I’m hoping for a solution here. :slight_smile: Again–and I suspect critically–I didn’t enable OEM unlocking because I only was planning to sideload the OTA update and I didn’t know that it would have been critical for a Plan B.

I wouldn’t mind installing Lineage either, if that’s the only solution for whatever reason, but I’d prefer to remain on A11 due to the fingerprint sensor. If A13 is the only way out, I’ll take it though.

UPDATE 1: sometimes the boot sequence does get into Android, but because I performed a data wipe from recovery mode, I have to go through the initial setup sequence and don’t make it far enough to enable OEM unlocking before it crashes and reboots. :confused:

Not sure if you read this!?

3 Likes

Thanks for the link! I realized I only searched FP3 help.

When trying to follow it, though, this is clearly meant for people who can fill in obvious blanks. For example, I don’t have a Linux machine and don’t understand how I should install the edl tool from Github. I tried following the instructions on installing all of the other necessary tools and drivers, but all of the test commands came back with errors. I’m also supposed to download loaders, but Fairphone isn’t on the list and I have no clue if there’s an equivalent and googling didn’t produce anything obvious answers. Now I also understand that I need a special EDL USB cable as well to do this.

Now I understand why that thread is under the Development section and not Help. :sweat_smile:

1 Like

I havent ever done this, still my understanding is: you need to downlaod the gpx file, boot into fastboot and flash it.

My understanding is, you can unlock the bootloader enable OEM unlocking with this and then go from there…

Maybe @Ingo has further tipps or can correct my understanding.

2 Likes

Yes, your understanding is correct.

Once the steps from the first post of that topic are done, one can proceed as if fastboot flashing unlock from any regular unlocking/manuall install documentation had been executed successfully.

It doesn’t require any special USB cable. It doesn’t require Linux but works on Windows, too. It doesn’t require to install some edl tool. I’m not sure where you (arizona_deux) read all this.

4 Likes

Maybe following the link at Fairphone 3 unlocking without oem unlocking - #26 by k4y0z (at the end of the linked topic) or the expanded information in post 1 “Thanks to @Ingo for checking that”. Still at post 26 it mentions in case fastboot does not work. So I fully agree that I’d definitely go the fastboot way in the first post of the topic…! :sweat_smile:

2 Likes

Yep, I thought I had to follow all of the steps from the linked post because my phone wasn’t being detected in fastboot mode. I could run the flash command from fastbootd mode though, because fastboot devices didn’t detect any devices in fastboot mode.

After running the following command in fastbootd mode
fastboot flash devinfo devinfo-unlocked.gpx
I got the following error
Warning: skip copying devinfo image avb footer (devinfo partition size: 0, devinfo image size: 1048576). Sending 'devinfo' (1024 KB) FAILED (remote: 'Download is not allowed on locked devices') fastboot: error: Command failed

I probably misunderstood a step though, so I’d be thankful for any ideas if anyone recognizes this error from a workflow mistake. I also attached images of the recovery, fastboot, and fastbootd modes I see, in case any useful information is contained in them.



1 Like

I think this is something you should fix first as I assume the mentioned commands should be run in fastboot and not in fastbootd mode.
Although it’s for FP4 and not for FP3 you might have a look at Black Screen/Booting Issue After FPOS C.073 Android 13 Update - #210 by GunniMator and the following posts as there at first the phone in fastboot mode was also not detected. But after changing USB port and rebooting the device again it finally worked… (and there are other things to check mentioned, too…)

1 Like

Thanks for the tip! Unfortunately it brought me no success, though.

I tried two cables and multiple USB ports while booting directly into fastboot with the command waiting for a device, yet no device was detected. I did get some interesting failure modes though:

  • the phone generally does not want to start with a USB cable plugged in. Even when selecting Restart Bootloader from the fastboot menu on the phone, it won’t actually restart. Sometimes it will start into fastboot using the buttons, however. I couldn’t find a clearly reproducible workflow. Generally, though, I have to take out the battery and wait before it will boot up again.
  • when selecting Power Off from the fastboot menu, it vibrates constantly until I pull the battery out.

HOWEVER: for completely unrelated reasons, while doing this, I connected my headphones and all of the sudden, I heard a Windows alert when I entered fastboot mode. The device was there in the device manager, but without a driver. So I downloaded the drivers from Google directly and told the device manager to search for drivers in the extracted folder, but it said it couldn’t find one. I’m no expert, but this seems like it could be the cause of my fastboot issues.

So currently I’m downloading the Android Studio and will see if that can install the correct drivers. I’ll update this post when I have news.

1 Like

Have you done this to get the driver, so not in devce manager?

3 Likes

Just in case you need a cleanup of an existing driver conflict or similar in Windows…

3 Likes

This fixed my driver issues! Megathanks! :medal_sports: :robot: :calling:

3 Likes

This was the solution to enabling OEM unlock. With stable drivers, it worked fine!

I’m not going to mark it as a solution to my post, though, because I now strongly suspect an underlying hardware issue. I was going to load FP OS for A11, but then I thought about how it was going to be obsolete soon anyhow and the Lineage 20 (A13) installation seemed straightforward enough. So I tried installing that, but had a boot error early on and restarted the process. In the second round everything worked as advertised, but Lineage couldn’t successfully boot.

After the getting the Lineage boot.img loaded:

Following the boot error, I did everything again. Maybe that’s why there’s a “slot b” now?

Lineage wanted to boot but got stuck looking like Agent Smith was taking over.

Did a factory reset from the Lineage recovery mode but the OS couldn’t successfully boot and would go into a boot loop from here.

So it’s the same behavior as with FP OS.

I’m still going to try to bake the motherboard but as far as I can tell, my Fairphone days are over for now. There are no motherboards as spare parts and used FP3s still cost 300+€. I can’t justify buying it, even considering that I might get 100€ back selling the spare parts, because I got a friend’s old Samsung S8 and I’m going to try to install Lineage on that.

So in the next few days I’ll get some ESD bags and post the various modules for sale.

1 Like

What kind of boot error?

Did you also try LineageOS without installing GApps (your 2nd screenshot)?