Word-file downloads as bin-file

Hi there,

Since the end of August I haven’t been able to download Word-files: during the download, it turns into a bin-file, which I cannot open.
Why is this? How can I fix it?


Does it happen to all files you download or does it only happen to .doc files?
Which browser do you use? Have you tried using an alternative to check whether it’s a browser problem? Did you update your browser recently?
Does the file actually work? Test by renaming the file so it has the right ending: file.bin -> file.doc or file.docx. Does that work?
Have you tried “Save as…” in the context menu instead of just clicking the link?

Hi Vinni, thanks for your suggestions. It turns out it happens with pdf’s as well. I have no idea how I can rename the file, there is no context menu. I can only select files to share or to delete. I don’t even know how to move the file from Downloads?
I use the standard browser, no idea what browser that is. Haven’t updated it either, although I have updated my OS to Kola nut 1.8.7. Could that be the problem? Or could it have anything to do with storage? I recently found out I need the storage partition upgrade.

Try using the browser Fennec F-Droid (a FOSS Firefox Mobile clone). It works for me (at least for pdf-files).

You might as well do the Storage Upgrade first because it will delete all data from your phone (you should have a backup - the Backup&Restore app is not enough.)


You can also download Firefox from the Play Store if you prefer that: https://play.google.com/store/apps/details?id=org.mozilla.firefox.

Generally, i would strongly encourage you to switch to either Fennec (see above) or Firefox. They are way better then the integrated Standard Browser. And more secure as well.

1 Like