WIFI is connected but still doesn't work (O2 router Fritz-Box 6431)

I renamed the topic to make it easier to find for others, who also have troubles with the O2 router.

I just tried solving this via the O2 customer service chat and they told me to call their technical support service. Of course for this I need to be at home (now I’m at work). I’ll try tonight and let you know how it went. If anyone is impatient and wants to try now, the number is 0800 5251378 (Germany) :wink:

1 Like

OK, so I called them. You can get a different model router from O2, but it’ll set you back 69 Euros. It’ll be what the support service guy called a “Home Box” which is supposedly a model up from the O2 Box 6431 we all have. No idea whether it’d work with our FPs. So I asked him if I could just connect my old Alice router again, which used to work perfectly with my FP. He said no, because they changed the dial-in protocol, but apparently you can connect it to the O2 box via cable and use it as a sort of wifi booster. So I’ll try that one of these days (again, I’ll report). The other option is an actual wifi booster, which costs money but is still cheaper than the O2 Home Box.

There’s no guarantee either of these will work, sorry I can’t be of more help.

1 Like

My girlfriend is using a Fritz-Box (router) for the wifi. She simply connected the Kabel Deutschland router directly to the FritzBox and let it do the rest.

She did this because if she wanted to use the Kabel Deutschland wifi (the router is capable of providing wifi) it would cost her a monthly fee.

So maybe it is possible to connect a wifi router (of any brand?) to the O2 internet router.

At least other, unaltered, Fritz-Box routers should do the job.

Who knows how O2 changed their Fritz-Box 6431…

1 Like

I am in Germany for a couple of days, in a rental apartment with an O2 router. Because I face exactly the same problem as described here, I am checking the forum. No solution so far - I am not going for the static IP and all that since I am going home in 2 days. I was hoping to make use of free wifi in public places, but these seem to be limited too here.

I had this problem too. This was the only thing that worked for me:

You have to go to the configuration site of your o2-router. Than in the firefox menu go to “Ansicht” - “Webseiten-Stil” and choose “kein Stil” (sorry, don’t know how this is named in english). There you can change the WiFi mode to 20 Mhz. This should solve your problems.


For some strange reason, for me the problem has fixed itself. I did nothing but it has been working by itself for over a month now. I sometimes get the grayed out wifi icon, but then I just restart the router and it works again. Not sure why, but this is why I haven’t posted about my experience with another router - I didn’t end up getting one.

1 Like

I set this topic on autoclose. If nobody else is experiencing troubles with this type of router, the topic will close in 10 days.

Don’t close the topic yet. The Wifi Connection Problem with the O2-Router occured about 2 weeks ago on my phone. So far I didn’t solve it. I wasn’t aware that so many people are having the same problem (everything as mentioned in other posts, except that very few times a day my WiFi works).
I would like to try the solutions mentioned above tomorrow. Would be nice if you wont close it until than. Thanks!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Unfortunately the problem is back, at least for me. After spontaneously fixing itself (I still don’t know what happened), the grayed-out wifi icon is now back with my O2 router after I updated to Kola Nut.
Again the problem is only with this router and it occurs occasionally. If I switch wifi on and off several times it will work for a while. Restarting the router sometimes also works. I’m flummoxed.

Lesson: If you have this router and haven’t updated yet, don’t do it just yet.

I’m not sure if this is the case here but sometimes after a OS update you have to re-enable Google’s Synch function by downloading any app from the play store before the wifi symbol turns blue again.

It think Paul is right.

We discussed related issues here and here, when resetting/updating, your phone gets issued a new Android ID and Google Cloud Messaging ID (I forgot the correct term and acronym). Either you restore from a backup (TitaniumBackup can do this, I think - at least for the Android ID, this is even prompted on opening after the app after an update) or you re-register your apps by turning off sync and/or messaging capabilities in each app.

HTH. :slight_smile:

Thanks for your help, guys. However I honestly don’t think that this is the problem, because I do get a connection with any other router, and even on my router after fiddling I get it to work for a while… until I leave the house, lose the connection and when I come back it’s gray again.

As I understand, if the problem were the Android and/or Cloud Messaging ID, the problem would be consistent and occur on any WiFi connection, right?

I really do think the issue is somehow with the router, but then again I’m not techy at all and what the hell do I know :wink:


You are right that sounds like it’s the router. Did you try contacting O2? Or Fritz(?)?

Briefly said: not just a wifi but an internet problem!?


I am having a o2 problem too (o2 box 6431). It seems to be rather similar to the problem described in this thread. But only similar!
For me it is hard to go into internet via wifi although some wifi checking apps (“Wifi manager”, “Fing”) show, the wifi is working fine. But when I try to access the internet (e. g. via the “Inetify” app or simply via browser), it won’t work. The problem seems to be specific to o2. But it is not just o2 on its own, since my family doesn’t have any problems accessing the internet via wifi with their smartphones (Samsung). So I am afraid, it is the Fairphone that does not deal with the o2 box rightly :weary

Who can help?


Do you have a MAC filter enabled? Is your phone listed there?

At home I have no MAC filter aktiv, but in my office I have, with my Fairphone’s MAC beeing registered, so it is allowed to enter the internet.


Try accessing