WiFi connection dropping on FP3

I have a good quick BT connection to the internet but find that my FF3 drops the connection from time to time. Most of the time it isn’t a problem but it is a real nuisance when I am watching TV using Chromecast.

The problem seems worst when the phone has gone to sleep, During it’s sleeping time the connection drops out and then I have to wait for it to connect again before I can control the TV with my phone.

I have looked for setting to correct this but I have not yet found anything.


Hello and welcome to our community forum. :slight_smile:

Just to clarify, I guess you mean British Telecom by “BT”? I’m just asking because otherwise people here might initially guess that BT stood for bluetooth which would make your explanation confusing to some.

You might want to give this a try:

1 Like

Hi Theo

I wonder what Hub you use and are you connected via 2.4GHz or 5GHz.

From the beginning of my excursion with Fairphone, Oct 2020, I have disabled 5GHz as, although faster, has less range and if you have a dynamic setting on the router it may be switching between 5GHz and 2.4GHz and so you lose connection temporarily.

Also if you are using wifi presumably you can go to Airplane mode which turns of the mobile network. This will possibly stop any other conflicts in connections and you can still call over wifi.

I have two broadband connections, one an old ADSL @ 540KB using an old BTHUB 3 with no problems watching Netfix, though it can’t handle adverts of Channel 4 and 5 etc. they are too high definition and need lengthy buffering…

I also have a FRITZBox for my FTTP only on 2.4 as mentioned due to switching. The BT HUB is so old it doesn’t do 5GHz so no switching ever happens and the FRITZbox is fine now I’m only on 2.4

All the best.

1 Like

I am sorry that I haven’t replied earlier. BT in this case means British Telecom.

In the couple of weeks that have passed since my original post I have had the engineer round. He disovered a faulty connection and has sorted out the problem. It wasn’t FF it was the internet signal.

Thanks for your replies.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.