WiFi Calling A12 Build FP4.SP21.B.048.20230215 on FP4

Hi,
I got FP4 initially running A11. Since I updated to A12 the Wifi-Calling is more or less never getting activated anymore.

Typically use case:
I go to basement, where WiFi is available, but no sufficient cellular network connectivity.

With A11 loss of cellular connectivity was detected (no signal symbol in top status bar), wifi calling icon showed up and further calls routed via wifi (e.g. symbols in phone app got that wifi icon).

With A12 signal strength shows connectivity (half of icon is filled) and wifi calling is not activated. Placing calls will end up with silence, no audio at all (due to no connection to network). WiFi icon in status bar shows full signal strength. Internet working.

I created log with logcat. Started within wifi call system menu, activated wificalling.
Doing grep in log shows these log items:

03-07 14:27:15.678 2842 2983 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = true mMMtelVowifi = false getDataNetworkType() = 2 mCurrentState.voiceCapable = false mCurrentState.imsRegistered = false, regTech = -1

SW Version / BuildNo.: FP4.SP21.B.048.20230215

Any help, any ideas?

1 Like

As this is a version issue not an A12 you could add that to the title, by starting a new topic it spreads new version problems making it difficult to track.

Of course this may just be a setup you have to change and not related to the update per ce

Fairphone are looking at the dedicated thread for the last update for problems. By not adding to that topic you are in effect not targeting Fairphone employees which may warranty more investigation.

All the best

You may like to add it too

Please dont suggest to create duplicates. I will add the Version number

3 Likes

My suggestion wasn’t to copy but to place it there and delete this one if they so chose, but so as to not be commanding I didn’t say move it and delete this one.

I left that to their integrity but I’m often misunderstood so I get that you didn’t understand. I did think of trying to find a similar topic but gave up and in the same vein didn’t ask a moderator to move it to the general new update topic.

I edited the post a few times and see now I could have edited so it was clearer, so thanks for the critique.

What is your provider? Have seen one other report with German Vodafone so far. For me actually WiFi Calling Symbol is visible more stable since A12, though I don’t need it regularly its just turned on in case off…

Maybe this can help somehow?

Yes, provider is Vodafone. But nevertheless, I personally do not think root cause is there. My wife has FP4, as well. Same provider, even sharing same contract. But she still got A11 running.
On her phone wifi calling works as expected.

I rely on that feature, as my office is located in basement without cellular network.
I’ll try to get log from her phone, successfully enabling wifi calling.

Would be interesting if there is certain logging to enable, or increase loglevel of something.

It might still be your provider in combination with A12 something seem to be broken… And especially Vodafone (Germany) showed many different issues with FP3 + FP4 in the past after several updates…I would report to Fairphone and Vodafone

Thanks or the link. I tried that use case:
“deactivate flight mode or connect to wifi” when trying to place a call, so no “hidden wifi call mode” :frowning:

sure. Like to pinpoint that, but I don’t know what exactly look for. If this logcat is sufficient, fine.
Would attach it here, but cannot find how to attach files here :person_shrugging:

I added equal thread to Vodafone Forum:

Just note the forum is not official support line, so it might be better to attach a logcat output to an official support ticket #contactsupport

:frowning: fter resetting the connectivity via systems menü
(Settings → System → Reset Options → Reset WiFi, mobile & Bluetooth)
AND rebooting the device, wifi-calling got operational.
:partying_face:

Here is snipped, that finally got wifi calling running. Maybe it helps.
Again starting in wifi calling menu, activating the feature.

03-13 07:31:46.069  2723  2723 D NetworkController.MobileSignalController(1): onDeregistered imsReasonInfo=ImsReasonInfo :: {1000 : CODE_REGISTRATION_ERROR, 4002, null}
03-13 07:31:46.089  2723  2723 D NetworkController.MobileSignalController(1): onDeregistered imsReasonInfo=ImsReasonInfo :: {1000 : CODE_REGISTRATION_ERROR, 0, }
...
03-13 07:31:46.206  2723  2830 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = false mMMtelVowifi = false getDataNetworkType() = 18 mCurrentState.voiceCapable = false mCurrentState.imsRegistered = false, regTech = -1
03-13 07:31:46.285  2723  2723 D NetworkController.MobileSignalController(1): onDeregistered imsReasonInfo=ImsReasonInfo :: {1000 : CODE_REGISTRATION_ERROR, 4002, null}
03-13 07:31:46.287  2723  2723 D NetworkController.MobileSignalController(1): onDeregistered imsReasonInfo=ImsReasonInfo :: {1000 : CODE_REGISTRATION_ERROR, 999, General_Error17-Unable to connect}
...
03-13 07:32:29.193  2723  2723 D NetworkController.MobileSignalController(1): onRegistering imsTransportType=2
03-13 07:32:29.197  2723  2723 D NetworkController.MobileSignalController(1): onCapabilitiesStatusChanged isVoiceCapable=false isVideoCapable=false
03-13 07:32:30.350  2723  2830 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = true mMMtelVowifi = false getDataNetworkType() = 18 mCurrentState.voiceCapable = false mCurrentState.imsRegistered = false, regTech = 1
...
03-13 07:32:30.361  2723  2830 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = true mMMtelVowifi = false getDataNetworkType() = 18 mCurrentState.voiceCapable = false mCurrentState.imsRegistered = false, regTech = 1
03-13 07:32:31.165  2723  2723 D NetworkController.MobileSignalController(1): onRegistered imsTransportType=2
...
03-13 07:32:31.184  2723  2723 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = true mMMtelVowifi = false getDataNetworkType() = 18 mCurrentState.voiceCapable = false mCurrentState.imsRegistered = true, regTech = 1
...
03-13 07:32:34.470  2723  2830 I NetworkController.MobileSignalController(1): isVowifiAvailable,mVoWiFiSettingEnabled = true mMMtelVowifi = true getDataNetworkType() = 18 mCurrentState.voiceCapable = true mCurrentState.imsRegistered = true, regTech = 1

In exchange bluetooth partly stopped working :roll_eyes:
As the reset deleted the paired devices, I was able to get a JBL Flip 4 and Anker box running again.
In case of rpi based bluetooth box (https://www.picoreplayer.org/), I’m able to finish the pairing procedure successfully and shortly start connection, it finally gets dropped silently after. It even not showing up in recent devices, so I guess even stating “active”, the connection procedure gave up at some point.
Due to fact that other working, root cause may be located in picoplayers bluetooth.

Where is this reset option?

Can’t this be due to the aptx codec peoblems described here on the forum? The reset might clear your custom codec settings.

@peci1

Where is this reset option?

I added to solution above:
Settings → System → Reset Options → Reset WiFi, mobile & Bluetooth

Can’t this be due to the aptx codec peoblems described here on the forum?

got a link?

1 Like
1 Like

Thanks @peci1 , nevertheless seems to be other issue.
Used codec with picore is SBC.
Actually, connection is established and device is listed within connected devices. But when starting playback nothing audible.

But that is different topic, so I’ll further investigate and open new thread or adding to the one linked.