Where is "Disable SIM" in LineageOS?

Hi all,

I have a problem similar to the ones reported in the closed threads Loss of mobile network connection on FP2 and Mobile network won’t work until next reboot with my FP2 running LineageOS 14.1 (20171205-nightly) and one SIM card in slot 1.

The mobile network icon in the status bar occasionally shows full signal but no marker for the network type (LTE, H+, 3G etc.). When that happens, internet and phone calls do not work.

The same thing happened for me on my FP1 previously. There, I disabled the SIM card and enabled it again immediately. That reliably got me a working mobile network connection again.

But now, with the FP2 and LineageOS I don’t find anything in the settings to disable the SIM card.
Where is that switch? Or is it only shown when I have two SIMs inserted?

What I tried and did NOT work:

  • flightmode off/on
  • mobile data off/on
  • changing the preferred network type

The only thing that did work so far is

  • reboot the phone

But rebooting in quite inconvenient. I’d rather be able to quickly disable/enable the SIM card (assuming this would fix the problem when it happens again).

So, does anyone know of a more comfortable way than rebooting for such situations?

There’s no such feature in LineageOS codebase yet. It’s supposed to be in the works, but I’m not able to find the link right now (it was linked multiple times in the huge “Using LineageOS on the FP2” topic).

Implementing it is a hard task because LineageOS is meant for a huge amount of devices, with very different chipsets and hardware.

1 Like

Does the FP2/Lineage port also have an option for ‘automatic network selection’? On the FP1 selecting this option (even when it was marked as selected in the first place) would cause the phone to re-register itself on the network - this usually fixed connectivity after a short wait (~ 1 min, iirc - the registration isn’t instant, and there is no progress indicator)


See https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/5

1 Like

I had good success with a root shell and typing

svc data enable

(Or first disable, wait some seconds, and then enable)


Thanks everyone. At least I know I’m not blind :wink:

Next time it happens I’ll try the suggestions to either use the automatic network selection option or the root shell command.

I’ll let you know about the result.

It happened just now.

Unfortunately both suggestions didn’t work :frowning:

  • Tapping “automatic network selection” just claimed it registered with the network but nothing changed (list of available networks was empty)
  • “svc data disable/enable” seems to be no different than the “mobile data enabled/disabled” from the normal system settings (and didn’t help)

Back to reboot it is, then.

For me, it indeed did (something) more than the switch in the gui. Don’t know why, really…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.