Whatsapp only receives notifications on WiFi, but not on 3G/4G

Hello everyone,
Petz, is working for you now?
Just got my new FP today, and whatsapp works only with the wifi. I can’t send or receive any message with the 3G/4G data… :frowning:
I’ve read and tried all that was said about the restricted data and so on, and it seems the problem is not coming from that.
I’m wondering how to see if there’s any problem with GCM, and how to deal with it?
Stefan, the link you have provided is about the FP1, and it seems instructions are a bit different, I can’t find my way out there… Please help ! Thanks a lot…

Just to be sure, normal data, surfing :surfing_man: the Web, for example, works on mobile data?

Yes Ben, it does ! Everything works works through the mobile connection, only WhatsApp refuses to send/receive any message, unless Wifi is activated…
Actually on the precedent old topic regarding the same thing, it was said that GCM (Google Cloud Messaging) should be checked, probably it doesn’t work so well.
I just don’t know how to do that ! If anyone can help here it would be really welcome, because being always on international roads, I need whatsapp really bad… :tired_face:
Thanx !

I just found out where was the problem ! Actually I checked the WhatsApp Q&A, and it explains well that sometimes this bug comes from the APN connection.
Therefore you need to go to Parameters - Mobile Networks - APN (Access Point Name) - Full Internet SRR
There are several options offered, just make sure the “Full Internet SRR” is ticked. In my case, the “GPRS SRR” was ticked instead.
Now it works perfectly !
Many thanks to my dear partner, who brilliantly found the trick ! :wink:


Thanks for reporting your solution :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.