English

FP2 Open: no Whatsapp notifications

Hi

I have a problem with Whatsapp running on Fairphone 2 (Android 7.1.2) under Fairphone Open 19.02.1. Whenever the phone or Whatsapp are in use (i.e. I use the phone and do something or I do something in Whatsapp), I receive messages without problems. In contrast, when the phone is not touched for some time, messages are not received. For example, returning to the phone after 5 hours, no Whatsapp notifications are shown. Then, if I open Whatsapp, suddenly 10 messages are shown which were sent during the last 5 hours. This is annoying since I need to open Whatsapp just to see if there are new messages.

Whatsapp was installed from the official .apk (version 2.19.150). I checked this and this post. However, the two options

Settings -> Apps -> Whatsapp -> Data usage -> Background data: Enable usage of cellular data in the background (my current setting: enabled)
Settings -> Apps -> Whatsapp -> Data usage -> Unrestricted data usage: Allow unrestricted data access when Data Saver is on (my current setting: disabled)

do not impact the described problem, i.e. if I disable the former and/or enable the latter, the problem persists. In addition, the problem is independent of the type of internet connection, whether WIFI or Cellular (e.g. 3G), and if a Whatsapp Web session is running or not. Also, I could not find the described option in one of the other posts

Settings -> Cellular networks -> Access Point Names -> Full Internet SRR

Specifically, I could not find the Full Internet SRR option. Instead, when I started using FP2, I had to create a new access point name (APN) in order to establish an internet connection at all.

Note that the two apps Signal (version 4.40.4) and Telegram (version 5.7.1) do not show this behavior. The two settings above are the same for these two apps (i.e. the former is enabled and the latter disabled).

Any help is very appreciated!
Kind regards,
Chris

Probably WhatsApp is battery optimized. Check in settings, apps for WhatsApp n entry battery. I’m not sure of the correct wording, i’m on LOS

3 Likes

Thank you so much! That worked.

Settings -> Battery -> [3 dots] Battery optimization -> Show All apps -> Select Whatsapp and change to Don't optimize
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.