English

Whatsapp backup can't be restored in FP Open OS

Hi there,

I have a new FP2 and installed the FP Open OS on it. Now that I wanted to restore my WhatsApp backup, it failed. As I don’t know that much about the whole developing thing, I thought I’d ask here for help.
Maybe I’ll describe what I did until now and what’s the problem:

  • On my old Android device, I made a local backup of my whatsapp data and copied all existing files from my old phone to my computer with Android File Transfer.
  • I downloaded the WhatsApp apk on my FP2.
  • I copied the whole Whatsapp file from my computer to the FP2. (after that didn’t work, I also copied only the newest msgstore.db.crypt12-file into the WhatsApp/Databases folder on my phone.
  • I installed Whatsapp and verified my number
  • Whatsapp asks me if I want to restore a backup and it also says it found one, but the size of the backup file is 0 KB and after I click on Restore, there are only the group chats in which I am member, but without messages in them.

Does anybody have any ideas on that?
Could the problem exist because of the Custom ROM? Should I maybe try to hide the root with RootCloak like Paula Kreuzer suggests here ✏ How to install any app on FP Open OS (for beginners and experts) ?
I also found these instructions, but I’m not sure if I should try this: https://forum.xda-developers.com/general/general/whatsapp-restore-encrypted-backup-t3462246
And I just noticed there are two msgstore.db.crypt12-files in my Databases-folder (msgstore.db.crypt12 and msgstore.db_1.crypt12), could that be a problem?

I would be quite happy about an answer. thanks in advance!

2 Likes

Root shouldn’t interfere with WhatsApp. I run FPOOS, and WhatsApp runs fine, including a database file that’s been inside four different phones. You also copied over the correct file. The group chats appear because they’re stored on the server, so your phone just downloads them from there.

First, let’s be sure the copying process worked properly: when you look at the database file in your file manager, is the file bigger than 0kB?

Okay, thanks!
Yes, it is. It’s around 16 MB.

Thanks for sharining your views on it. This will surely help me a lot!!

Well, that’s a good sign at least. I’d try clearing out the Databases folder and then re-copying the database file. It looks like it created a new one when it couldn’t restore from your backup.

I remember helping someone out years ago with the method you linked, and it did work - so it’s definitely something to try. It doesn’t damage anything if it doesn’t work, at least.

Other than that, we’re largely in the dark. WhatsApp is proprietary, so the inner workings of their local message storage is a bit of a mystery.

@hannahz Did you find a solution? Maybe actually by copying the mysterious key file from \data\data\com.whatsapp\files\ ?
… which I do not have anymore :frowning:

Thanks for your response!
webaschtl

I had the same problem on FP Open 19.11.2-sibon-24df0be9 with Whatsapp 2.20.193.9

In my case, I also changed my phone number, so the restore problem could come from there, too.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.