What does this system ui message mean?

Hi @Wollerik,

I have not had the issue happen since December, when I posted about it here. I also scanned my phone for malware, but none was found. I’ll try to paste my reply from support. I closed the ticket since I could not recreate the issue beyond the two times it happened in December to see if their suggestions helped. However, I did confirm to them that I had the latest Fairphone build. I, like you, am using the FP charger setup.

<*****> (Fairphone)

Jan 5, 2023, 12:28 GMT+1

Dear Sorcha,

My name is <*****> from the support team, nice to e-meet you :slight_smile:
Thank you for supporting Fairphone and for reaching out.

Let’s make sure that you are running the latest Fairphone OS. To check your build number follow the steps below:

Go to Settings → About your phone → Build number
Check if your Fairphone 4 has Fairphone OS v.175 (Build number FP4.FP4I.A.175.20221207). Some network carriers might differentiate for one digit.
If the build number on your device is different, please, follow our support article to Update to the latest software.

Additionally, if this happens again, make sure your charger and/or USB-C cable are not failing. Just try a couple of different ones on your Fairphone. Try also to charge the phone using a PC or a laptop.

You can find further instructions and more information on compatible charging equipment for the Fairphone 4 in this support article. Please, make sure to check it and follow the suggestions before proceeding with this message.

If none of the chargers/cables you tried is working, and they are compatible, please take some pictures showing:

Both USB-A and USB-C connectors for every cable that you tried.
The label clearly showing the technical data for every charger that you tried.

Should the issue still be there, please go to the next step.

Test your device
If after following the previous steps your phone turns on, please run this test. Otherwise you can of course skip it:

Open the phone app.
Dial ##2886## in the same way you enter a phone number to make a phone call. Once the last character is introduced, the Service Menu appears.
Select Manu
Tap on USB/Charger. This test is for testing the USB-C connection and charge. If the USB cable and the right charging current are detected, the screen will display OK. Current can be OK (quick charge) or NOK (slow charge), based on the type of charger used. Keep in mind that slow charge refers to the use of a charger of 5V and minimum 1A. You can check this support article for more information.
Take a screenshot(s) of what you see on the screen.
If you want to stop the test, tap on FAIL or PASS. It does not matter which one you select.
Send the screenshot to me as a reply to this message.

Once you performed all the previous steps, please come back to me with your feedback and the requested screenshots/pictures so that we can help you further.

Thank you in advance for your time and collaboration, I will wait for your reply.

Have a lovely day and take care!

Kind regards,

<*****> | Customer Support Agent

☆ Fairphone || Change is in your hands ☆

✆ Phone: <*****>
Monday - Friday 10:00 - 16:00 (CEST)


Hello everyone, I got this exact same system-ui message. This happened at 5.00 in the morning with a very loud noise. It startled the hell out of me. I put the phone on the charger at night. The phone is automatically set to do not disturb when it is charging, so for something to get through it must be really bad, right? Like a natural disaster or something. On the one hand I am glad it was NOT a natural disaster, on the other hand I am seriously annoyed that this stupid message is somehow set to overrule the do-not-disturb-status.

Right now I do not really care why I get this message, I just want it to be QUIET. I have tried to turn of the warning sound via Settings > Notifications > App settings but “System UI” is not listed there.

If I search for “System UI” in Settings I do find the app. If then has a setting with the rather obscure name “notification_usbntc_temp”. I wondered if this might be the culprit! However, it has no sound icon next to it. Also, this setting is greyed out, meaning I cannot adjust it.

Unsure what to do next, except hope that this was just a fluke and won’t happen again.

Welcome to the community forum IrisHRA.

I would recommend you to inform official Fairphone support. They would be able to pass the information on to developers. Please make sure you quote this topic if you contact them.

How to: #contactsupport

P.S. It might be useful for you to know, that charging at night is not recommended, since this will likely charge the battery to 100% or close. It is recommended to keep your battery charge level between 20% and 80% whenever possible. The same goes for all Li-based batteries.

1 Like

I also got this message on my FP4. The battery was down to 33% around last night, so I put it on the charger overnight. When I saw the message this morning it was already 10 hours old, so it probably appeared during charging or shortly after.

I agree that the punctuation has a really amateur feel about it: no space after the comma, and an exclamation mark at the end. This is definitely not conforming to Android UI guidelines. Worse, it’s entirely unclear what the message is trying to tell you.

Given that this thread is literally the only hit in search engines, I bet it’s coming from a Fairphone customization. My phone is not rooted and I’m not running any shady software on it.

I tried to find the message in the Fairphone OS source code, but failed. The website only has a tarball of GPL sources of third-party libraries, which is outdated (A.067 release) and doesn’t contain the message. There’s also the Linux kernel source, but I didn’t check there because it’s unlikely that a UI message would be found there. The rest of the modifications that Fairphone made to the Android OS are apparently not open source?!

This remains a mystery that probably only FP developers can clear up.


Yes, Fairphone OS is not open source and I agree this message is very likely FP in origin.

I presume you’re running the latest version of FPOS (currently FP4.SP28.B.065.20230420).

The few appeals to official support seem not to have obtained any satisfying result. It’s a bit frustrating seeing how easy, I would have thought, it would be for them to check it in their source code.

My five cents’ worth:

  • don’t leave the phone charging all night, you’ll be kinder to your battery and the message won’t wake you up
  • the message in itself seems harmless, if meaningless and likely comes from FP, not some malware.
1 Like

During the day, charging is difficult, since I carry it around in my pocket. Software should be able to stop charging at a specified point, shouldn’t it?

I’m not annoyed by the message, but by the alarm, which sounds at high volume in the middle of the night. How can I prevent this type of alarms? I don’t use the Do Not Disturb mode just for fun…

It’s also strange that this warning doesn’t appear every day (night, actually), which I would expect when I do the same thing every day.

Being woken up by an unwanted alarm three times in the last two weeks is no fun at all! I think it started after the last software update, a few weeks ago. (5 May, security update)

I agree, but this requires the function to be either built into the OS or supplied by an app with root access. There’s a lot of discussion in the forum. Have you read this topic from the top?

To take this further, you can contact official Fairphone support.

Leaving the phone charging all night is not recommended (also much discussed). If you need to leave it on at night but not receive calls, put it in Airplane mode.

1 Like

Ok, let’s skip the good advice on battery usage.

I have found the source of this annoying alarm!

I was triggered by a post on this subject from a Samsung Galaxy user.

On my FP4, I went to Settings → Notifications → App Settings, here you get a list of apps, but system-ui is not in it,… but… in the top corner on the right, there are three dots: tap on them and you’ll get 1 option: show system. Nothing seems to have changed,… but, if you scroll down, System-UI is in the list! Tap it! Now you can see the notifications that are switched on and those that are switched off. If you tap Battery, you can choose to make it Standard, or to make it silent. I’m a bit confused, because my current settings tell it to respect my do not disturb settings. Last night, it woke me at 5 AM, though. Not with the standard sound (in my case Fermium), but with Cesium, and not at amoderate volume, but at max volume, or so it appeared in the dark of the night.

I hope this helps!


As for the notification itself. I doubt that it is intended to educate the phone user to pull out the charger at 80% (for which no notification can be set, afaik). I think the system has stopped the charging process, since the battery was full (in my case) and it is issuing a warning that the charging process will not start again automatically. You will have to pull out the charger and put it back in for the charging to start again. So this alarm does NOT mean that you have to wake up your family and have to evacuate the room, building, street or city because of an imminent danger coming from your phone.

1 Like

Thanks so much, Richard! I’ve just changed these settings based on your walkthrough, and hopefully that take care of the alarm. It most recently sounded for me early Monday morning, and while my phone was on Do Not Disturb. I also noticed that the alarm ringtone is not one I’d chosen Mt’s. I think you’re onto something regarding it happening when the battery reaches 100 percent. I usually unplug my phone when it gets around 80, but, the last time I heard this alarm, I’d accidentally fallen asleep before unplugging the phone.

1 Like

No, it appears not to be the feature, but a bug after all. Last night I was brutally woken up at 4:12 AM by Cesium and this warning. The warning settings had not changed: silent warnings and no ignoring the do not disturb mode. What I noticed, was that I had received the silent warning much more often since my last message, like every night (no sound!). So, it is SOMETIMES so that the alarm sounds, regardless of the settings. This suggests that the warning can be triggered in multiple ways and that one of these ways, the user settings are ignored or not used at all, like in hard coded. I had the call reopened and switched battery warnings off in the system-ui settings. I prefer not to switch off warnings, because of the obvious function of a warning, but, in this hot early Summer, it is difficult to catch any sleep again, after being woken up by an alarm with the intensity of a fire alarm.

1 Like

I’ve seen the message a few times, but last night at 06:30 is the first time I’ve gotten the full volume default alarm that continues until dismissed. The actual alarm screen had text which I didn’t quite read in my sleep, but something regarding temperature and an error id in the form “height_usb_ntc_xxx”. The phone had been plugged in 5 hours at that point with the cable securely connected. I speculate the alarm may have come 10-20 minutes after the System UI notification, based on when I remember being woken.

Also just found this related thread with a screenshot showing the alarm message with even more impressive English, although missing the error id I saw: Error Message - "Height USB NTC Temperature"

Hello everybody,
This also happen with my FP4. I bought it last october and this message showed up 3 times since then. And the message comes with an unbelievable loud and annoying alarm sound which scare myself and my wife out of bed everytime. She is very very jumpy and everytime she almost gets a heartattack.
But it is impossible to turn the sound of.
Yes of course I started to not load the phone at night, but sometimes I just forget it and have to do so, otherwise I do not have a morning alert for wake up.
If anyone has a solution on this, it would be very appreciated.
I use the official fast charge cable and adapter from fairphone. I purchased it together with the phone.

I’d like to chime in to keep some momentum on this topic. I recently got a Fairphone 4 and this week also experienced this notification (only once so far). It woke me up at 5 in the morning by this incredibly loud notification - despite the “Do not disturb” mode being active! As others already mentioned, not the best experience. Thus I’d be quite grateful for this to be fixed (as I unfortunately need to rely on charging the phone over night, suboptimal for the battery as it is).

Hi everyone,

I just had the exact same issue last night ( at 04:00) and neither me nor my wife were very happy that it happened.

My phone also was in “do not disturb” mode and on the charger.

I just made a support ticket, hoping it helps FairPhone to find a cause and solution.

All the best for now,


I have had this happen too a few times, it usually happens when I charge my phone with my rather low-quality USB powerbank. The powerbank I use gets very warm when I plug a cable into it for a while, so maybe the error message is a warning that notifies the user that some thermal sensor that’s part of OTG capabilities(?) has crossed a threshold and that the phone stopped charging to prevent overheating? It only happens on my powerbank, not on my wall adapter or any other power source.

I have had this message appear once or twice about two months ago too. Weirdly it hasn’t happened since, so I didn’t think much about it until I stumbled across this thread. I will advise if the message appears again and pay closer attention to the exact circumstances.

This happened to me at 1:30 am with the loud alarm while in No Disturb. Please do something FP.

Phone, cable and charger were all at room temperature.

1 Like

If you want FP to do something, please contactsupport and give them the details mentioned above and link to this forum thread.

I did exactly that and their solution is, surprise, surprise, to buy a new charger and cable. Even when they work perfectly.