English

Well, I screwed it up (internal user storage completely wiped)

Hey guys!

Seems that even angels need help sometimes. Since 3 months, about every two days or so my FP2 tells me that my internal storage is full (completely - 29,12/29,12 GB used). I still don’t know how this happens and which app is responsible, but what I know is that out of nowhere a folder called “Thumbnails” frequently appears in my DCIM folder. It contains low quality thumbnails from all the pictures which are on my phone (as far as I can tell), which already is stupid since I have the real pictures in eg DCIM/OpenCamera. But there are also two enormous files called “thumbnail…”, each being around 8GB. I don’t know anything about them except that it’s not actually possible for a file on the internal storage to be larger than 4GB, because of FAT32 limits.
While this was super annoying, I could just delete the folder and a couple of minutes later I have around 2-3GB free storage again (which is also weird, but that’s not my main problem at the moment).

Just now, I again was in the completely-full-situation while I tried downloading a file, and Signal was already continuously crashing because it couldn’t store incoming messages anywhere. So I deleted my Signal backup and the Tempates folder. Then Amaze started crashing all the time. I thought “well, mabe because the battery was almost empty and it couldn’t handle all this with power saving mode and I just plugged it in 2mins ago, so lets just reboot” which I did. And now, my entire storage/emulated/0 is gone. There are no folders there anymore. I thought that Amaze was just uncapable of displaying them, but also my gallery app/VLC showed nothing/shortcuts to non-existing files.
I immediately shut down my phone to prevent data from getting overwritten, but honestly, I don’t know what to do now. Every “Professional Data Recovery Pro 2018 Rescue Extreme Free Edition”-Software that I used earlier for USB-sticks etc was completely useless, and of course I don’t have a backup, because I’m always too lazy to make one. :man_facepalming:

If someone could recommend any program that could recover my files, I’d be very happy.

Did you never learn:

  1. Make a Backup!
  2. Make a Backup!
  3. Make a f***ing Backup!

Die Jugend von heute…

Sorry, can’t help you: I can only recommend the next “Professional Data Recovery Pro 2018 Rescue Extreme Free Edition” Tool. I used this one here to save my brother’s HDD: https://www.stellarinfo.com/de/

1 Like

Luckily you have all your important data safely stored in your G%§$e cloud right?

Sorry, too soon? :wink:

2 Likes

Internal storage is EXT4, so no stupid limits.

The issue is not with the tool, but with the way the internal storage is connected to the PC. I found a thread in XDA which explains how to dump your data partition as a raw file, so that you have a thing to begin with, and apply PhotoRec (open source) or Recuva (closed source) or whathever file recovery software. Personally, I’d skip all the “root your device” thing and do it right in TWRP, which is minimal, already rooted, and can be adb shell-ed into.

6 Likes

Just to confirm this is no glitch of some sort …

  • If the phone is connected via USB to a computer, disconnect it.
    (Because the next step will be booting TWRP, TWRP offers MTP mode, and as far as I understand MTP involves an index of files which might get updated and has to be written somewhere, so I’m rather cautious here.)
  • Boot TWRP by keeping Volume + pressed while starting the phone until the TWRP splash screen is shown.
    If you are using Fairphone OS 18.04.1 or earlier, TWRP will not be installed as recovery, in this case boot TWRP without flashing it.
  • Choose Advanced - File Manager and have a look around (for me Internal Storage is in the “sdcard” folder, but I don’t know whether that depends on the OS or TWRP version).
4 Likes

What the actual hell, my entire SD-card got deleted too!!
How is this even possible!?

@paulakreuzer F. you!!* :joy:

So, since the PhotoRec and StellarRecovery both don’t see my phone, since it’s not mounted as a disk, but as something else (the icon looks like a MP3-player; why can’t this be standardised goddammit), I tried mounting with TWRP and right now I’m scanning the external SD with PhotoRec, which at least seems to find something. After that I’m going to try to mount the internal storage and recover the files from there.

*Funny you

1 Like

Did you choose to let the card be incorporated into Internal Storage, or did you leave it as external storage?

If the card was a part of Internal Storage, and Internal Storage got corrupted, than the data on the card could seem gone. With this setup, a failure of the card could even cause Internal Storage to get corrupted in the first place.

It is standardized, just not in the way you want in this very moment :wink: .

Nope, it’s external storage. And I was just able to recover 10.1GBof data from it (including this file, so at least my most important data is safe now :joy:)

1 Like

Data integrity on SD cards is terrible unless you go for industrial grade.

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.