VoLTE on Fairphone 4 with /e/ with Vodafone germany

Hello /e/ users!
I’m a happy /e/ user but cannot use the internet (on 4g/5g) while making phonecalls. Vodafone germany sells FP4s, so the device should be supporting VoLTE. The customersupport says, it’s enabled. # #4636 ## says it’s activated.
Do you have any Idea how to make it work?
I’ve tried it on /e/ Forum but got no answer.

Thank you

Can you upload a Screenshot of the screen under the test number? On my FP3 it looks the same for both SIM although VoLTE is only enabled for one SIM.
In general you can enable VoLTE in thesettings under Network and the corresponding SIM. Is it really enabled there?

Which customer support stated its enabled, Vodafone? Do they mean enabled at their end for you to use or really enabled on the phone? How old is your SIM card, have rhey considered to replace it?

1 Like

Thank you for your reply. The vodafone customer support stated ist’s enabled - yes. It works with another phone also.
Well, I can enable VoWiFi in settings - i thought both use the ims service, but the screenshot says ims not registered… probably that’s why? It seems to be an /e/-issue, right?
The simcard is 1y old.

Thank you for helping

So there is no setting to en-/disable VoLTE?

Its a FP3 Screenshot but bis should be similar I guess…

So if you dont have a setting for VoLTE maybe you can confirm in the e/ forum if that is a bug?

Does VoWifi work? Are there further settings on when to use it?

Maybe someone using the FP4 with stock Rom or any other Custom Rom can confirm it works with Vodafone Germany? Did Vodafone confirm it should be working with the FP4? Have it enabled at their end and working on other devices does not necessarily mean its compatible/working on all devices.

I understand you have 5G enabled? Maybe turn this off and see if it changes something?

Reg the IMS Status: as long as you are connected to a Wifi network, VoLTE is not used and will show as not available. Did you check when Wifi is off? However yes I think IMS should still show as registered.

So if you can somehow confirm it should work on the FP4 in general and is not a e/ bug, I would try a new SIM, even if 1 year is not that old.

Or try if possible a SIM of another mobile provider, best Telekom as O2 has def VoLTE issues in Germany…

Works here.
iode 3.0, FP4, vodafone

Can you really use the internet while having a phone call or is the option just available, but not functional? I read a lot regarding problems with VoLTE and LineageOS based ROMs and can’t use it on stock LineageOS. So if iode has a fix, it could be applied to LineageOS and /e/os.

My settings are as in my screenshots.

I did a test now.

I gave myself a call to another phone. speakers on on both sides. I could hear myself.
And in parallel i could surf in internet. check mails, etc…
both works fine in parallel. WLAN off, only 4G data and phone connection
→ If you mean this. I’m not sure…

iodé did fix nothing here. They’re using pure LOS 19.1 Android 12

Thank you for testing! On LineageOS 18, it doesn’t work (for me). Since this is the base for the current /e/os, that will likely be the answer to the opening question.

OK, strange
It worked also for me on iodé 2.4 which is LOS 18, A11

thank you so much for your help!
actually I’ve used my sim in another phone (shiftphone 6mq) and it worked there.
I was curious because there are neither 4g+ nor volte settings but VoWiFi. Afaik both use the same technology (IMS), so I thought both might be the same. I’ve tried the vodafone card of my wife, which didn’t work as well. Could an esim be a sollution?
I’m tring to find a simcard of some other provider now.

Switching to any other service 4g/gsm/5g or whatever didn’t do anything :frowning:

I’m glad so many people help with this issue!

1 Like

I doubt an eSIM from Vodafone will make any difference, in case the root cause is not the SIM itself and as you testet another SIM already from Vodafone, I doubt its the SIM. So in my eyes there is either some issue with e/OS (and unofficial LOS), because I would say you should have 2 seperate settings normally, or an issue with your FP4 in general.


I’ve now tried another sim from another network (d1) ims still not registered, and as we all expected, no other menus show up suddenly. Im curious because the screenshots would show almost the same information.

I’m filing a bugreport asap
thank you very much

1 Like

I’m on the latest regular Fairphone 4 OS and have a SIMon SIM (Vodafone Germany) - I can only see a Wi-Fi Calling option, no settings for VoLTE or 4G Calling functionality.

Simon FAQ say WiFi Calling bieten wir leider nicht an. Dafür kannst du aber gerne VoLTE nutzen. Easy!

So when you enable Wifi calling, do you have VoLTE? Can you call *#*#4636#*#* and check the phone status menu via the 3 dots IMS registering status?


I had VoWiFi on all the time, unfortunately it didn’t change the ims registration status :frowning:

I don’t know which FAQ you red, but VoWiFi and VoLTE should work according to: Info about Fairphone FP4 - FP4

Bug reported: VoWiFi/VoLTE not working on Fairphone 4 with /e/ (on Vodafone Germany and other networks) (#5452) · Issues · e / Backlog · GitLab

But still, probably you could still help finding a sollution.

I can confirm following:

  1. VoLTE works for me on FP4 with vodafone
  2. VoWiFi works NOT for me. I can configure it, but it has no impact. Whatever I choose and configure it will always use mobile to take calls. Never WiFi.

Do you mean it doesn’t automatically switch if you have a poor LTE connection or you just can’t get Wi-Fi calling to work.

My undestanding is that LTE is the deafult, Wi-Fi a back up, so unlikley to be used unless as in my situation there is no LTE.